Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 52327 - Vim-6.2-r8 and -r9 Segfault when quiting
Summary: Vim-6.2-r8 and -r9 Segfault when quiting
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: PPC64 Linux
: Normal minor (vote)
Assignee: ppc64 architecture team
Depends on:
Reported: 2004-05-29 03:25 UTC by Philippe Trottier (RETIRED)
Modified: 2004-07-13 20:21 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Philippe Trottier (RETIRED) gentoo-dev 2004-05-29 03:25:27 UTC
I tried to compile vim-6.2-r and -r9 using ebuild ... merge

the result produces a working vi/vim in every restpect except that :q :q! will terminate in a segfault. otherwize works beautifully.

$vi /etc/a 
Vim: Caught deadly signal SEGV
Vim: Finished.
Segmentation fault

Tried compiling with gcc-3.3.3-r3 and 3.3.3_pre20040215
both the same result... my only gues is glibc or vim itself ...
Comment 1 Tom Gall (RETIRED) gentoo-dev 2004-05-29 09:16:28 UTC
actually this goes in the ppc64 bucket .. note the Hardware setting :-)
Comment 2 Tom Gall (RETIRED) gentoo-dev 2004-05-29 19:58:01 UTC
I've done a little bit of digging this evening.  looks like this is dieing in glibc land


perhaps our somewhat crustly glibc is to blame?  hmmm!
Comment 3 Philippe Trottier (RETIRED) gentoo-dev 2004-05-30 08:06:11 UTC
Bug went away with glibc-2.3.3-pre20040529
no more segfault.
Comment 4 Philippe Trottier (RETIRED) gentoo-dev 2004-05-30 08:06:56 UTC
Fixed thanks to glibc-20040529
Comment 5 Tom Gall (RETIRED) gentoo-dev 2004-05-31 10:37:02 UTC
this DID NOT go away for me with glibc-20040529 :-/  course this is also with gcc 3.4 and binutils 2.15
Comment 6 Philippe Trottier (RETIRED) gentoo-dev 2004-05-31 14:51:38 UTC
Have you tried to recompile vim-core and vim ?
Comment 7 Tom Gall (RETIRED) gentoo-dev 2004-06-02 19:25:54 UTC
-r9 with 3.4 is aok with this ... prior I was using -r8

I think our stategy is 2004.2 and 3.4 based...  what we have now is beta material after all....
Comment 8 Tom Gall (RETIRED) gentoo-dev 2004-06-02 19:26:22 UTC
so upgraded to 3.4 .. eh?