Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 522586 - sys-libs/ncurses-5.9-r3 - cc1: warning: include location "/usr/include/ncursesw" is unsafe for cross-compilation [-Wpoison-system-directories]
Summary: sys-libs/ncurses-5.9-r3 - cc1: warning: include location "/usr/include/ncurse...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo's Team for Core System packages
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-09-11 15:07 UTC by Joakim Tjernlund
Modified: 2015-08-12 08:20 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Joakim Tjernlund 2014-09-11 15:07:44 UTC
cross building ncurses with USE unicode generates alot of
cc1: warning: include location "/usr/include/ncursesw" is unsafe for cross-compilation [-Wpoison-system-directories]

This is because unicode enforces:
 use unicode && do_configure widec --enable-widec --includedir="${EPREFIX}"/usr/include/ncursesw
and ncurses configure adds any non standard includedir till CPPFLAGS.

This seems very wrong and adding a
	#Remove ${includedir} from CPPFLAGS, need for cross compile
	sed -i 's/-I\\${includedir}//g' configure || die "sed CPPFLAGS"
to src_prepare removes the complaint and ncurses still builds

Reproducible: Always
Comment 1 Joakim Tjernlund 2014-09-22 16:11:19 UTC
Upstream just removed -I\\${includedir} from CPPFLAGS too:

http://ncurses.scripts.mit.edu/?p=ncurses.git;a=commitdiff;h=9ee3995474454b7d956885e0fe5c8cac2ae25d42
Comment 2 James Le Cuirot gentoo-dev 2014-09-22 16:22:29 UTC
Thanks for reporting this upstream. It didn't break anything for me but the warning is always unsettling as it often does lead to breakages in other packages. I guess you can close this now.
Comment 3 Joakim Tjernlund 2014-09-22 19:37:59 UTC
(In reply to James Le Cuirot from comment #2)
> Thanks for reporting this upstream. It didn't break anything for me but the
> warning is always unsettling as it often does lead to breakages in other
> packages. I guess you can close this now.

Cant close because it isn't fixed in Gentoo and upstream won't
relase anything soon. He "releasing" patch sets every week but no
real release until he is "done". Done appears to be quite a long
time ahead. He thinks dists should just pick his patch sets meanwhile
which I don't think Gentoo does(does any dist?).

Until this happens, the little fix I listed here should be applied.
Also, he thinks keeping unicode is /usr/include/nursesw is a bad idea.
Comment 4 Joakim Tjernlund 2014-10-23 18:56:48 UTC
ping @base
Comment 5 Joakim Tjernlund 2015-03-03 09:00:08 UTC
Mike, I see you are fixing python cross compile w.r.t ncursesw.
Perhaps you can address nucurses too?