Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 522238 - app-misc/megasync - mega synchronization app(s)
Summary: app-misc/megasync - mega synchronization app(s)
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal enhancement with 8 votes (vote)
Assignee: Default Assignee for New Packages
URL: https://mega.co.nz/#sync
Whiteboard:
Keywords:
: 719050 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-09-05 23:27 UTC by Tales Mendonca
Modified: 2021-05-09 11:01 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
v2.9.1 failed to compile. (build.log,174.61 KB, text/plain)
2016-04-30 03:50 UTC, Alexandre
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tales Mendonca 2014-09-05 23:27:42 UTC
I could not find the overlay, but I saw that in the MEGA server, there are binaries for various Linux distro.

Client: https://mega.co.nz/linux/MEGAsync/
Comment 1 Tales Mendonca 2014-09-12 03:41:38 UTC
the megatools is another application, this is official and I posted there for linux, just need to create an ebuild for it. The megasync is also official. If there is a simple graphical tool to facilitate, for I will use a more complicated textual?
Comment 3 Tales Mendonca 2014-09-26 21:10:53 UTC
Thank you, I will test right now;)
Comment 4 Alexandre 2014-09-26 21:47:36 UTC
Hi,

Thank you for the input but version 1.0.30 is out now.
Comment 5 miklosh 2014-09-26 21:50:44 UTC
Alexandre, just rename ebuild to megasync-1.0.30.ebuild =)
Comment 6 Alexandre 2014-09-26 22:08:12 UTC
I did! I was just noticing! :-D

Thanks!
Comment 7 Alexandre 2014-09-27 20:20:38 UTC
v1.0.31 is out.
Comment 8 Tales Mendonca 2014-09-27 20:31:58 UTC
Solution:

# cd /var/lib/layman/jorgicio-gentoo/net-misc/megasync
# mv megasync-1.0.29.ebuild megasync-1.0.31.ebuild
# rm Manifest
# ebuild megasync-1.0.31.ebuild manifest
# layman -S
# emerge -av net-misc/megasync
Comment 9 Alexandre 2016-03-10 20:27:31 UTC
Source code available at:

https://github.com/meganz/MEGAsync

An Arch Linux PKGBUILD as reference:

http://pastebin.com/Cvaxq0fp
Comment 10 Alexandre 2016-04-23 19:41:00 UTC
Please the ebuild may be updated to have libressl support?

I do not know how to proper update it but I tested against libressl removing openssl from RDEPEND and with libressl already installed megasync compiled and is working.

https://wiki.gentoo.org/wiki/Project:LibreSSL

Thanks!
Comment 11 Alexandre 2016-04-30 03:50:34 UTC
Created attachment 432620 [details]
v2.9.1 failed to compile.

Failed to compile the v2.9.1:

control/HTTPServer.cpp: In member function ‘void HTTPServer::processRequest(QAbstractSocket*, HTTPRequest)’:
control/HTTPServer.cpp:370:51: error: ‘class mega::MegaApi’ has no member named ‘createForeignFolderNode’
                         MegaNode *node = megaApi->createForeignFolderNode(h, name.toUtf8().constData(), p,
                                                   ^
control/HTTPServer.cpp:383:55: error: ‘class mega::MegaApi’ has no member named ‘createForeignFileNode’
                             MegaNode *node = megaApi->createForeignFileNode(h, key.toUtf8().constData(),
                                                       ^
Makefile:4088: recipe for target 'HTTPServer.o' failed
Comment 12 Alexandre 2016-06-28 20:56:46 UTC
MEGAsync-2.9.5 is out but still fail to compile using a renamed ebuild.

Compiling following their README works:

git clone https://github.com/meganz/MEGAsync.git
cd MEGAsync
git submodule update --init --recursive
cd src
./configure
qmake MEGA.pro
lrelease MEGASync/MEGASync.pro
make

When running ./configure locally it download and compile specific versions of curl, c-ares, libuv, and zlib, which are older than we have on ~amd64.

I do not know how to properly update the ebuild to reflect those changes.

Thanks!
Comment 13 Alexandre 2016-06-28 21:09:14 UTC
Sorry, I
Comment 14 Alexandre 2016-06-28 21:09:46 UTC
Sorry, I forgot it is on the overlay now.
Comment 15 Jonas Stein gentoo-dev 2020-04-24 19:07:03 UTC
*** Bug 719050 has been marked as a duplicate of this bug. ***
Comment 16 urcindalo 2020-04-27 08:38:13 UTC
I just got here through a closed bug: https://bugs.gentoo.org/719050

Apparently, my bug is a duplicate of the bug here, but really it is not since the MEGA cloud still does not have an ebuid in the official portage tree.

So far, I was using the ebuild in the 4nykey overlay. However, this overlay does not sync anymore whenever you "emerge --sync", failing and preventing the whole sync'ing process from completing. It is really frustrating having to manually delete the overlay, then "emerge --sync" and, later on, add the overlay back.

So, I tried the ssnb overlay, but the latest ebuild in it (4.3.1-r1) can't find a java file during config, even though I have either icedtea-bin or openjdek-bin installed (I tried both).

Finally, what I did was to copy the latest needed ebuilds from the 4nykey overlay to my local one and remove 4nykey.

This is merely a workaround, because if megasync gets updated I'll miss it. So, is there any possibility of a) adding MEGA to the portage tree (ideal) or b) at least correct the issues in the 4nykey overlay when sync'ing or find the bug in the ssnb overlay ebuild?