Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 522204 - sys-process/runit-2.1.1 - runsvdir/all/getty-* scripts need to set the process group for shell to work properly
Summary: sys-process/runit-2.1.1 - runsvdir/all/getty-* scripts need to set the proces...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: William Hubbs
URL:
Whiteboard:
Keywords: PATCH
Depends on:
Blocks:
 
Reported: 2014-09-05 14:53 UTC by Anthony Parsons
Modified: 2014-11-13 19:36 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Make each agetty process have its own process group (getty.diff,252 bytes, patch)
2014-09-05 14:53 UTC, Anthony Parsons
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Anthony Parsons 2014-09-05 14:53:17 UTC
Created attachment 384236 [details, diff]
Make each agetty process have its own process group

With Gentoo's current runit scripts, logging in on a VT makes bash complain about "no job control in this shell". This stops things like ctrl+c and ctrl+z from working, which is pretty annoying.

The bash manpage is vague about this, but I figured out that the root cause is that bash wants its own process group, and runsv doesn't give it one by default.

It's a trivial fix, here's a patch.
Comment 1 William Hubbs gentoo-dev 2014-11-13 19:36:09 UTC
This is fixed in 2.1.2.