Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 52218 - Java applications fail to start after upgrading to Gnome2.6 with accessibility enabled
Summary: Java applications fail to start after upgrading to Gnome2.6 with accessibilit...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gnome Accessibility (OBSOLETE)
Depends on:
Reported: 2004-05-27 15:16 UTC by Jose Gonzalez Gomez
Modified: 2004-09-06 23:46 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Jose Gonzalez Gomez 2004-05-27 15:16:41 UTC
After upgrading to Gnome 2.6 with the accessibility USE flag enabled, graphical Java applications refused to start, complaining about Java Assistive Technology problems.

Reproducible: Always
Steps to Reproduce:
1. Upgrade to Gnome 2.6, with USE including accessibility
2. Start any graphical Java application
3. Search for cover so the bang doesn't catch you unprotected

Actual Results:  
All the graphical Java applications refused to start, complaining about problems
with the Java Assistive Technology

Here is the output from JXplorer:

Thu May 27 23:56:47 CEST 2004: running java version 1.4.2_04
Exception in thread "main" java.awt.AWTError: Assistive Technology not found:
        at java.awt.Toolkit.loadAssistiveTechnologies(
        at java.awt.Toolkit.getDefaultToolkit(
        at java.awt.Window.getToolkit(
        at java.awt.Window.init(
        at java.awt.Window.<init>(
        at java.awt.Frame.<init>(
        at java.awt.Frame.<init>(
        at javax.swing.JFrame.<init>(

Expected Results:  
Graphical Java applications should start without any problem

jgonzalez@bit tools $ emerge info
Portage 2.0.50-r6 (default-x86-1.4, gcc-3.3.2, glibc-2.3.2-r9, 2.4.22-gentoo-r5)
System uname: 2.4.22-gentoo-r5 i686 AMD Athlon(TM) XP 2000+
Gentoo Base System version 1.4.10
Autoconf: sys-devel/autoconf-2.58-r1
Automake: sys-devel/automake-1.8.3
CFLAGS="-march=athlon-xp -O3 -pipe -fomit-frame-pointer -mmmx -m3dnow"
CONFIG_PROTECT="/etc /etc/tomcat /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config
/usr/kde/3/share/config /usr/lib/mozilla/defaults/pref /usr/share/config
/usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/
/usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/
/usr/share/texmf/xdvi/ /var/lib/jboss /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-march=athlon-xp -O3 -pipe -fomit-frame-pointer -mmmx -m3dnow"
FEATURES="autoaddcvs ccache sandbox"
USE="3dnow X accessibility acpi alsa apm avi berkdb bonobo cdr cjk cups doc dvd
dvdr encode esd foomaticdb freetype gdbm gif gnome gpm gstreamer gtk gtk2
gtkhtml guile hbci imlib java jikes jpeg junit kerberos ldap libg++ libwww mad
mikmod mmx mng motif mozcalendar mozilla mozsvg mpeg ncurses nls ofx oggvorbis
openal opengl oss pam pdflib perl png python quicktime readline samba sdl slang
spell ssl svga tcltk tcpd tetex truetype x86 xml2 xmms xv zlib"

jgonzalez@bit tools $ java-config -L
[sun-jdk-] "Sun JDK" (/etc/env.d/java/20sun-jdk- *
[sun-j2sdk-1.4.1] "Sun JDK 1.4.1" (/etc/env.d/java/20sun-j2sdk-1.4.1)
[sun-jdk-1.5.0_beta1] "Sun JDK 1.5.0_beta1" (/etc/env.d/java/20sun-jdk-1.5.0_beta1)


First I tried to reemerge app-accessibility/java-access-bridge-1.3.1, with no
success (I had errors while compiling), so I emerged 
app-accessibility/java-access-bridge-1.4.2. This version of the package emerged
successfully, but Java applications still refused to start. Then I installed
java-sdk-1.5.0-beta1. This solved the problem.

Maybe the dependencies should be fixed, so <sun-jdk-1.4.99 cannot be used with
Gnome 2.6
Comment 1 Leonardo Boshell (RETIRED) gentoo-dev 2004-05-30 14:35:34 UTC
I really doubt the dependency should be >=sun-jdk-1.4.99 since, as far as I know, the java-access-bridge package was developed using the Sun JDK v1.4.

Anyhow, I don't use the Sun JDK, and I can't really test this. I'm going to have to ask that someone from the Java team take a look at this.

By the way, what were the errors with java-access-bridge-1.3.1?
Comment 2 Jose Gonzalez Gomez 2004-06-03 10:48:41 UTC
I have tried to reproduce the error, but right now java-access-bridge-1.3.1 is emerging correctly in my system. Anyway, I have reemerged gnome without accessibility support since I got the error.
Comment 3 Leonardo Boshell (RETIRED) gentoo-dev 2004-09-06 23:46:40 UTC
No more useful info here... assuming it's not reproducible. Please re-open if the problem still exists and there's new information.