Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 521972 - >=media-plugins/grilo-plugins-0.3.4 and dev-libs/gom keyword request
Summary: >=media-plugins/grilo-plugins-0.3.4 and dev-libs/gom keyword request
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Keywording (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL: https://bugzilla.gnome.org/show_bug.c...
Whiteboard:
Keywords: KEYWORDREQ
Depends on:
Blocks: 551634 gnome-3.22 613786
  Show dependency tree
 
Reported: 2014-09-02 13:39 UTC by Pacho Ramos
Modified: 2017-06-17 08:33 UTC (History)
2 users (show)

See Also:
Package list:
media-plugins/grilo-plugins-0.3.4 dev-libs/gom-0.3.2 media-video/totem-3.22.1
Runtime testing required: ---
stable-bot: sanity-check+


Attachments
media-plugins:grilo-plugins-0.2.13:20140926-001540.log (media-plugins:grilo-plugins-0.2.13:20140926-001540.log,36.84 KB, text/plain)
2014-09-26 05:26 UTC, Markus Meier
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Pacho Ramos gentoo-dev 2014-09-02 13:39:23 UTC
Due new dep in dev-libs/gom
Comment 1 Markus Meier gentoo-dev 2014-09-26 05:26:28 UTC
Created attachment 385490 [details]
media-plugins:grilo-plugins-0.2.13:20140926-001540.log

media-plugins/grilo-plugins-0.2.13 fails to build on arm:

make[3]: Entering directory '/var/tmp/portage/media-plugins/grilo-plugins-0.2.13/work/grilo-plugins-0.2.13/src/local-metadata'
/bin/sh ../../libtool  --tag=CC   --mode=compile armv5tel-softfloat-linux-gnueabi-gcc -DHAVE_CONFIG_H -I. -I../..    -pthread -I/usr/include/grilo-0.2 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/libxml2  -pthread -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include  -I/usr/include/libmediaart-1.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include  -DG_LOG_DOMAIN=\"GrlLocalMetadata\" -DLOCALEDIR=\"/usr/share/locale\" -O2 -march=armv5te -pipe  -Wall  -Wmissing-declarations -std=c99  -c -o libgrllocalmetadata_la-grl-local-metadata.lo `test -f 'grl-local-metadata.c' || echo './'`grl-local-metadata.c
libtool: compile:  armv5tel-softfloat-linux-gnueabi-gcc -DHAVE_CONFIG_H -I. -I../.. -pthread -I/usr/include/grilo-0.2 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/libxml2 -pthread -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/libmediaart-1.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -DG_LOG_DOMAIN=\"GrlLocalMetadata\" -DLOCALEDIR=\"/usr/share/locale\" -O2 -march=armv5te -pipe -Wall -Wmissing-declarations -std=c99 -c grl-local-metadata.c  -fPIC -DPIC -o .libs/libgrllocalmetadata_la-grl-local-metadata.o
grl-local-metadata.c: In function 'resolve_video':
grl-local-metadata.c:520:37: error: 'GRL_METADATA_KEY_TITLE_FROM_FILENAME' undeclared (first use in this function)
     if (grl_data_get_boolean (data, GRL_METADATA_KEY_TITLE_FROM_FILENAME)) {
                                     ^
grl-local-metadata.c:520:37: note: each undeclared identifier is reported only once for each function it appears in
grl-local-metadata.c: In function 'grl_local_metadata_source_resolve':
grl-local-metadata.c:869:51: error: 'GRL_METADATA_KEY_TITLE_FROM_FILENAME' undeclared (first use in this function)
   if (grl_data_get_boolean (GRL_DATA (rs->media), GRL_METADATA_KEY_TITLE_FROM_FILENAME))
                                                   ^
Makefile:630: recipe for target 'libgrllocalmetadata_la-grl-local-metadata.lo' failed
make[3]: *** [libgrllocalmetadata_la-grl-local-metadata.lo] Error 1
make[3]: Leaving directory '/var/tmp/portage/media-plugins/grilo-plugins-0.2.13/work/grilo-plugins-0.2.13/src/local-metadata'
Makefile:562: recipe for target 'all-recursive' failed
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory '/var/tmp/portage/media-plugins/grilo-plugins-0.2.13/work/grilo-plugins-0.2.13/src'
Makefile:616: recipe for target 'all-recursive' failed
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory '/var/tmp/portage/media-plugins/grilo-plugins-0.2.13/work/grilo-plugins-0.2.13'
Makefile:544: recipe for target 'all' failed
make: *** [all] Error 2
 * ERROR: media-plugins/grilo-plugins-0.2.13::gentoo failed (compile phase):
 *   emake failed
Comment 2 Pacho Ramos gentoo-dev 2014-09-26 09:38:47 UTC
Not sure if you could report it to upstream directly -> bugzilla.gnome.org

I could also do that but, as I cannot reproduce (on amd64 and x86), would be slower to reply to upstream as I would need to come here on each question as forward it to you :/
Comment 3 Pacho Ramos gentoo-dev 2014-11-10 10:24:21 UTC
+  10 Nov 2014; Pacho Ramos <pacho@gentoo.org> grilo-plugins-0.2.13.ebuild:
+  Needs newer grilo (upstream bug #739159)
+
Comment 4 Pacho Ramos gentoo-dev 2015-02-23 11:59:50 UTC
ppc/ppc64 done
Comment 5 Pacho Ramos gentoo-dev 2015-06-20 20:51:06 UTC
I will dekeyword all reverse deps and grilo-plugins for remaining arches in a week if nobody disagree 

$ grep -r media-plugins/grilo-plugins */*/*.ebuild
media-gfx/gnome-photos/gnome-photos-3.14.2.ebuild:	>=media-plugins/grilo-plugins-0.2.6:0.2[upnp-av]
media-gfx/gnome-photos/gnome-photos-3.14.3.ebuild:	>=media-plugins/grilo-plugins-0.2.6:0.2[upnp-av]
media-gfx/gnome-photos/gnome-photos-3.16.2.ebuild:	>=media-plugins/grilo-plugins-0.2.6:0.2[upnp-av]
media-libs/grilo/grilo-0.2.11.ebuild:		media-plugins/grilo-plugins:0.2 )
media-libs/grilo/grilo-0.2.12.ebuild:		media-plugins/grilo-plugins:0.2 )
media-plugins/grilo-plugins/grilo-plugins-0.2.12.ebuild:# $Header: /var/cvsroot/gentoo-x86/media-plugins/grilo-plugins/grilo-plugins-0.2.12.ebuild,v 1.4 2015/05/14 22:25:54 eva Exp $
media-plugins/grilo-plugins/grilo-plugins-0.2.13.ebuild:# $Header: /var/cvsroot/gentoo-x86/media-plugins/grilo-plugins/grilo-plugins-0.2.13.ebuild,v 1.7 2015/05/14 22:25:54 eva Exp $
media-plugins/grilo-plugins/grilo-plugins-0.2.14.ebuild:# $Header: /var/cvsroot/gentoo-x86/media-plugins/grilo-plugins/grilo-plugins-0.2.14.ebuild,v 1.1 2015/06/09 23:48:31 eva Exp $
media-sound/gnome-music/gnome-music-3.14.3.1.ebuild:	media-plugins/grilo-plugins:0.2[tracker]
media-sound/gnome-music/gnome-music-3.16.1.ebuild:	media-plugins/grilo-plugins:0.2[tracker]
media-sound/rhythmbox/rhythmbox-3.0.3.ebuild:		>=media-plugins/grilo-plugins-0.2:0.2[upnp-av] )
media-sound/rhythmbox/rhythmbox-3.1.ebuild:		>=media-plugins/grilo-plugins-0.2:0.2[upnp-av] )
media-sound/rhythmbox/rhythmbox-3.2.1.ebuild:		>=media-plugins/grilo-plugins-0.2:0.2[upnp-av] )
media-video/totem/totem-3.12.2.ebuild:	media-plugins/grilo-plugins:0.2
media-video/totem/totem-3.14.2.ebuild:	media-plugins/grilo-plugins:0.2
media-video/totem/totem-3.14.3.ebuild:	media-plugins/grilo-plugins:0.2
media-video/totem/totem-3.16.1.ebuild:	media-plugins/grilo-plugins:0.2
Comment 6 Tobias Klausmann (RETIRED) gentoo-dev 2015-08-07 15:02:29 UTC
Keyworded these on alpha because we want to keep rhythmbox:

media-plugins/grilo-plugins-0.2.13
dev-libs/gom-0.3.1
Comment 7 Gilles Dartiguelongue gentoo-dev 2016-08-21 22:20:43 UTC
Hello arch teams. This issue is becoming more pressing as due to an error while introducing grilo 0.3 ebuilds in tree, dependency to plugins was not properly updated resulting in an invalid dependency check. As such, if you do not keyword gom for your respective arch we will start pruning USE flags and or keywords from affected packages to resolve https://qa-reports.gentoo.org/output/gentoo-ci/926399a/output.html#media-libs/grilo.

Thanks for your understanding.
Comment 8 Gilles Dartiguelongue gentoo-dev 2016-08-22 18:10:15 UTC
Had to mask test USE flag since broken deptree breaks synchronization it seems : https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=39853e7deedacb42b25cdc7746117265938f6c5d
Comment 9 Mart Raudsepp gentoo-dev 2017-03-23 04:05:32 UTC
arm and ia64 have lost keywords on totem as well due to this.
I will probably be removing totem-3.18 soon, which is still present only because of arm/ia64 keyword dropping.
Comment 10 Mart Raudsepp gentoo-dev 2017-03-25 13:18:40 UTC
Adding totem to the keywording list, Removing sparc CC as they have apparently already done this keywording.
Comment 11 Markus Meier gentoo-dev 2017-04-04 21:06:09 UTC
~arm added.
Comment 12 Émeric Maschino 2017-04-05 22:38:45 UTC
Tested OK on ia64.

     Émeric
Comment 13 Sergei Trofimovich (RETIRED) gentoo-dev 2017-06-17 08:33:37 UTC
~ia64 keyworded. Thank you Émeric!

Last arch. Closing.