Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 521734 - app-eselect/eselect-opencl - add support for selecting CL-1.2 headers
Summary: app-eselect/eselect-opencl - add support for selecting CL-1.2 headers
Status: RESOLVED TEST-REQUEST
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 2 votes (vote)
Assignee: Patrick Lauer
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 601996
  Show dependency tree
 
Reported: 2014-08-30 13:04 UTC by xpue
Modified: 2018-09-27 09:50 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description xpue 2014-08-30 13:04:03 UTC
Its needed for opencl support in media-video/ffmpeg-2*, see

http://bugs.gentoo.org/show_bug.cgi?id=520736

Reproducible: Always
Comment 1 Patrick Lauer gentoo-dev 2014-09-03 09:33:07 UTC
So the trick here would be that we figure out for each target what it supports (e.g. nvidia -> 1.1, fglrx -> 1.2, radeon/mesa -> 1.1 ) and then either show the "best" by default, or allow eselect to choose all up to the highest available
Comment 3 Timo Rothenpieler 2015-07-29 15:13:20 UTC
nvidia-drivers 350 support OpenCL 1.2, but eselect-opencl still links to the 1.1 headers, causing issues with ffmpeg and other applications.

As a workaround:

mkdir /usr/lib64/OpenCL/vendors/nvidia/include
cd /usr/lib64/OpenCL/vendors/nvidia/include
ln -s ../../../global/include/CL-1.2 CL
eselect opengl set nvidia

This symlink should propably be created by the nvidia-drivers package, as it's the only package which knows weather the current nvidia driver supports OpenCL 1.2.
Comment 4 Marius Brehler 2015-09-17 10:03:14 UTC
Actually, it is even worse.

Installing dev-util/intel-ocl-sdk-4.4.0.117-r1 ships a libOpenCL.so pointing to ../../opt/intel/opencl-1.2-4.4.0.117/lib64/libOpenCL.so.1.2. The headers still point to OpenCL 1.1 anyway.
Comment 5 Marius Brehler 2015-10-31 10:46:27 UTC
Any progress or further ideas how to handle this issue? This somehow blocks revision bumps of clblas and clfft in the science overlay, since these require OpenCL<=1.2.
Comment 6 Craig Andrews gentoo-dev 2018-03-27 01:40:06 UTC
It looks like this was fixed in https://github.com/gentoo/gentoo/commit/cb730d07e4e9c2f96b865de36428eefa091723cb ? Can anyone confirm?