Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 521314 - dev-util/android-sdk-update-manager should depend on =dev-java/swt:3.8
Summary: dev-util/android-sdk-update-manager should depend on =dev-java/swt:3.8
Status: CONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Development (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Richard Freeman
URL:
Whiteboard:
Keywords:
Depends on: 521308
Blocks:
  Show dependency tree
 
Reported: 2014-08-27 15:23 UTC by Matthias Dahl
Modified: 2018-01-16 17:35 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Matthias Dahl 2014-08-27 15:23:23 UTC
android crashes due to incompatibilities with the bundled or in-tree SWT versions and newer Glib/GTK+ versions.

Since the SDK works just fine with SWT 3.8.2 -- except for the crashes of course -- I suggest moving its dependency entirely to 3.8 since that is the most recent one from the 3.x series which will actually still work. I have already opened another bug report which contains fixes for SWT 3.8 which will stop android from crashing or emitting any errors/warnings.

Reproducible: Always

Steps to Reproduce:
1. Open android
2. Create a new AVD
3. Create/Save it
Actual Results:  
Once you leave the dialog, android will crash with an error in Glib.