Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 520268 - dev-lang/php-5.5.15 USE=fileinfo - segmentation fault in /usr/lib64/apache2/modules/libphp5.so at finfo_resource_destructor()
Summary: dev-lang/php-5.5.15 USE=fileinfo - segmentation fault in /usr/lib64/apache2/m...
Status: RESOLVED DUPLICATE of bug 471682
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Development (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: PHP Bugs
URL:
Whiteboard:
Keywords:
: 520386 520394 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-08-19 18:54 UTC by Marcel Sondaar
Modified: 2015-11-07 02:29 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
error_log (error_log,41.92 KB, text/plain)
2014-08-19 19:00 UTC, Marcel Sondaar
Details
emerge --info (emerge_info,4.44 KB, text/plain)
2014-08-19 19:02 UTC, Marcel Sondaar
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marcel Sondaar 2014-08-19 18:54:31 UTC
Installing a fresh copy of mediawiki on an apache2 server with virtualhosts results in half the content being dropped on the client side, and segfaults in the server log. The problem occurs with both PHP 5.3.29 (which reports a segfault without a stacktrace) and with PHP 5.5 with stacktrace in error_log. 

Restarting does not help. Recompiling file/apache/php does not help. Switching between 5.5 and 5.3 does not help. Recompiling php without the fileinfo use flag results in a working installation.


Reproducible: Always

Steps to Reproduce:
1. install apache, php, postgresql and configure a functional server
2. create a vhost and extract the mediawiki package.
3. follow the mediawiki install procedure in the browser and install LocalSettings.php
4. Visit the new index page.
Actual Results:  
The styling will be absent, there are segfaults reported in the error_log. Accessing the css file at /load.php?debug=false&lang=en-gb&modules=mediawiki.legacy.commonPrint%2Cshared|mediawiki.skinning.interface|mediawiki.ui.button|skins.vector.styles&only=styles&skin=vector&* results in a connection reset.


Expected Results:  
A standard empty mediawiki installation

#eselect profile list
Available profile symlink targets:
  [1]   default/linux/amd64/13.0 *

#make.conf
USE="-X -alsa sse sse2 mysql mysqli postgres pdo truetype png jpg tiff apache2 svn snmp ipv6 php gd -cups sasl dovecot-sasl"
Comment 1 Marcel Sondaar 2014-08-19 19:00:14 UTC
Created attachment 383142 [details]
error_log
Comment 2 Marcel Sondaar 2014-08-19 19:02:08 UTC
Created attachment 383144 [details]
emerge --info
Comment 3 Jeroen Roovers gentoo-dev 2014-08-21 11:37:57 UTC
*** Bug 520394 has been marked as a duplicate of this bug. ***
Comment 4 Jeroen Roovers gentoo-dev 2014-08-22 07:42:40 UTC
*** Bug 520386 has been marked as a duplicate of this bug. ***
Comment 5 Jeroen Roovers gentoo-dev 2014-10-12 21:12:41 UTC
*** Bug 520386 has been marked as a duplicate of this bug. ***
Comment 6 Michael Orlitzky gentoo-dev 2015-11-07 02:29:56 UTC

*** This bug has been marked as a duplicate of bug 471682 ***