Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 519646 - =dev-libs/cyrus-sasl-2.1.26-r9 stabilization request (WAS: dev-libs/cyrus-sasl-2.1.26-r3 - postfix/smtpd: SQL engine 'mysql' not supported)
Summary: =dev-libs/cyrus-sasl-2.1.26-r9 stabilization request (WAS: dev-libs/cyrus-sas...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Keywording and Stabilization (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Net-Mail Packages
URL:
Whiteboard:
Keywords: STABLEREQ
: 520300 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-08-11 14:03 UTC by Oleh Kravchenko
Modified: 2015-04-10 00:38 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
dev-libs/cyrus-sasl-2.1.26-r3 build log (cyrus-sasl.build,97.53 KB, text/plain)
2014-08-11 18:32 UTC, Oleh Kravchenko
Details
emerge --info dev-libs/cyrus-sasl (cyrus-sasl.info,5.41 KB, text/plain)
2014-08-11 18:33 UTC, Oleh Kravchenko
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Oleh Kravchenko 2014-08-11 14:03:01 UTC
After update world postfix loose ability to use auth over mysql.

In log appear new message:
Aug 10 23:44:05 localhost postfix/smtpd[4568]: SQL engine 'mysql' not supported
Aug 10 23:44:05 localhost postfix/smtpd[4568]: auxpropfunc error no mechanism available
Aug 10 23:44:05 localhost postfix/smtpd[4568]: _sasl_plugin_load failed on sasl_auxprop_plug_init for plugin: sql

Small investigation give me more info:
./configure --prefix=/usr --build=x86_64-pc-linux-gnu --host=x86_64-pc-linux-gnu --mandir=/usr/share/man --infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc --localstatedir=/var/lib --libdir=/usr/lib64 --disable-dependency-tracking --enable-login --enable-ntlm --enable-auth-sasldb --disable-cmulocal --disable-krb4 --enable-otp --without-sqlite --with-saslauthd=/run/saslauthd --with-pwcheck=/run/saslauthd --with-configdir=/etc/sasl2 --with-plugindir=/usr/lib64/sasl2 --with-dbpath=/etc/sasl2/sasldb2 --without-openssl --without-pam --without-ldap --disable-ldapdb --disable-sample --disable-gssapi --disable-java --without-javahome --with-mysql --without-pgsql --without-sqlite3 --disable-srp --disable-static --without-des --enable-sql --with-dblib=none

dev-libs/cyrus-sasl-2.1.26-r3 was emerged without mysql
configure: WARNING: MySQL Library not found


Reproducible: Always

Steps to Reproduce:
1. emerge -NDu world -p
2. use postfix with sasl mysql auth
Actual Results:  
sasl auth over mysql don't work


I workaround this bug by adding to ebuild this string:
--with-mysql=/usr/include/mysql
Comment 1 Jeroen Roovers (RETIRED) gentoo-dev 2014-08-11 15:15:43 UTC
1) Please post your `emerge --info dev-libs/cyrus-sasl' output in a comment.
2) Please attach the entire build log to this bug report.
Comment 2 Brian Evans Gentoo Infrastructure gentoo-dev 2014-08-11 18:21:59 UTC
Looking at the configure.in:

The old way of --with-mysql worked because the static libraries where unconditionally installed with <=dev-db/mysql-5.1.  Now, there is the static-libs IUSE on virtual/mysql and all providers.

If --with-mysql=/usr is given (plus other prefix if needed), it should search for the shared library instead.

Leaving it up to the maintainer to decide what to do with it.
Comment 3 Oleh Kravchenko 2014-08-11 18:32:29 UTC
Created attachment 382688 [details]
dev-libs/cyrus-sasl-2.1.26-r3 build log
Comment 4 Oleh Kravchenko 2014-08-11 18:33:06 UTC
Created attachment 382690 [details]
emerge --info dev-libs/cyrus-sasl

2.1.26-r3
Comment 5 Oleh Kravchenko 2014-08-11 18:38:38 UTC
I'm sorry, but updating cyrus-sasl is break authorization for postfix. This is a major bug. I spend few hours, to investigate issue and I hope it will be fixed.
Comment 6 Alexandru N. Barloiu 2014-08-14 20:13:26 UTC
>=dev-db/mysql-5.5 breaks cyrus-sasl. i dont know why. downgrade to lower mysql fixes it.
Comment 7 Brian Evans Gentoo Infrastructure gentoo-dev 2014-08-14 20:17:43 UTC
(In reply to Alexandru N. Barloiu from comment #6)
> >=dev-db/mysql-5.5 breaks cyrus-sasl. i dont know why. downgrade to lower mysql fixes it.

Enable USE="static-libs" for >=virtual/mysql-5.5 to retain the old behavior on cyrus-sasl.

OR

The ebuild should be changed to point to the shared libraries.
Comment 8 Oleh Kravchenko 2014-08-15 04:57:23 UTC
(In reply to Brian Evans from comment #7)
> (In reply to Alexandru N. Barloiu from comment #6)
> > >=dev-db/mysql-5.5 breaks cyrus-sasl. i dont know why. downgrade to lower mysql fixes it.
> 
> Enable USE="static-libs" for >=virtual/mysql-5.5 to retain the old behavior
> on cyrus-sasl.
> 
> OR
> 
> The ebuild should be changed to point to the shared libraries.

I think ebuild anyway should be changed to require mysql with static-libs or link with dynamic libraries
Comment 9 Jeroen Roovers (RETIRED) gentoo-dev 2014-08-20 08:59:03 UTC
*** Bug 520300 has been marked as a duplicate of this bug. ***
Comment 10 Eray Aslan gentoo-dev 2014-08-20 15:35:09 UTC
+*cyrus-sasl-2.1.26-r8 (20 Aug 2014)
+
+  20 Aug 2014; Eray Aslan <eras@gentoo.org> +cyrus-sasl-2.1.26-r8.ebuild:
+  Fix buiding with >mysql-5.5 - bug #519646
+
Comment 11 Sergey Popov gentoo-dev 2014-08-22 06:06:35 UTC
Reopening, cause this breakage affects current stable. I begin stabilization using my QA hat.

Arches, please test and mark stable =dev-libs/cyrus-sasl-2.1.26-r3

Target keywords: alpha amd64 arm hppa ia64 ppc ppc64 sparc x86
Comment 12 Sergey Popov gentoo-dev 2014-08-22 06:09:09 UTC
About ChangeLog entry:

  20 Aug 2014; Eray Aslan <eras@gentoo.org> cyrus-sasl-2.1.26-r3.ebuild:
  Fix stable version for >mysql-5.5 as well

Users MUST rebuild cyrus-sasl to make this work, so, without revision bump fix is useless, if they do not rebuild it manually.
Comment 13 Eray Aslan gentoo-dev 2014-08-22 06:20:10 UTC
(In reply to Sergey Popov from comment #12)
> Users MUST rebuild cyrus-sasl to make this work, so, without revision bump
> fix is useless, if they do not rebuild it manually.

Hence the -r7 to -r8 bump.  -r3 fix is useful in that it will help with the *new* stable tree users.

(In reply to Sergey Popov from comment #11)
> Arches, please test and mark stable =dev-libs/cyrus-sasl-2.1.26-r3

Please go for =net-libs/cyrus-sasl-2.1.26-r8.
Comment 14 Sergey Popov gentoo-dev 2014-08-22 06:23:06 UTC
(In reply to Eray Aslan from comment #13)
> (In reply to Sergey Popov from comment #12)
> > Users MUST rebuild cyrus-sasl to make this work, so, without revision bump
> > fix is useless, if they do not rebuild it manually.
> 
> Hence the -r7 to -r8 bump.  -r3 fix is useful in that it will help with the
> *new* stable tree users.

And what should people with stable AND already installed cyrus-sasl-2.1.26-r3 do? How they will understand that they need to rebuild it to fix things properly?

Anyway, thanks for fixing me(i notices that i posted message with wrong revision, -r3 is already stable).
Comment 15 Eray Aslan gentoo-dev 2014-08-22 11:39:49 UTC
Better yet, we should go for stabilizing -r9.

Arches, please test and mark stable =dev-libs/cyrus-sasl-2.1.26-r9.  Thank you.

Target Keywords: alpha amd64 arm hppa ia64 ppc ppc64 sparc x86
Comment 16 Jeroen Roovers (RETIRED) gentoo-dev 2014-08-22 19:00:30 UTC
Stable for HPPA.
Comment 17 Markus Meier gentoo-dev 2014-09-13 12:14:56 UTC
arm stable
Comment 18 Pacho Ramos gentoo-dev 2014-10-23 10:52:04 UTC
amd64/x86 stable
Comment 19 Vitaly A. Repin 2014-10-26 10:17:08 UTC
https://bugs.gentoo.org/show_bug.cgi?id=526892  Doees ithis bug affects this stabilization request?
Comment 20 Tobias Klausmann gentoo-dev 2014-11-21 09:49:08 UTC
Stable on alpha.
Comment 21 Raúl Porcel (RETIRED) gentoo-dev 2015-01-16 08:35:56 UTC
ia64/s390/sh/sparc stable
Comment 22 Agostino Sarubbo gentoo-dev 2015-03-02 09:39:37 UTC
ppc stable
Comment 23 Anthony Basile gentoo-dev 2015-04-09 23:40:11 UTC
Stable on ppc64.  Closing since this is the last arch.