Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 517500 - media-libs/libquvi-0.4.1-r1 should depend on dev-lang/lua:5.1
Summary: media-libs/libquvi-0.4.1-r1 should depend on dev-lang/lua:5.1
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: media-video herd
Depends on:
Reported: 2014-07-19 12:20 UTC by nE0sIghT
Modified: 2018-11-13 16:17 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description nE0sIghT 2014-07-19 12:20:03 UTC
Currently media-libs/libquvi-0.4.1-r1 depends on >=dev-lang/lua-5.1, but does not compiles with lua:5.2
Dependency must be adjusted to lua:5.1 or <lua-5.2
Comment 1 John Bytheway 2014-08-18 01:51:48 UTC
I hit this problem too (at least, I guess it's the same problem; OP didn't provide many details).  In my case I not only had to have lua-5.1 installed, but also selected with 'eselect lua' before libquvi would compile.

The case where lua-5.1 is not installed manifests as a configure error because pkgconfig can't find the right version.  The case where it's not selected manifests as a compile-time missing header error because the header isn't symlinked to the expected place.

Sorry, I didn't catch the exact error messages to paste here.
Comment 2 nE0sIghT 2015-01-06 15:36:54 UTC
Trivial patch for current stable libquvi-0.4.1-r1.ebuild:

commit d2b46927c117bc574ac239781a2e6caa3f593262
Author: nE0sIghT <>
Date:   Tue Jan 6 18:33:46 2015 +0300

    Fixed lua dependency -

diff --git a/media-libs/libquvi/libquvi-0.4.1-r1.ebuild b/media-libs/libquvi/libquvi-0.4.1-r1.ebuild
index 3f5f873..a46b11e 100644
--- a/media-libs/libquvi/libquvi-0.4.1-r1.ebuild
+++ b/media-libs/libquvi/libquvi-0.4.1-r1.ebuild
@@ -18,7 +18,7 @@ IUSE="examples static-libs"
-	>=dev-lang/lua-5.1[deprecated]
+	dev-lang/lua:5.1[deprecated]