Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 51748 - rc script for media-sound/mpd fails to stop daemon
Summary: rc script for media-sound/mpd fails to stop daemon
Status: VERIFIED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All All
: High normal (vote)
Assignee: Gentoo Sound Team
URL:
Whiteboard:
Keywords:
: 50583 (view as bug list)
Depends on:
Blocks:
 
Reported: 2004-05-22 11:31 UTC by Drake Wyrm
Modified: 2010-03-27 23:29 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
rc script excerpt: using start-stop-daemon (rcscript_excerpt,275 bytes, text/plain)
2004-05-22 11:35 UTC, Drake Wyrm
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Drake Wyrm 2004-05-22 11:31:06 UTC
When mpd starts, it immediately forks, so the pid file created by start-stop-daemon is invalid. When attempting to stop mpd via the rc script, start-stop-daemon can't find mpd, and returns an error.

Steps to reproduce:
# /etc/init.d/mpd stop

Result:
 * Stopping Music Player Daemon...
start-stop-daemon: warning: failed to kill 21353: No such process [ !! ]

Fix speculation:
The rc script should either issue a "kill" command directly to mpd (Bash networking) or use `start-stop-daemon --stop --exec /usr/bin/mpd
Comment 1 Drake Wyrm 2004-05-22 11:35:24 UTC
Created attachment 31847 [details]
rc script excerpt: using start-stop-daemon
Comment 2 Brian Harring gentoo-dev 2004-05-24 15:06:58 UTC
*** Bug 50583 has been marked as a duplicate of this bug. ***
Comment 3 Brian Harring gentoo-dev 2004-05-24 15:08:16 UTC
Thanks Drake-
commited to cvs, rev-bumped 0.9.4 and 0.10.3 to -r1.