Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 51733 - Gnome 2.6 cannot access WebDAV folder
Summary: Gnome 2.6 cannot access WebDAV folder
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
Depends on:
Reported: 2004-05-22 04:15 UTC by Thomas Beutin
Modified: 2004-10-17 11:59 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Beutin 2004-05-22 04:15:20 UTC
Accessing a WebDAV folger with Gnome 2.4 was no problem, but is not longer possible after upgrade to Gnome 2.6.

Reproducible: Always
Steps to Reproduce:
1. open Nautilus 2.6.0
2. type in a valid WebDAV server URL in the "Location" field
3. press <enter>
Actual Results:  
Error message pops up:

The folder contents could not be displayed.

"http: <my_webdav_server>" couldn't be found. Perhaps it has recently been deleted.

(No slashes!)

from my .xsession-errors:
PROPFIND:2: parser warning : xmlns:D: 'DAV:' is not a valid URI
<D:multistatus xmlns:D="DAV:">
PROPFIND:3: parser warning : xmlns:lp0: 'DAV:' is not a valid URI
<D:response xmlns:lp0="DAV:" xmlns:lp1="" xmlns:i0="
PROPFIND:3: parser warning : xmlns:i0: 'DAV:' is not a valid URI
sponse xmlns:lp0="DAV:" xmlns:lp1="" xmlns:i0="DAV:"
Portage 2.0.50-r6 (default-x86-1.4, gcc-3.3.2, glibc-2.3.2-r9, 2.6.5-gentoo-r1)
System uname: 2.6.5-gentoo-r1 i686 Intel(R) Pentium(R) 4 CPU 2.60GHz
Gentoo Base System version 1.4.10
Autoconf: sys-devel/autoconf-2.58-r1
Automake: sys-devel/automake-1.8.3
CFLAGS="-O3 -march=pentium4 -funroll-loops -pipe -fforce-addr
-fomit-frame-pointer -frerun-cse-after-loop -frerun-loop-opt -falign-functions=4"
CONFIG_PROTECT="/etc /etc/tomcat /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config
/usr/kde/3.1/share/config /usr/kde/3.2/share/config /usr/kde/3/share/config
/usr/lib/mozilla/defaults/pref /usr/share/config
/usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/
/usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/
/usr/share/texmf/xdvi/ /var/bind /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O3 -march=pentium4 -funroll-loops -pipe -fforce-addr
-fomit-frame-pointer -frerun-cse-after-loop -frerun-loop-opt -falign-functions=4"
FEATURES="autoaddcvs ccache sandbox"
USE="X aalib alsa apache apache2 apm arts avi berkdb bonobo cdr clamav crypt
cups curl dga dvd dvdr encode esd foomaticdb gd gdbm gif gnome gphoto gphoto2
gpm gstreams gtk gtk2 gtkhtml imap imlib jack java jikes jpeg kde lcms ldap
libg++ libwww mad mikmod motif mozilla mpeg ncurses nls oggvorbis opengl oss pam
pda pdflib perl plotutils png postgres python qt quicktime readline ruby samba
sasl scanner sdl slang smpgsql snmp spell sse ssl svga tcltk tcpd tetex tiff
truetype unicode usb virus-scan wmf x86 xinerama xml xml2 xml2xmms xmms xv zlib"
Comment 1 foser (RETIRED) gentoo-dev 2004-05-25 02:26:47 UTC
dunno, never worked with webdev. It seems they should be handled by gnome-vfs http plugin. Not sure what changed.
Comment 2 Thomas Beutin 2004-05-25 04:52:34 UTC
How can i see which plugins is involved?

BTW: I found this working with URLs like http://<my_webdav_server>/<subdir>/ but not with the main directory http://<my_webdav_server>/
Comment 3 foser (RETIRED) gentoo-dev 2004-08-19 16:07:43 UTC
still a problem ?

are there public versions of these servers so we can test ?
Comment 4 Thomas Beutin 2004-08-20 07:10:03 UTC
Yes, the problem still exists. Now nautilus shows the http content of the resource but not a file system view. In KDE this is solved by different addressing scheme (http://<server-name>/ vs. webdav://<server-name>/).

Unfortunally the server is not reachable from the internet, but probybly i can setup a folder in early september accesible from the internet to some developers for a month or so. If You think this might be helpfull please drop me a line with a couple of adresses so i can send the login data to this peoples.
Comment 5 foser (RETIRED) gentoo-dev 2004-08-20 08:11:11 UTC
i tried with a public account, works fine here..

the url prefix is apperantly dav:// for gnome-vfs .. in nautilus->file menu you can select 'connect to server' and choose webdav there. Does that work for you ?
Comment 6 Thomas Beutin 2004-08-20 09:13:33 UTC
Nope, i cannot select webdav there. I've only two input fields (Linke name, Locatio (URL)) and two buttons (Cancel, Connect). When i enter a name and dav://<my-server>/ an try to connect (click on Connect), nothing happens. When i enter dav://<my-server>/ into nautilus' location bar i get an error: Couldn't display "dav://<my-server>/". Nautilus cannot handle dav: locations.
The installed gnome-base/gnome-vfs version is
Comment 7 Joe McCann (RETIRED) gentoo-dev 2004-08-20 12:38:06 UTC
The connect to server dialogue was redone for 2.8 with those extra options (maybe what foser was thinking of?)
Comment 8 foser (RETIRED) gentoo-dev 2004-08-20 12:44:48 UTC
yeah well.. halfway, i gave the vfs name to try that too.
Comment 9 Mike Gardiner (RETIRED) gentoo-dev 2004-08-22 03:55:40 UTC
Webdav works perfectly here in GNOME 2.6, using dav://<server>/<dir>. I'm prompted for username and password, enter that and then it works.
Comment 10 Alastair Tse (RETIRED) gentoo-dev 2004-10-17 11:59:24 UTC
needinfo for reproducing