Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 517192 - net-libs/webkit-gtk-2.4.4 - ?
Summary: net-libs/webkit-gtk-2.4.4 - ?
Status: RESOLVED DUPLICATE of bug 463960
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
Depends on:
Reported: 2014-07-15 21:16 UTC by Fred Krogh
Modified: 2014-07-22 06:04 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---

Shows the end of the compile before aborting (webkit-gtk-2.4.4-abort,11.41 KB, text/plain)
2014-07-15 21:16 UTC, Fred Krogh
build.log (webkit-gtk-2.4.4.again,652.84 KB, text/plain)
2014-07-16 04:39 UTC, Fred Krogh

Note You need to log in before you can comment on or make changes to this bug.
Description Fred Krogh 2014-07-15 21:16:54 UTC
Created attachment 380770 [details]
Shows the end of the compile before aborting

Since I abort the compile, the attachment is all that I have

========= My emerge --info ====

Portage 2.2.10 (default/linux/amd64/13.0/desktop, gcc-4.8.3, glibc-2.19-r1, 3.15.5-gentoo x86_64)
System uname: Linux-3.15.5-gentoo-x86_64-Intel-R-_Core-TM-_i7-2600_CPU_@_3.40GHz-with-gentoo-2.2
KiB Mem:     8164776 total,   2950344 free
KiB Swap:    4194300 total,   4157512 free
Timestamp of tree: Tue, 15 Jul 2014 20:00:01 +0000
ld GNU ld (GNU Binutils) 2.24
app-shells/bash:          4.2_p47
dev-java/java-config:     2.2.0
dev-lang/python:          2.7.7, 3.3.5, 3.4.1
dev-util/pkgconfig:       0.28-r1
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.12.4
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.10.3, 1.11.6, 1.14.1
sys-devel/binutils:       2.24-r3
sys-devel/gcc:            4.8.3, 4.9.0
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2-r1
sys-devel/make:           4.0-r1
sys-kernel/linux-headers: 3.15 (virtual/os-headers)
sys-libs/glibc:           2.19-r1
Repositories: gentoo x-portage
ACCEPT_KEYWORDS="amd64 ~amd64"
CFLAGS="-O2 -march=native -pipe"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -march=native -pipe"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_EXTRA_OPTS=" --exclude=/.unionfs --exclude=.fuse_hidden*"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="64bit X a52 aac acl acpi ads alsa amd64 apache2 apng auctex bash-completion bcmath berkdb bluetooth branding bzip2 cairo caps caps-ng cdda cdr cdrom clamav clamd cli clisp colordiff consolekit cracklib crypt cups cxx dbus dconf debugger device-mapper dri dts dvd dvdr dvdread emacs emboss emul-linux86 encode exif fam fastcgi ffmpeg flac fontconfig fortran ftpuf g3dvl games gdbm gdu gif gnome gpm graphite gstreamer gtk gudev hwdb iconv icu introspection ipod ipv6 java javascript jpeg keymap kpathsea latex latin1 lcms ldap libclamav libnotify libwww logrotate mad mbox mmx mmxext mng modemmanager modules mono motif mouse mp3 mp4 mpeg multilib mysql nat ncurses network-cron networkmanager nls nptl nsplugin nvidia ogg opengl openmp openrc pam pango pcre pdf playlist png policykit pop pop3d ppds preview-latex pulseaudio python qt3support qt4 readline regex rpc samba sdl session smbclient sockets sound spamassassin spell sqlite sse sse2 ssl startup-notification sudoku svg symlink systemd tcpd theora threads thunderbird tiff truetype udev udisks unicode upcall upower usb vdpau vhosts vorbis webkit winbind wxwidgets x264 xcb xcomposite xml xulrunner xv xvid zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter fcgid file_cache filter headers hwdb ident imagemap include info log_config logio macro mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http python rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="pc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en en_US" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" RUBY_TARGETS="ruby19 ruby20" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Comment 1 Jeroen Roovers (RETIRED) gentoo-dev 2014-07-16 02:22:54 UTC
1) Please attach the entire build log to this bug report.
2) What happened while it "hung"? Were sub-processes still churning or did
   everything simply halt without using any further resources?
3) What else did you try? Removing -pipe from your *FLAGS should help get memory
   usage down, as would reducing the number of make jobs.
Comment 2 Fred Krogh 2014-07-16 04:39:33 UTC
Created attachment 380792 [details]

Tried this with no -pipe, and MAKEOPTS="-j1".  Got a different result, but it still hung.  The task manager showed lots of stuff running, but the stuff connected with the emerge was gone (no gcc, etc.).  It just seemed to decide to "retire".  The stuff at the end of the attachment, may be helpful.  It seems that in this case emerge webkit-gtk chose webkit-gtk-2.4.4-r200.  I think last time may have been a different version.  Once again there is no build log that was created.  This sucker take forever to compile!
Comment 3 Pacho Ramos gentoo-dev 2014-07-16 08:56:49 UTC
eselect opengl set xorg-x11

Before compiling it. I think this could be a dupe of bug 463960
Comment 4 Jeroen Roovers (RETIRED) gentoo-dev 2014-07-16 11:35:15 UTC
Comment on attachment 380792 [details]

That's not the entire build log.
Comment 5 Pacho Ramos gentoo-dev 2014-07-21 09:45:45 UTC
(In reply to Pacho Ramos from comment #3)
> Try:
> eselect opengl set xorg-x11
> Before compiling it. I think this could be a dupe of bug 463960

did you try it?
Comment 6 Fred Krogh 2014-07-22 00:08:03 UTC
I did try it and it worked.  And I thought I had posted that here shortly before leaving for a few days.  Don't know what happened to that post.
Comment 7 Pacho Ramos gentoo-dev 2014-07-22 06:04:36 UTC

*** This bug has been marked as a duplicate of bug 463960 ***