Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 516760 - dev-perl/libintl-perl - ld: cannot find -lintl (when dev-db/firebird is installed?)
Summary: dev-perl/libintl-perl - ld: cannot find -lintl (when dev-db/firebird is insta...
Alias: None
Product: Gentoo/Alt
Classification: Unclassified
Component: Prefix Support (show other bugs)
Hardware: All Linux
: Normal normal with 4 votes (vote)
Assignee: Gentoo Prefix
Depends on:
Reported: 2014-07-09 12:13 UTC by Laurent Bachelier
Modified: 2017-02-04 19:35 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---

build log (build.log,14.90 KB, text/plain)
2014-07-09 12:13 UTC, Laurent Bachelier

Note You need to log in before you can comment on or make changes to this bug.
Description Laurent Bachelier 2014-07-09 12:13:06 UTC
It stops at:
ld: cannot find -lintl

There is no "-L" to be found in the temporary work directory.

This is a dependency of texinfo 5, and prevents stage3 from finishing.
Host system is Mandriva Linux release 2010.2.

Reproducible: Always
Comment 1 Laurent Bachelier 2014-07-09 12:13:30 UTC
Created attachment 380488 [details]
build log
Comment 2 Fabian Groffen gentoo-dev 2014-07-10 17:51:17 UTC
do you have a in /usr/lib, /usr/lib64, /lib or /lib64?
Comment 3 Laurent Bachelier 2014-07-11 09:12:25 UTC
$ ls -l /lib*/*
lrwxrwxrwx 1 root root     16 19 sept.  2011 /lib64/ ->
-rw-r--r-- 1 root root 156975 29 avril  2010 /lib64/
Comment 4 Paul Osmialowski 2014-07-31 18:50:04 UTC
I looked into /usr/lib64 on my recently installed Gentoo box and found: ->

and there's no trace of libinlt.*

So I did:

ln -s

and now dev-perl/libintl-perl installed successfully.
Comment 5 renato gallo 2014-11-08 21:13:57 UTC
thank you guys I was stuck with the same problem, the link solved everything
Comment 6 renato gallo 2014-11-08 21:15:50 UTC
emerge --info
Portage 2.2.14 (python 3.3.5-final-0, default/linux/amd64/13.0, gcc-4.8.2, glibc-2.20, 3.16.3-gentoo x86_64)
System uname: Linux-3.16.3-gentoo-x86_64-AMD_Phenom-tm-_9950_Quad-Core_Processor-with-gentoo-2.2
KiB Mem:     3795656 total,    516316 free
KiB Swap:    8388604 total,   7294420 free
Timestamp of tree: Fri, 07 Nov 2014 20:45:01 +0000
ld GNU ld (GNU Binutils) 2.24
app-shells/bash:          4.3_p30
dev-java/java-config:     2.2.0
dev-lang/perl:            5.20.1-r2
dev-lang/python:          2.7.8, 3.2.5, 3.3.5-r1, 3.4.2
dev-util/pkgconfig:       0.28-r2
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.12.4
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6, 1.12.6, 1.13.4, 1.14.1
sys-devel/binutils:       2.24-r2
sys-devel/gcc:            4.5.4, 4.6.3, 4.7.3, 4.8.2
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.3-r2
sys-devel/make:           4.1-r1
sys-kernel/linux-headers: 3.17-r1 (virtual/os-headers)
sys-libs/glibc:           2.20
Repositories: gentoo sunrise
ACCEPT_KEYWORDS="amd64 ~amd64"
CFLAGS="-O2 -pipe"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/polkit-1/actions /var/bind"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/apache2-php5.5/ext-active/ /etc/php/apache2-php5.6/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cgi-php5.5/ext-active/ /etc/php/cgi-php5.6/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/php/cli-php5.5/ext-active/ /etc/php/cli-php5.6/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="X a52 aac aalib acl alsa amd64 apache2 apng atmo audit authfile auto-hinter autoipd avahi ban bash-completion bcmath berkdb bidi bittorrent bluetooth bzip2 cairo calendar case cdb cdda cddb cdr cgi cjk clamav clamdtop cli cnijtools courier cracklib crypt ctrls cups curl curlwrappers cxx dbus dc1394 dconf declarative deflate desktopglobe dga dhcpcd dirac directfb djvu dlz dri dts dvb dvd dynamicplugin eds embed enchant encode epydoc esd examples exec exif extras fbcon ffmpeg filter flac flatfile fluidsynth fontconfig fontforge foomaticdb fortran fpm ftp g3dvl gbm gd gdbm ggi gif gimp gme gmp gnome gnome-keyring gphoto2 gpm gstreamer gtk gtk3 gudev hpijs httpd hwdb iconv icu id3tag ident ieee1394 ifsession inifile inline-init-failopen intl introspection iodbc ip1900 ip3600 ip4600 ipmi ipq ix6550 java jce jpeg jpeg2k kate kde lame lapack large-pcap-64bit lcms libass libcaca libkms libnotify libproxy libtiger libv4l2 linux-smp-stats live lua lzma mad matroska mdnsresponder-compat mhash midi milter minizip mmx mng mod modplug modules mp190 mp240 mp3 mp540 mp630 mpeg mtp multilib musepack mx360 mx410 mx420 mx880 mysql mysqli mysqlnd mythtv ncurses nfq nls nptl nsplugin nspluginwrapper nss odbc odk ogg openexr opengl openmp openssl optimisememory oss ovftool pam pango pasteafter pcntl pcre pdf pdfimport pdo perl phonon php pic plasma playlist png policykit poll ppds projectm ps pulseaudio pvr python python2 python3 qalculate qt3support qwt rar ratio raw readline readme reload-error-restar remoteosd rewrite romio rpc rtsp run-as-root samba schroedinger scim screensaver script sdk sdl sdl-image semantic-desktop server session setup sftp shaper shine shout sitemisc skins slp smbsharemodes smp snmp soap sockets softquota spamassassin speex spell sql sqlite sqlite2 sse sse2 ssl static-ppds stream stunnel suhosin svg swat system-libvncserver systemd taglib tcpd templates theora threads tidy tiff tilepath tk tools trace truetype truetype-debugger twolame type3 udev udisks unicode upcall upnp ups_drivers_netxml-ups ups_drivers_nut-ipmipsu ups_drivers_snmp-ups usb utils v4l2 vaapi vala vcdx vdpau vix vlm vmware-tools vmware_guest_freebsd vmware_guest_linux vmware_guest_netware vmware_guest_solaris vmware_guest_winPre2k vmware_guest_windows vorbis vroot wddx webinterface webkit winbind wma-fixed wmf wxwidgets x264 xa xattr xml xmlreader xmlrpc xmlwriter xosd xpm xsl xv xvfb zip zlib zvbi" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias auth_digest" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CURL_SSL="nss" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="it" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" RUBY_TARGETS="ruby19 ruby20" USERLAND="GNU" VIDEO_CARDS="fbdev glint intel mach64 mga nouveau nv r128 radeon savage sis tdfx trident vesa via vmware dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Comment 7 Matthias Hanft 2015-07-26 08:06:47 UTC
Had the same problem since some weeks on a 32-bit system (kernel 4.0.5); the solution in comment #4 worked for me, too (in /usr/lib instead of /usr/lib64).
Comment 8 Paul Osmialowski 2016-09-16 06:47:36 UTC
the same problem appeared today after perl update.
Comment 9 Paul Osmialowski 2016-09-16 06:49:35 UTC
Oh my God! This bug is so old that I'm chasing my old solutions for it! My 2014 hack (with creating a symlink) worked again! Well done perl maintainers!
Comment 10 Fabian Groffen gentoo-dev 2016-09-16 08:20:44 UTC
@perl: it appears these reporters are not on Prefix, can you have a loot to see if this is relevant to you?
Comment 11 Christian Glindkamp 2016-09-16 08:32:20 UTC
The real issue seems to be, that when you have dev-db/firebird installed, it detects firebirds, but cannot link it, because firebird does not provide
Comment 12 Andreas Sturmlechner gentoo-dev 2017-02-04 19:35:57 UTC
Thanks, this is fixed by commit 06590bfb0f7ec387135e4c00935c52dcef5d00ef