Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 516342 - media-libs/taglib-1.9.1-r2 stable request
Summary: media-libs/taglib-1.9.1-r2 stable request
Status: RESOLVED DUPLICATE of bug 512012
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Keywording and Stabilization (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords: STABLEREQ
Depends on: 516344
Blocks: gnome-3.12-stable
  Show dependency tree
 
Reported: 2014-07-04 08:34 UTC by Pacho Ramos
Modified: 2014-07-18 19:29 UTC (History)
8 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
fixes erroneous resource release (taglib-1.9.1-tbytevector-replace-fix.patch,3.68 KB, patch)
2014-07-07 06:28 UTC, CT
Details | Diff
Relevant backtrace (amarok-20140706-223450.kcrash.txt,36.40 KB, text/plain)
2014-07-07 06:34 UTC, CT
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Pacho Ramos gentoo-dev 2014-07-04 08:34:35 UTC
For multilib stuff
Comment 1 CT 2014-07-07 06:28:36 UTC
Created attachment 380348 [details, diff]
fixes erroneous resource release

Apropos of stabilization, taglib-1.9.1-r1 still has a nasty bug that was caught after the 1.9.1 milestone of taglib in TagLib::ByteVector::replace(), which currently crashes all extant versions of amarok in the portage tree under AMD64. The attached patch was fashioned from this commit (https://github.com/TsudaKageyu/taglib/commit/4a7d31c87bf41c1de21cb725176d5b34c2a95720), which specifically addresses this issue. It applies to the stock sources in portage without issue and seems to have eliminated the crashing issue, at least on AMD64.
Comment 2 CT 2014-07-07 06:34:44 UTC
Created attachment 380350 [details]
Relevant backtrace

Representative backtrace generated from Dr. Konqi, in case anyone wants to double-check. This particular specimen was generated from amarok-2.8.0 with the following:

Portage 2.2.8-r1 (default/linux/amd64/13.0/desktop/kde, gcc-4.9.0, glibc-2.17, 3.12.20-gentoo x86_64)
=================================================================
System uname: Linux-3.12.20-gentoo-x86_64-AMD_Phenom-tm-_II_X6_1100T_Processor-with-gentoo-2.2
KiB Mem:    16413092 total,   3091188 free
KiB Swap:     891572 total,    891416 free
Timestamp of tree: Fri, 04 Jul 2014 01:30:01 +0000
ld GNU gold (GNU Binutils 2.23.2) 1.11
app-shells/bash:          4.2_p45
dev-java/java-config:     2.2.0
dev-lang/python:          2.7.6, 3.3.3, 3.4.1
dev-util/cmake:           2.8.12.2
dev-util/pkgconfig:       0.28-r1
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.12.4
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6, 1.12.6, 1.13.4
sys-devel/binutils:       2.23.2
sys-devel/gcc:            4.6.3, 4.8.2, 4.9.0
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.2-r1
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.13 (virtual/os-headers)
sys-libs/glibc:           2.17
Repositories: gentoo ct-ebuilds font-overlay multimedia sunrise bitcoin flow sublime-text kde steam-overlay
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=amdfam10 -pipe -O3 -flto=6 -ffat-lto-objects"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/themes/oxygen-gtk/gtk-2.0"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.5/ext-active/ /etc/php/cgi-php5.5/ext-active/ /etc/php/cli-php5.5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=amdfam10 -pipe -O3 -flto=6 -ffat-lto-objects"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.UTF-8"
LDFLAGS="-O3 -flto=6"
MAKEOPTS="-j7"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/ct-ebuilds /var/lib/layman/font-overlay /var/lib/layman/multimedia /var/lib/layman/sunrise /var/lib/layman/bitcoin /var/lib/layman/flow /var/lib/layman/sublime-text /var/lib/layman/kde /var/lib/layman/steam"
USE="3dnow 3dnowext X a52 aac acl acpi ada alsa amd64 anthy avi bash-completion berkdb bitmap-fonts branding bzip2 cairo cdda cdr cjk cli consolekit cracklib crypt cups cxx dbus declarative dlloader dri dts dvd dvdr dvi eds emboss encode exif fam ffmpeg firefox flac fortran gdbm gif gpm gstreamer iconv idn ieee1394 immqt-bc ipv6 isdnlog java jpeg kde kipi lame lcms ldap ldc libg++ libnotify loop-aes mad matroska midi mikmod mmx mmxext mng modules mono mp3 mp4 mpeg mule multilib nautilus ncurses nls nptl nptlonly nsplugin ogg opengl openmp pam pango pcre pdf pdflib perl phonon plasma png policykit ppds pppd python qt3support qt4 readline rtc sdl semantic-desktop session spell sse sse2 sse3 ssl ssse3 startup-notification svg tcpd threads tiff truetype truetype-fonts type1-fonts udev udisks unicode upower usb vdpau vorbis wxwidgets x264 xattr xcb xcomposite xine xinerama xml xorg xscreensaver xv xvid zlib" ABI_X86="32 64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en en_GB el ja he" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3 python3_4" RUBY_TARGETS="ruby19 ruby20" USERLAND="GNU" VIDEO_CARDS="nvidia nv vga vesa nvidia-drivers" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
USE_PYTHON="2.7 3.3"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, SYNC

This issue persisted even when LTO was turned off, GCC 4.7.3 was used, and -O0 was set.
Comment 4 Michael Palimaka (kensington) gentoo-dev 2014-07-07 10:53:24 UTC
Looks fine, feel free to go ahead with whatever you require in case we don't get around to it soon enough.
Comment 5 Pacho Ramos gentoo-dev 2014-07-07 12:43:57 UTC
@CT, try with -r2
Comment 6 CT 2014-07-07 20:22:02 UTC
(In reply to Pacho Ramos from comment #5)
> @CT, try with -r2

Works, thank you very much. :D Even did some additional testing of tag editing and stuff on my own, just to make sure there wasn't any other behavior I might be missing owing to sole usage via amarok.
Comment 7 Pacho Ramos gentoo-dev 2014-07-07 20:27:21 UTC
Nice :D, CCing arches then ;)
Comment 8 Jeroen Roovers gentoo-dev 2014-07-12 12:25:15 UTC
Stable for HPPA.
Comment 9 Tom Gall (RETIRED) gentoo-dev 2014-07-13 03:50:02 UTC
stable arm64
Comment 10 Pacho Ramos gentoo-dev 2014-07-18 19:29:58 UTC
Will handle the remaining arches in parent bug as it's preferred by Ago and this can wait for those arches until the rest is done

*** This bug has been marked as a duplicate of bug 512012 ***