Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 513156 - net-wireless/broadcom-sta- - revision bump / add kernel 3.15 patch
Summary: net-wireless/broadcom-sta- - revision bump / add kernel 3.15 p...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: AMD64 Linux
: Normal normal with 1 vote (vote)
Assignee: M. B.
Depends on:
Blocks: 512304 512788 512984
  Show dependency tree
Reported: 2014-06-13 22:08 UTC by M. B.
Modified: 2014-06-24 17:07 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---

broadcom-sta- (broadcom-sta-,2.59 KB, text/plain)
2014-06-13 22:11 UTC, M. B.
broadcom-sta- (broadcom-sta-,1.09 KB, patch)
2014-06-13 22:12 UTC, M. B.
Details | Diff
broadcom-sta- (broadcom-sta-,2.42 KB, text/plain)
2014-06-13 22:37 UTC, M. B.
Build failure (broadcom-sta-r2-buildfail.log,7.71 KB, text/plain)
2014-06-15 15:47 UTC, Sven Vermeulen (RETIRED)
Build failure with different linux-3.15 patch (buildfailure-broadcom-sta-r2.log,7.71 KB, text/plain)
2014-06-17 07:54 UTC, Sven Vermeulen (RETIRED)
My build.log (build.log,5.27 KB, text/plain)
2014-06-23 13:45 UTC, rtlanceroad

Note You need to log in before you can comment on or make changes to this bug.
Description M. B. 2014-06-13 22:08:23 UTC
This is a new version of the broadcom-sta package.
This version
- reverts to the old patch-structure (which I somehow managed to mess up)
- adds support for Kernel 3.15 (featuring a patch by Alberto Milone from Ubuntu)

Reproducible: Always
Comment 1 M. B. 2014-06-13 22:11:31 UTC
Created attachment 378832 [details]

--- broadcom-sta-	2014-04-04 00:30:03.094363389 +0200
+++ broadcom-sta-	2014-06-12 01:04:13.666009027 +0200
@@ -1,4 +1,4 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Header: $
@@ -12,7 +12,7 @@
 	amd64? ( ${SRC_BASE}_64-nodebug-pcoem-${PV//\./_}.tar.gz )"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="-* ~amd64 ~x86"
@@ -59,8 +59,12 @@
 #	Makefile.patch: keep `emake install` working
 #	linux-3.9.0.patch: add support for kernel 3.9.0
 #	linux-3.10.0.patch: add support for kernel 3.10, bug #477372
-	epatch "${FILESDIR}/${P}-makefile.patch" \
-		"${FILESDIR}/${P}-linux-3.10.0.patch"
+	epatch "${FILESDIR}/${P}-license.patch"
+	epatch "${FILESDIR}/${P}-makefile.patch"
+	epatch "${FILESDIR}/${P}-linux-recent.patch"
+	epatch "${FILESDIR}/${P}-eth-to-wlan.patch"
+	epatch "${FILESDIR}/${P}-gcc.patch"
+	epatch "${FILESDIR}/${P}-linux-3.15.patch"
Comment 2 M. B. 2014-06-13 22:12:36 UTC
Created attachment 378836 [details, diff]

The new patch required for Kernel 3.15.
Comment 3 M. B. 2014-06-13 22:37:44 UTC
Created attachment 378838 [details]

Another cosmetic change.
Also, please compare it to the original broadcom-sta- to see the actual changes that happened.

--- /usr/portage/net-wireless/broadcom-sta/broadcom-sta-	2013-10-16 03:07:10.000000000 +0200
+++ broadcom-sta-	2014-06-14 00:24:45.220053215 +0200
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/broadcom-sta/broadcom-sta-,v 1.1 2013/10/16 01:07:10 tomwij Exp $
+# $Header: $
 inherit eutils linux-info linux-mod
@@ -38,7 +38,7 @@
 	ERROR_PREEMPT_RCU="PREEMPT_RCU: Please do not set the Preemption Model to \"Preemptible Kernel\"; choose something else."
 	ERROR_LIB80211_CRYPT_TKIP="LIB80211_CRYPT_TKIP: You will need this for WPA."
 	if kernel_is ge 3 8 8; then
 	elif kernel_is ge 2 6 32; then
 	elif kernel_is ge 2 6 31; then
@@ -56,14 +56,12 @@
 src_prepare() {
-#	Makefile.patch: keep `emake install` working
-#	linux-3.9.0.patch: add support for kernel 3.9.0
-#	linux-3.10.0.patch: add support for kernel 3.10, bug #477372
-	epatch "${FILESDIR}/${P}-license.patch"
-	epatch "${FILESDIR}/${P}-makefile.patch"
-	epatch "${FILESDIR}/${P}-linux-recent.patch"
-	epatch "${FILESDIR}/${P}-eth-to-wlan.patch"
-	epatch "${FILESDIR}/${P}-gcc.patch"
+	epatch "${FILESDIR}/${P}-license.patch" \
+		"${FILESDIR}/${P}-makefile.patch" \
+		"${FILESDIR}/${P}-linux-recent.patch" \
+		"${FILESDIR}/${P}-eth-to-wlan.patch" \
+		"${FILESDIR}/${P}-gcc.patch" \
+		"${FILESDIR}/${P}-linux-3.15.patch"
Comment 4 rtlanceroad 2014-06-14 14:22:46 UTC
please update
Comment 5 Sven Vermeulen (RETIRED) gentoo-dev 2014-06-15 15:47:33 UTC
Created attachment 378948 [details]
Build failure

I tried to build the code but got the following failure.
Comment 6 M. B. 2014-06-16 20:06:42 UTC
Sven, would you mind testing it with instead of the patch which I posted here?
Comment 7 Sven Vermeulen (RETIRED) gentoo-dev 2014-06-17 07:54:01 UTC
Created attachment 379112 [details]
Build failure with different linux-3.15 patch

Still a build failure here.
Comment 8 Vladimir Miloserdov 2014-06-20 05:20:12 UTC
I've encountered this bug recently on linux-3.15.1.
Thanks to new ebuild by M.B. the problem was solved for me. Please update the tree. Why is it still unconfirmed? Is anyone working on this issue?

!!! CONFIG_PROTECT is empty
Portage 2.2.10 (default/linux/amd64/13.0/desktop, gcc-4.8.3, glibc-2.19-r1, 3.15.1-gentoo-gnu x86_64)
System uname: Linux-3.15.1-gentoo-gnu-x86_64-Intel-R-_Pentium-R-_CPU_2020M_@_2.40GHz-with-gentoo-2.2
KiB Mem:     1557676 total,    915020 free
KiB Swap:    4194300 total,   4194300 free
Timestamp of tree: Thu, 19 Jun 2014 10:15:01 +0000
ld GNU ld (Gentoo 2.24 p1.4) 2.24
app-shells/bash:          4.2_p47
dev-lang/python:          2.7.6-r1, 3.3.5, 3.4.0
dev-util/pkgconfig:       0.28-r1
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.12.4
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.69
sys-devel/automake:       1.12.6, 1.13.4, 1.14.1
sys-devel/binutils:       2.24-r3
sys-devel/gcc:            4.7.3-r1, 4.8.3
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2-r1
sys-devel/make:           4.0-r1
sys-kernel/linux-headers: 3.15 (virtual/os-headers)
sys-libs/glibc:           2.19-r1
Repositories: gentoo steam-overlay
ACCEPT_KEYWORDS="amd64 ~amd64"
CFLAGS="-march=native -mtune=native -Ofast -fomit-frame-pointer -pipe"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -mtune=native -Ofast -fomit-frame-pointer -pipe"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="X a52 aac acl acpi alsa amd64 apm atm bash-completion berkdb bluetooth branding bzip2 cairo cdda cdr cli consolekit cracklib crypt cryptsetup cups curl custom-cflags custom-cxxflags custom-optimization cxx dbus dga djvu dri dts dvd dvdr emacs emboss encode exif fam firefox flac fontconfig fortran ftp gdbm gif git gpm gstreamer gtk gtk3 gzip iconv icu imagemagick ipv6 jit jpeg jpeg2k latex lcms ldap libnotify lzma lzo mad mime mmx mng modules mp3 mp4 mpeg mtp multilib ncurses networkmanager nls nptl nsplugin offensive ogg openal opengl openmp pam pango pcre pdf png policykit posix ppds qt3support qt4 raw readline sdl session smp snmp sockets sound spell sse sse2 sse4 sse4_1 sse4_2 ssl ssse3 startup-notification svg syslog taglib tcpd threads tiff truetype udev udisks unicode upnp upower usb vaapi vdpau vim-syntax vorbis wavpack wifi wmf wxwidgets x264 xattr xcb xml xv xvid zlib" ABI_X86="64 32" ALSA_CARDS="hda-intel" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="pc" INPUT_DEVICES="synaptics evdev keyboard mouse void" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en_GB en_US en ru" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" RUBY_TARGETS="ruby19 ruby20" USERLAND="GNU" VIDEO_CARDS="intel i965" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Comment 9 M. B. 2014-06-22 06:14:27 UTC
So far my efforts have been in vain.
I am unable to reproduce the build failure and looking for similar bugs didn't turn up any solution :/

Suggestions on how to proceed in this case?
Comment 10 Eric Siskonen 2014-06-23 03:05:21 UTC
I can confirm your patch works for me just by placing it in /etc/portage/patches/net-wireless/broadcom-sta/. Thanks!
Comment 11 rtlanceroad 2014-06-23 13:45:37 UTC
Created attachment 379490 [details]
My build.log

This is my build.log. Thanks for M.B.'s ebuid and patch. We need someone to confirm.
Comment 12 Sven Vermeulen (RETIRED) gentoo-dev 2014-06-23 17:50:56 UTC
Okay, I've committed the ebuild and patch to the tree as there have been confirmed builds with the change & patch provided.

If someone can confirm that the portage tree provided one builds just fine for them, I can close the bug
Comment 13 Matt Turner gentoo-dev 2014-06-24 03:25:25 UTC
Works for me. Thanks!
Comment 14 Mark R. Pariente 2014-06-24 04:57:24 UTC
=net-wireless/broadcom-sta- complies fine against =sys-kernel/gentoo-sources-3.15.1 and works fine for me as well.
Comment 15 Sven Vermeulen (RETIRED) gentoo-dev 2014-06-24 17:07:17 UTC
Thanks for the validation.