Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 511692 - app-emulation/virt-manager doesn't depend on any of ssh-askpass implementations
Summary: app-emulation/virt-manager doesn't depend on any of ssh-askpass implementations
Status: RESOLVED DUPLICATE of bug 323775
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal minor (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-05-28 13:53 UTC by MarisN
Modified: 2014-05-28 13:59 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description MarisN 2014-05-28 13:53:49 UTC
virt-manager provides a mechanism to manage remote hosts via SSH. If SSH is using password based auth, virt-manager needs a working ssh-askpass to prompt user for a password. Currently virt-manager ebuild doesn't depend on any of ssh-askpass implementations and doesn't hint on possible options. Moreover installing any of ssh-askpass implementations does not automatically provide it to the virt-manager.

Reproducible: Always

Steps to Reproduce:
Install virt-manager and try to connect to any SSH host with password based auth. For testing needs the remote host even doesn't need to run anything else except SSH server with password based auth. 
Actual Results:  
An error message in virt-manager is printed and a suggestion to install ssh-askpass package is provided. The problem - Gentoo does not provide a generic ssh-askpass package, as there are multiple implementations available and some of them have name sshaskpass and thus might be missed by plain emerge -s.

Expected Results:  
ebuild should depend on any of askpass implementations or print a warning suggesting to install one.

virt-manager is searching for a /usr/lib64/misc/ssh-askpass thus i.e. in case of KDE askpass implementation, a symlink /usr/lib64/misc/ssh-askpass -> /usr/bin/ksshaskpass is required. A "eselect ssh-askpass" might be required to solve the issue.


app-emulation/virt-manager-0.10.0-r2
Portage 2.2.10 (default/linux/amd64/13.0/desktop, gcc-4.8.2, glibc-2.19, 3.13.1-gentoo x86_64)
Comment 1 Jeroen Roovers gentoo-dev 2014-05-28 13:59:22 UTC

*** This bug has been marked as a duplicate of bug 323775 ***