Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 510846 - dev-lua/lgi - add support for multiple dev-lang/lua versions (app-eselect/eselect-lua)
Summary: dev-lua/lgi - add support for multiple dev-lang/lua versions (app-eselect/ese...
Status: CONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Development (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Robin Johnson
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-05-20 12:09 UTC by Jeroen Roovers
Modified: 2018-07-22 02:46 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jeroen Roovers gentoo-dev 2014-05-20 12:09:54 UTC
Depending on which dev-lang/lua is eselected, dev-lua/lgi installs differently:

With 5.2, it installs the relevant files into /usr/share/lua/, notably /usr/share/lua/lgi.lua .

With 5.1 selected, it installs into /usr/share/lua/5.1/, including /usr/share/lua/5.1/lgi.lua .

It should probably install both, and then (a newer version of?) lua.eselect should set a default one symlinked at /usr/share/lua/lgi.lua, maybe?
Comment 1 Julian Ospald 2014-09-25 00:46:22 UTC
The eselect module is terrible crap, please don't support it. I hope it will be removed from the tree.
Comment 2 Dennis Schridde 2015-02-22 15:07:39 UTC
Please see bug #534150 for a draft of how dev-lua/* packages could be build against multiple versions of Lua.
Comment 3 Amel Hodzic 2018-07-22 02:46:52 UTC
bug #657722 should be helpful for this