Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 510070 - sys-boot/efibootmgr-0.11 version bump
Summary: sys-boot/efibootmgr-0.11 version bump
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: Normal normal with 2 votes (vote)
Assignee: Yannick Schaeffer
Depends on:
Blocks: 462705 502470 523196
  Show dependency tree
Reported: 2014-05-11 15:24 UTC by Yannick Schaeffer
Modified: 2014-11-26 00:46 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---

efibootmgr-0.9 ebuild (efibootmgr-0.9.0.ebuild,668 bytes, text/plain)
2014-10-10 07:23 UTC, Yannick Schaeffer
Ebuild for the required sys-libs/efivar-0.12 library (efivar-0.12.ebuild,411 bytes, text/plain)
2014-10-10 07:25 UTC, Yannick Schaeffer
Ebuild for sys-boot/efibootmgr-0.11.0 (efibootmgr-0.11.0.ebuild,669 bytes, text/plain)
2014-10-27 09:30 UTC, Yannick Schaeffer
Ebuild for sys-libs/efivar-0.15 (efivar-0.15.ebuild,411 bytes, text/plain)
2014-10-27 09:32 UTC, Yannick Schaeffer

Note You need to log in before you can comment on or make changes to this bug.
Description Yannick Schaeffer 2014-05-11 15:24:45 UTC
efibootmgr moved to github (
compared to version 0.6 this version new support the "new" efivarfs support (added in Linux 3.8)

Reproducible: Always
Comment 1 DJ Dunn 2014-05-29 05:14:00 UTC
this is important for AMD64, and any other arch that uses uefi
Comment 2 Andreas Hermann 2014-06-01 23:58:41 UTC
tried to build the new version 0.7.0, looks like it also needs 'efivar' library hosted at
Comment 3 gabriel14_wii 2014-07-11 21:26:37 UTC
We need a more updated ebuild of efibootmgr. I installed Gentoo on a UEFI with Archlinux. 

The efibootmgr(0.7) of Archlinux worked and could give me my efivars. When I chroot in the Gentoo environnement, efibootmgr(0.6) couldn't detech the efivars. I had to grab the latest git version, compile and it worked. I'm on AMD64.
Comment 4 Perfect Gentleman 2014-09-13 07:10:08 UTC
efivar should be added as RDEPEND
Comment 5 Yannick Schaeffer 2014-09-16 11:06:14 UTC
I've added an ebuild on my overlay :
Everything seems to work on my computer but feel free to repport any issues on gitHub issue tracker.
Comment 6 Yannick Schaeffer 2014-10-10 07:23:32 UTC
Created attachment 386356 [details]
efibootmgr-0.9 ebuild
Comment 7 Yannick Schaeffer 2014-10-10 07:25:01 UTC
Created attachment 386358 [details]
Ebuild for the required sys-libs/efivar-0.12 library
Comment 8 Yannick Schaeffer 2014-10-27 09:30:13 UTC
Created attachment 387510 [details]
Ebuild for sys-boot/efibootmgr-0.11.0

Require >=sys-libs/efivar-0.14
Comment 9 Yannick Schaeffer 2014-10-27 09:32:04 UTC
Created attachment 387514 [details]
Ebuild for sys-libs/efivar-0.15

new ebuild required by sys-boot/efibootmgr
Comment 10 Yannick Schaeffer 2014-10-28 12:24:23 UTC
Thoses ebuilds (efibootmgr-0.11.0 and the required sys-libs/efivar) should fix the following bugs 462705, 502470, 523196
Comment 11 Cedric Sodhi 2014-11-15 17:00:07 UTC
We're still suck with an ancient 0.5.4-r1 in stable and 0.6.0 on ~amd64! Why is this still only in the overlay, it's needed urgently!?
Comment 12 Mike Gilbert gentoo-dev 2014-11-25 18:56:12 UTC
I'll look this over later today.
Comment 13 Mike Gilbert gentoo-dev 2014-11-26 00:46:33 UTC
Should be all set here.

+*efivar-0.15 (26 Nov 2014)
+  26 Nov 2014; Mike Gilbert <> +efivar-0.15.ebuild,
+  +metadata.xml:
+  New package, dependency of sys-boot/efibootmgr. Ebuild by Yannick Schaeffer,
+  bug 510070.

+*efibootmgr-0.11.0 (26 Nov 2014)
+  26 Nov 2014; Mike Gilbert <> +efibootmgr-0.11.0.ebuild,
+  metadata.xml:
+  Version bump, bug 510070. Thanks to Yannick Schaeffer.