Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 510064 - install-amd64-minimal-20140508.iso incompatible with USB controllers on ASUS maximus extreme VI motherboard
Summary: install-amd64-minimal-20140508.iso incompatible with USB controllers on ASUS ...
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Release Media
Classification: Unclassified
Component: InstallCD (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Gentoo Release Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-05-11 13:05 UTC by brad
Modified: 2014-06-22 12:13 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description brad 2014-05-11 13:05:51 UTC
I have tried with numerous LiveCD ISO images, both older and current stable.
Every time it's the same error. I have 2 maximus extreme VI mb and the error is duplicated on each.

The motherboard settings are default except for PCIe set to Gen2 due to my r9 280x sapphire video card
I have tried various USB settings in the one area of the BIOS gui that references USB and nothing changes the error.

Description:
Boot to live CD, and ask for boot: , you tap the keyboard once and you see mdev load and it get's to key maps but the first thing you notice is the keyboard no longer works. That times out, and then the install dies a couple of lines later because it can no longer read the USB DVD-RW which has the iso in it.

I have successfully installed Ubuntu, Win8 and Win7 on the board with the same hardware config.
Gentoo borks at mdev.
Comment 1 brad 2014-05-11 13:06:39 UTC
I can't get this far. Even on the live cd
Comment 2 brad 2014-05-11 14:20:56 UTC
I have tried with and without legacy USB.
The board also has and HCIx hands off feature, this has no effect.
Comment 3 Jeroen Roovers (RETIRED) gentoo-dev 2014-05-11 16:21:08 UTC
What LiveCD ISO images? Please post the URLs you used to fetch the images.
Comment 4 brad 2014-05-11 18:45:24 UTC
http://distfiles.gentoo.org/releases/amd64/current-iso/
install-amd64-minimal-20140508.iso
md5:  27ae516e0a433da4667eebb4c2895d41

I don't recall the URL from the older image
install-amd64-minimal-20140403.iso
md5:  5961618e379b8f25ca7e062b0a8c9d27
Comment 5 Jeroen Roovers (RETIRED) gentoo-dev 2014-05-12 00:36:50 UTC
Can you also show the lspci output for that system?
Comment 6 brad 2014-05-12 05:53:59 UTC
Hmmm, I don't think I ever got Ubuntu to work on this board. I ordered 2 maximus extremes and 1 Z87-PLUS. I think Ubuntu only worked on the z87-plus

Booting from Finnix, SystemRescue disk and Ubuntu right now fails in the exact same way.
Board boots up fine with windows. I am presently trying to overwrite windows but can't get that far.

lspci does not seem possible with this board.
Why every Linux fails and winblows doesn't, I have no idea.
Same issue, both extreme boards and one was just plugged in for the first time today after being RMA'ed.
Comment 8 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2014-05-12 11:08:41 UTC
From your comments, this seems to be better suited for upstream kernel. We can't enable the support for hardware that isn't supported by the kernel.
Comment 9 brad 2014-05-12 23:23:58 UTC
bad boards. a double whammy
Comment 10 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2014-06-22 12:13:52 UTC
I'm going to close this bug as there's nothing we can do here.
If / when the kernel gets a workaround or your board manufacturer releases a firmware updates that fixes this issue, if you try to install Gentoo again and hit any issues, please open a new bug.