Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 510044 - app-editors/gedit-3.12.2 preference dialog doesn't show anything
Summary: app-editors/gedit-3.12.2 preference dialog doesn't show anything
Status: RESOLVED TEST-REQUEST
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-05-11 10:20 UTC by Paolo
Modified: 2014-06-25 14:37 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
screenshot of the problem (bug.png,5.46 KB, image/png)
2014-05-11 10:20 UTC, Paolo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Paolo 2014-05-11 10:20:39 UTC
Created attachment 376720 [details]
screenshot of the problem

I just updated from Gnome 3.10 to Gnome 3.12 and all went fine, everything works except one thing from GEdit: the preference dialog doesn't show anything.
This is what i get if i run GEdit from terminal and click in "Preferences":


(gedit:32020): Gtk-CRITICAL **: Error building template class 'GeditPreferencesDialog' for an instance of type 'GeditPreferencesDialog': Invalid object type `PeasGtkPluginManager'

(gedit:32020): GLib-GIO-CRITICAL **: g_settings_bind_with_mapping: assertion 'G_IS_OBJECT (object)' failed

(gedit:32020): GLib-GIO-CRITICAL **: g_settings_bind_with_mapping: assertion 'G_IS_OBJECT (object)' failed

(gedit:32020): GLib-GIO-CRITICAL **: g_settings_bind_with_mapping: assertion 'G_IS_OBJECT (object)' failed

(gedit:32020): GLib-GIO-CRITICAL **: g_settings_bind_with_mapping: assertion 'G_IS_OBJECT (object)' failed

(gedit:32020): GLib-GIO-CRITICAL **: g_settings_bind_with_mapping: assertion 'G_IS_OBJECT (object)' failed

(gedit:32020): GLib-GIO-CRITICAL **: g_settings_bind_with_mapping: assertion 'G_IS_OBJECT (object)' failed

(gedit:32020): GLib-GIO-CRITICAL **: g_settings_bind_with_mapping: assertion 'G_IS_OBJECT (object)' failed

(gedit:32020): GLib-GIO-CRITICAL **: g_settings_bind_with_mapping: assertion 'G_IS_OBJECT (object)' failed

(gedit:32020): Gtk-CRITICAL **: gtk_toggle_button_set_active: assertion 'GTK_IS_TOGGLE_BUTTON (toggle_button)' failed

(gedit:32020): Gtk-CRITICAL **: gtk_toggle_button_set_active: assertion 'GTK_IS_TOGGLE_BUTTON (toggle_button)' failed

(gedit:32020): Gtk-CRITICAL **: gtk_toggle_button_set_active: assertion 'GTK_IS_TOGGLE_BUTTON (toggle_button)' failed

(gedit:32020): Gtk-CRITICAL **: gtk_widget_set_sensitive: assertion 'GTK_IS_WIDGET (widget)' failed

(gedit:32020): GLib-GIO-CRITICAL **: g_settings_bind_with_mapping: assertion 'G_IS_OBJECT (object)' failed

(gedit:32020): GLib-GIO-CRITICAL **: g_settings_bind_with_mapping: assertion 'G_IS_OBJECT (object)' failed

(gedit:32020): GLib-GIO-CRITICAL **: g_settings_bind_with_mapping: assertion 'G_IS_OBJECT (object)' failed

(gedit:32020): GLib-GIO-CRITICAL **: g_settings_bind_with_mapping: assertion 'G_IS_OBJECT (object)' failed

(gedit:32020): GLib-GIO-CRITICAL **: g_settings_bind_with_mapping: assertion 'G_IS_OBJECT (object)' failed

(gedit:32020): GLib-GIO-CRITICAL **: g_settings_bind_with_mapping: assertion 'G_IS_OBJECT (object)' failed

(gedit:32020): GLib-GIO-CRITICAL **: g_settings_bind_with_mapping: assertion 'G_IS_OBJECT (object)' failed
sys:1: Warning: invalid (NULL) pointer instance
sys:1: Warning: g_signal_connect_data: assertion 'G_TYPE_CHECK_INSTANCE (instance)' failed

(gedit:32020): Gtk-CRITICAL **: gtk_widget_set_tooltip_text: assertion 'GTK_IS_WIDGET (widget)' failed

(gedit:32020): Gtk-CRITICAL **: gtk_widget_get_accessible: assertion 'GTK_IS_WIDGET (widget)' failed

(gedit:32020): Gtk-CRITICAL **: gtk_widget_get_accessible: assertion 'GTK_IS_WIDGET (widget)' failed

(gedit:32020): Gtk-CRITICAL **: gtk_widget_get_accessible: assertion 'GTK_IS_WIDGET (widget)' failed

(gedit:32020): Gtk-CRITICAL **: gtk_widget_get_accessible: assertion 'GTK_IS_WIDGET (widget)' failed

(gedit:32020): Gtk-CRITICAL **: gtk_button_set_label: assertion 'GTK_IS_BUTTON (button)' failed

(gedit:32020): GLib-GIO-CRITICAL **: g_settings_bind_with_mapping: assertion 'G_IS_OBJECT (object)' failed

(gedit:32020): GLib-GIO-CRITICAL **: g_settings_bind_with_mapping: assertion 'G_IS_OBJECT (object)' failed

(gedit:32020): GLib-GIO-CRITICAL **: g_settings_bind_with_mapping: assertion 'G_IS_OBJECT (object)' failed

(gedit:32020): Gtk-CRITICAL **: gtk_cell_layout_set_cell_data_func: assertion 'GTK_IS_CELL_LAYOUT (cell_layout)' failed

(gedit:32020): Gtk-CRITICAL **: gtk_tree_view_get_selection: assertion 'GTK_IS_TREE_VIEW (tree_view)' failed

(gedit:32020): Gtk-CRITICAL **: gtk_tree_selection_set_mode: assertion 'GTK_IS_TREE_SELECTION (selection)' failed

(gedit:32020): Gtk-CRITICAL **: gtk_list_store_clear: assertion 'GTK_IS_LIST_STORE (list_store)' failed

(gedit:32020): Gtk-CRITICAL **: gtk_list_store_append: assertion 'GTK_IS_LIST_STORE (list_store)' failed

(gedit:32020): Gtk-CRITICAL **: gtk_list_store_set_valist: assertion 'GTK_IS_LIST_STORE (list_store)' failed

(gedit:32020): Gtk-CRITICAL **: gtk_list_store_append: assertion 'GTK_IS_LIST_STORE (list_store)' failed

(gedit:32020): Gtk-CRITICAL **: gtk_list_store_set_valist: assertion 'GTK_IS_LIST_STORE (list_store)' failed

(gedit:32020): Gtk-CRITICAL **: gtk_list_store_append: assertion 'GTK_IS_LIST_STORE (list_store)' failed

(gedit:32020): Gtk-CRITICAL **: gtk_list_store_set_valist: assertion 'GTK_IS_LIST_STORE (list_store)' failed

(gedit:32020): Gtk-CRITICAL **: gtk_list_store_append: assertion 'GTK_IS_LIST_STORE (list_store)' failed

(gedit:32020): Gtk-CRITICAL **: gtk_list_store_set_valist: assertion 'GTK_IS_LIST_STORE (list_store)' failed

(gedit:32020): Gtk-CRITICAL **: gtk_tree_view_get_selection: assertion 'GTK_IS_TREE_VIEW (tree_view)' failed

(gedit:32020): Gtk-CRITICAL **: gtk_tree_selection_select_iter: assertion 'GTK_IS_TREE_SELECTION (selection)' failed

(gedit:32020): Gtk-CRITICAL **: gtk_list_store_append: assertion 'GTK_IS_LIST_STORE (list_store)' failed

(gedit:32020): Gtk-CRITICAL **: gtk_list_store_set_valist: assertion 'GTK_IS_LIST_STORE (list_store)' failed

(gedit:32020): Gtk-CRITICAL **: gtk_list_store_append: assertion 'GTK_IS_LIST_STORE (list_store)' failed

(gedit:32020): Gtk-CRITICAL **: gtk_list_store_set_valist: assertion 'GTK_IS_LIST_STORE (list_store)' failed

(gedit:32020): Gtk-CRITICAL **: gtk_list_store_append: assertion 'GTK_IS_LIST_STORE (list_store)' failed

(gedit:32020): Gtk-CRITICAL **: gtk_list_store_set_valist: assertion 'GTK_IS_LIST_STORE (list_store)' failed

(gedit:32020): Gtk-CRITICAL **: gtk_widget_get_style_context: assertion 'GTK_IS_WIDGET (widget)' failed

(gedit:32020): Gtk-CRITICAL **: gtk_style_context_set_junction_sides: assertion 'GTK_IS_STYLE_CONTEXT (context)' failed

(gedit:32020): Gtk-CRITICAL **: gtk_widget_get_style_context: assertion 'GTK_IS_WIDGET (widget)' failed

(gedit:32020): Gtk-CRITICAL **: gtk_style_context_set_junction_sides: assertion 'GTK_IS_STYLE_CONTEXT (context)' failed

(gedit:32020): Gtk-CRITICAL **: gtk_widget_set_sensitive: assertion 'GTK_IS_WIDGET (widget)' failed

(gedit:32020): Gtk-CRITICAL **: gtk_widget_show_all: assertion 'GTK_IS_WIDGET (widget)' failed
Comment 1 Pacho Ramos gentoo-dev 2014-05-11 10:26:04 UTC
Try running it from a terminal to see if some errors are shown while reproducing the problem
Comment 2 Gilles Dartiguelongue gentoo-dev 2014-05-11 10:33:31 UTC
What version of libpeas do you have installed ?
Comment 3 Paolo 2014-05-11 10:51:49 UTC
@gilles:
[ebuild   R   #] dev-libs/libpeas-1.10.0  USE="gtk python -glade -seed {-test}" PYTHON_TARGETS="python2_7 python3_3 (-python2_6) -python3_2" 0 kB

@pachos: i posted the terminal output in my first comment :) i didn't get any errors before i clicked on the "Preference" menu.
Comment 4 Pacho Ramos gentoo-dev 2014-05-27 18:55:44 UTC
I cannot reproduce this with:
[ebuild   R   #] app-editors/gedit-3.12.1  USE="introspection python spell {test} -zeitgeist" PYTHON_TARGETS="python3_3 -python3_2" 0 kB
[ebuild   R   #] dev-libs/libpeas-1.10.0  USE="gtk python {test*} -glade -seed" PYTHON_TARGETS="python2_7 python3_3 (-python2_6) -python3_2" 0 kB
Comment 5 Paolo 2014-05-28 17:03:35 UTC
This is mine:

[ebuild   R   #] dev-libs/libpeas-1.10.0  USE="gtk python -glade -seed {-test}" PYTHON_TARGETS="python2_7 python3_3 (-python2_6) -python3_2" 0 kB
[ebuild   R   #] app-editors/gedit-3.12.1  USE="introspection python spell {-test} -zeitgeist" PYTHON_TARGETS="python3_3 -python3_2" 0 kB


i cannot undestand why i got this error :-/
i tried to rebuild: gtk, glib, libpeas and gedit but nothing changed...
Comment 6 Paolo 2014-05-28 17:13:37 UTC
i tried to compile gedit from sources downloaded from ftp.gnome.org and all works perfectly :O
Comment 7 Paolo 2014-05-28 18:02:29 UTC
I manually compiled and installed Gedit with the same 'enable-disable' features that are inside the Gentoo ebuild and it works perfectly.
This is very strange xD
Comment 8 Evgeny Bobkin 2014-05-29 09:49:47 UTC
(In reply to Paolo Stivanin from comment #7)
> I manually compiled and installed Gedit with the same 'enable-disable'
> features that are inside the Gentoo ebuild and it works perfectly.
> This is very strange xD

indeed, I can not reproduce it here as well.

maybe try to add an autoreconf call to the ebuild, and see if it helps
Comment 9 Paolo 2014-05-29 11:35:41 UTC
using `autoreconf` instead of `gnome2_src_prepare` solved my problem :)
Comment 10 Pacho Ramos gentoo-dev 2014-05-29 19:31:00 UTC
gnome2_src_prepare is running this commands, maybe you could try when you start to get the problems:
gnome2_environment_reset
gnome2_omf_fix
gnome2_disable_deprecation_warning
elibtoolize
Comment 11 Paolo 2014-05-31 08:49:41 UTC
nothing!
it works if use only autoreconf!
Comment 12 Pacho Ramos gentoo-dev 2014-05-31 08:53:45 UTC
Does:
eautoreconf
gnome2_src_prepare

work for you then?
Comment 13 Pacho Ramos gentoo-dev 2014-06-18 16:55:56 UTC
(In reply to Pacho Ramos from comment #12)
> Does:
> eautoreconf
> gnome2_src_prepare
> 
> work for you then?

Also try with a fully updated system
Comment 14 Paolo 2014-06-19 17:08:17 UTC
the system is updated daily :)
however it doesn't work.
I don't understand why...
Comment 15 Pacho Ramos gentoo-dev 2014-06-21 19:53:34 UTC
The most ugly thing is that I cannot reproduce at all. Did you try comment #12 suggestion?
Comment 16 Paolo 2014-06-24 10:03:53 UTC
yes, i tried and it didn't work!
I saw that i am not the only one with this bug (https://bugs.launchpad.net/ubuntu/+source/gedit/+bug/1325063) so it is an upstream bug not a gentoo related one!
Comment 17 Pacho Ramos gentoo-dev 2014-06-24 10:59:15 UTC
Then, maybe an upstream bug report to bugzilla.gnome.org could help :/
Comment 18 Alexandre Rostovtsev (RETIRED) gentoo-dev 2014-06-24 12:24:51 UTC
Can you reproduce this problem after rebuilding gedit *without* eautoreconf? Just using the normal ebuild from the portage tree?

My suspicion is this is some sort of libpeas ABI weirdness (e.g. if libpeas-1.9.0 was built against gtk+-3.10, it's incompatible with libpeas-1.10.0 built against gtk+-3.12) which doesn't show up if simply recompiling gedit in gnome-3.12.
Comment 19 Paolo 2014-06-25 10:18:55 UTC
@alexandre: but i haven't libpeas 1.9.0 installed in my system.
The weird thing is that if I compile gedit from the vanilla sources (taken from the gnome ftp) it is all ok (i tried with gedit 3.12.0,1,2).
Comment 20 Alexandre Rostovtsev (RETIRED) gentoo-dev 2014-06-25 14:21:26 UTC
Paolo, again, can you reproduce this problem after rebuilding gedit using the normal ebuild from the portage tree, without adding eautoreconf?
Comment 21 Paolo 2014-06-25 14:37:12 UTC
yes, the problem is still here :(