Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 510020 - x11-drivers/nvidia-drivers-96.43.23: Patches for kernels >3.7
Summary: x11-drivers/nvidia-drivers-96.43.23: Patches for kernels >3.7
Status: RESOLVED DUPLICATE of bug 447566
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Jeroen Roovers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-05-11 05:34 UTC by Roger
Modified: 2014-05-12 01:15 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
173.14.36-37-gentoo.patch (173.14.36-37-gentoo.patch,181.83 KB, patch)
2014-05-11 05:42 UTC, Roger
Details | Diff
173.14.37-38-gentoo.patch (173.14.37-38-gentoo.patch,90.47 KB, patch)
2014-05-11 05:43 UTC, Roger
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Roger 2014-05-11 05:34:02 UTC
I've found several patches which enable compiling nvidia-drivers-96.43.23 against kernels >3.7

Currently, compiling nvidia-drivers-96.43.23.ebuild against any kernel version greater than kerne-3.7 not only complains, but also fails with the same old vague "Unable to determine the target kernel version" error.

The two patch files names are 173.14.36-37.patch and 173.14.37-38.patch. They were apart of Arch Linux and after some searching, I found them here:
http://github.com/City-busz/city-repository/tree/master/nvidia-96xx-lts

The site also includes a build package file (or PKGBUILD), explaining the depends or limits of the additional patches.

I'm not quite sure what exactly the two patches do yet, as it took some time to apply the patches against gentoo-sources-3.12.13, but the two patches do successfully compile.  I shall test a little later on, but would imagine they work.

Reproducible: Always




NOTE: These so far still appear to offer no support beyond xorg-server-1.12
Comment 1 Roger 2014-05-11 05:42:35 UTC
Created attachment 376704 [details, diff]
173.14.36-37-gentoo.patch

Suffixed "-gentoo" to indicate ported to gentoo, retaining the original file name for historical references.  Change the name as you see fit, but application order may break patching.
Comment 2 Roger 2014-05-11 05:43:03 UTC
Created attachment 376706 [details, diff]
173.14.37-38-gentoo.patch

Suffixed "-gentoo" to indicate ported to gentoo, retaining the original file name for historical references.  Change the name as you see fit, but application order may break patching.
Comment 3 Roger 2014-05-11 05:46:13 UTC
I also had to manually "chmod -R a+rwX" on both /usr/src/linux & /lib/modules prior to emerging or installing.  (chown -R portage.portage or root.root might also be applicable, or there might be a FEATURES flag to avoid this file permissions problem.)
Comment 4 Roger 2014-05-11 05:48:36 UTC
As I previously mentioned concerning file permissions, I'll revert the permissions and debug a little later to get the specific correct chown or chmod incantation.  (Wish they had an "edit button" on this Bugzilla so I could merrily edit or change my own posts versus having a conversation with myself.)
Comment 5 Roger 2014-05-11 05:58:35 UTC
YES!

These patches work for =x11-drivers/nvidia-drivers-96.43.23 for building against =sys-kernel/gentoo-sources-3.12.13 using =sys-kernel/linux-headers-3.9, for which are the latest stable packages.
Comment 6 Jeroen Roovers gentoo-dev 2014-05-11 15:36:36 UTC

*** This bug has been marked as a duplicate of bug 447566 ***
Comment 7 Roger 2014-05-12 01:15:56 UTC
Might be a good idea to allow one of these bugs related to nvidia-drivers-96xx building against the kernel to remain open, so users can easily find and patch their own installations on their own.

With these bugs marked closed, they're much harder to find and sort from the many other closed bugs.  (I figure my old laptop has one or two more years of good use.  And in a third world country, might still be usable for a decade or so.)