Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 508762 - >=sys-apps/portage-2.2.9: slot conflict involving slot operator and subslot updates
Summary: >=sys-apps/portage-2.2.9: slot conflict involving slot operator and subslot u...
Status: RESOLVED FIXED
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Core (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords: InVCS
: 511702 520856 (view as bug list)
Depends on:
Blocks: 155723 484436 717140
  Show dependency tree
 
Reported: 2014-04-26 11:59 UTC by Kobboi
Modified: 2020-04-11 22:34 UTC (History)
9 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
0001-Fix-bug-that-prevented-some-rebuilds.patch (0001-Fix-bug-that-prevented-some-rebuilds.patch,845 bytes, patch)
2014-04-26 18:18 UTC, Sebastian Luther (few)
Details | Diff
debug.log - 9999 with 0001 patch (debug.log.tgz,643.89 KB, application/x-compressed-tar)
2014-04-27 13:36 UTC, Kobboi
Details
debug.log using portage-9999 (2.2.12_p12) (debug.log.xz,324.13 KB, application/x-xz)
2014-09-01 05:56 UTC, Garri
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kobboi 2014-04-26 11:59:11 UTC
With portage-2.2.8, emerge -avuDN world gives me:

$ sudo emerge -avuDN world

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  r  U  ] x11-base/xorg-server-1.15.1:0/1.15.1 [1.15.0:0/1.15.0] USE="ipv6 kdrive nptl suid udev xnest xorg xvfb -dmx -doc -minimal (-selinux) -static-libs -tslib -unwind" 5,361 kB
[ebuild  rR    ] x11-drivers/xf86-input-mouse-1.9.0  346 kB
[ebuild  rR    ] x11-drivers/xf86-input-evdev-2.8.2  362 kB
[ebuild  rR    ] x11-libs/glamor-0.6.0-r1  USE="xv -gles -static-libs" 0 kB
[ebuild  rR    ] x11-drivers/xf86-input-synaptics-1.7.4  0 kB
[ebuild  rR    ] x11-drivers/xf86-input-keyboard-1.7.0  312 kB
[ebuild  rR    ] x11-drivers/xf86-video-intel-2.99.911  USE="dri glamor sna udev uxa xvmc -debug" 0 kB
[ebuild     U *] sys-apps/portage-9999 [2.2.8-r1] USE="(ipc) xattr -build -doc -epydoc (-pypy) -python2 -python3 (-selinux) (-pypy2_0%)" LINGUAS="-ru" PYTHON_TARGETS="python2_7 python3_3 -pypy% (-pypy2_0) -python2_6 -python3_2 -python3_4" 0 kB

Total: 8 packages (2 upgrades, 6 reinstalls), Size of downloads: 6,379 kB

The following packages are causing rebuilds:

  (x11-base/xorg-server-1.15.1::gentoo, ebuild scheduled for merge) causes rebuilds for:
    (x11-drivers/xf86-input-keyboard-1.7.0::gentoo, ebuild scheduled for merge)
    (x11-drivers/xf86-video-intel-2.99.911::gentoo, ebuild scheduled for merge)
    (x11-drivers/xf86-input-synaptics-1.7.4::gentoo, ebuild scheduled for merge)
    (x11-libs/glamor-0.6.0-r1::gentoo, ebuild scheduled for merge)
    (x11-drivers/xf86-input-mouse-1.9.0::gentoo, ebuild scheduled for merge)
    (x11-drivers/xf86-input-evdev-2.8.2::gentoo, ebuild scheduled for merge)

With portage-2.2.10 and 9999 (20140426), emerge -avuDN world gives me:

$ sudo emerge -avuDN world

These are the packages that would be merged, in order:

Calculating dependencies... done!

Total: 0 packages, Size of downloads: 0 KiB

WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:

x11-base/xorg-server:0

  (x11-base/xorg-server-1.15.1:0/1.15.1::gentoo, ebuild scheduled for merge) conflicts with
    x11-base/xorg-server:0/1.15.0= required by (x11-libs/glamor-0.6.0-r1:0/0::gentoo, installed)
                        ^^^^^^^^^^
    x11-base/xorg-server:0/1.15.0= required by (x11-drivers/xf86-video-intel-2.99.911:0/0::gentoo, installed)
                        ^^^^^^^^^^
    x11-base/xorg-server:0/1.15.0= required by (x11-drivers/xf86-input-synaptics-1.7.4:0/0::gentoo, installed)
                        ^^^^^^^^^^
    x11-base/xorg-server:0/1.15.0= required by (x11-drivers/xf86-input-mouse-1.9.0:0/0::gentoo, installed)
                        ^^^^^^^^^^
    x11-base/xorg-server:0/1.15.0= required by (x11-drivers/xf86-input-keyboard-1.7.0:0/0::gentoo, installed)
                        ^^^^^^^^^^
    x11-base/xorg-server:0/1.15.0= required by (x11-drivers/xf86-input-evdev-2.8.2:0/0::gentoo, installed)
                        ^^^^^^^^^^


Nothing to merge; quitting.


Reproducible: Always
Comment 1 Sebastian Luther (few) 2014-04-26 18:18:35 UTC
Created attachment 375794 [details, diff]
0001-Fix-bug-that-prevented-some-rebuilds.patch

Please try this patch and report back.
Comment 2 Sebastian Luther (few) 2014-04-26 20:07:50 UTC
If this doesn't help, attach the debug.log created by:

emerge -avuDN world -pd &>debug.log
Comment 3 Kobboi 2014-04-27 13:36:43 UTC
Created attachment 375848 [details]
debug.log - 9999 with 0001 patch
Comment 4 Kobboi 2014-04-27 13:38:15 UTC
 * Fetching git://git.overlays.gentoo.org/proj/portage.git ...
git fetch git://git.overlays.gentoo.org/proj/portage.git +HEAD:refs/git-r3/HEAD
git symbolic-ref refs/git-r3/sys-apps/portage/0/__main__ refs/heads/master
 * Checking out git://git.overlays.gentoo.org/proj/portage.git to /var/tmp/portage/sys-apps/portage-9999/work/portage-9999 ...
git checkout --quiet master
GIT update -->
   repository:               git://git.overlays.gentoo.org/proj/portage.git
   at the commit:            de71f70eac5f8f82d739c2d6e5da8e7680e89efe
>>> Source unpacked in /var/tmp/portage/sys-apps/portage-9999/work
>>> Preparing source in /var/tmp/portage/sys-apps/portage-9999/work/portage-9999 ...
 * Applying user patches from /etc/portage/patches//sys-apps/portage ...
 *   0001-Fix-bug-that-prevented-some-rebuilds.patch ...                           [ ok ]
 * Done with patching

Issue still present, debug.log.tgz attached
Comment 5 Kobboi 2014-05-27 08:37:54 UTC
Anything else I can do here? Otherwise I will probably downgrade portage to get around this and we will lose the ability to investigate.
Comment 6 Kobboi 2014-05-29 18:20:16 UTC
See also #511702 ?
Comment 7 Markus Oehme 2014-06-02 20:18:46 UTC
Hi I see the same problem on ~amd64 with portage 2.2.10. Currently installed is xorg-server-1.15.1 and the upgrade to 1.15.99.902-r2 fails with the following error.

x11-base/xorg-server:0

  (x11-base/xorg-server-1.15.99.902-r2:0/1.15.99.902::gentoo, ebuild scheduled for merge) conflicts with
    x11-base/xorg-server:0/1.15.1= required by (x11-drivers/xf86-input-evdev-2.8.4:0/0::gentoo, installed)
                        ^^^^^^^^^^
    x11-base/xorg-server:0/1.15.1= required by (x11-drivers/xf86-video-intel-2.99.911-r1:0/0::gentoo, installed)
                        ^^^^^^^^^^
Comment 8 Mark Tomich 2014-06-18 12:47:49 UTC
+1
Comment 9 Mark Tomich 2014-06-18 12:55:47 UTC
FTR, the following worked around the issue for me (causing rebuilds for all the dependent packages):

> emerge -av1 =x11-base/xorg-server-1.15.99.903
Comment 10 Kobboi 2014-08-10 09:56:35 UTC
Still here on portage-2.2.11-r1
Comment 11 Kobboi 2014-08-23 10:01:37 UTC
Still present in portage 2.2.12
Comment 12 Garri 2014-09-01 05:56:43 UTC
Created attachment 384040 [details]
debug.log using portage-9999 (2.2.12_p12)

Same problems still in portage-9999 (2.2.12_p12):


------------------------
x11-base/xorg-server:0

  (x11-base/xorg-server-1.16.0:0/1.16.0::gentoo, ebuild scheduled for merge) conflicts with
    x11-base/xorg-server:0/1.15.99.903= required by (x11-drivers/xf86-input-synaptics-1.7.6:0/0::gentoo, installed)
                        ^^^^^^^^^^^^^^^
    x11-base/xorg-server:0/1.15.99.903= required by (x11-libs/glamor-0.6.0-r1:0/0::gentoo, installed)
                        ^^^^^^^^^^^^^^^
    x11-base/xorg-server:0/1.15.99.903= required by (x11-drivers/xf86-video-ati-7.4.0:0/0::gentoo, installed)
                        ^^^^^^^^^^^^^^^
    x11-base/xorg-server:0/1.15.99.903= required by (x11-drivers/xf86-video-intel-2.99.912-r1:0/0::gentoo, installed)
                        ^^^^^^^^^^^^^^^
    x11-base/xorg-server:0/1.15.99.903= required by (x11-drivers/xf86-input-evdev-2.8.4:0/0::gentoo, installed)
                        ^^^^^^^^^^^^^^^
--------------

Output from 'emerge -av --update --deep --newuse --with-bdeps=y @world -pd &>/tmp/debug.log' in attachment

--------------

'emerge -av1 xorg-server' solves the problem:


These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  r  U  ] x11-base/xorg-server-1.16.0:0/1.16.0 [1.15.99.903:0/1.15.99.903] USE="kdrive nptl suid systemd udev xorg -dmx -doc (-glamor) -ipv6 -minimal (-selinux) -static-libs -tslib -unwind -wayland -xnest -xvfb" 5,697 KiB
[ebuild  rR    ] x11-drivers/xf86-input-evdev-2.8.4  0 KiB
[ebuild  rR    ] x11-libs/glamor-0.6.0-r1  USE="xv -gles -static-libs" 0 KiB
[ebuild  r  U  ] x11-drivers/xf86-video-intel-2.99.914 [2.99.912-r1] USE="dri sna udev -debug -glamor -uxa -xvmc" 2,189 KiB
[ebuild  rR    ] x11-drivers/xf86-input-synaptics-1.7.6  0 KiB
[ebuild  rR    ] x11-drivers/xf86-video-ati-7.4.0  USE="glamor udev" 0 KiB

Total: 6 packages (2 upgrades, 4 reinstalls), Size of downloads: 7,885 KiB

The following packages are causing rebuilds:

  (x11-base/xorg-server-1.16.0:0/1.16.0::gentoo, ebuild scheduled for merge) causes rebuilds for:
    (x11-libs/glamor-0.6.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (x11-drivers/xf86-input-synaptics-1.7.6:0/0::gentoo, ebuild scheduled for merge)
    (x11-drivers/xf86-input-evdev-2.8.4:0/0::gentoo, ebuild scheduled for merge)
    (x11-drivers/xf86-video-ati-7.4.0:0/0::gentoo, ebuild scheduled for merge)
    (x11-drivers/xf86-video-intel-2.99.914:0/0::gentoo, ebuild scheduled for merge)
Comment 13 Zac Medico gentoo-dev 2014-09-01 16:40:47 UTC
*** Bug 520856 has been marked as a duplicate of this bug. ***
Comment 14 Zac Medico gentoo-dev 2014-09-01 16:41:40 UTC
The patch attached to bug 508762 handles more cases.
Comment 15 Zac Medico gentoo-dev 2014-09-01 16:44:02 UTC
*** Bug 511702 has been marked as a duplicate of this bug. ***
Comment 16 Zac Medico gentoo-dev 2014-09-01 17:05:08 UTC
I've pushed the patch attached to bug 520856 as commit d569a2d7275c65f991ea0e9648edf9458be240fa.
Comment 17 Zac Medico gentoo-dev 2014-09-01 17:16:46 UTC
(In reply to Zac Medico from comment #14)
> The patch attached to bug 508762 handles more cases.

I meant the patch attached to bug 520856 which is in git now:

https://github.com/gentoo/portage/commit/d569a2d7275c65f991ea0e9648edf9458be240fa
Comment 18 Zac Medico gentoo-dev 2014-09-17 17:46:40 UTC
This is fixed in 2.2.13.

Note that bug 523048 has a similar symptom, but it is cause by unsatisfied REQUIRED_USE.