Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 508072 - mate-base/mate keyword request
Summary: mate-base/mate keyword request
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Keywording and Stabilization (show other bugs)
Hardware: All Linux
: Normal enhancement (vote)
Assignee: Gentoo MATE Desktop
URL:
Whiteboard:
Keywords: KEYWORDREQ
: 551590 555522 (view as bug list)
Depends on: 512040 512042 512044 512046 551588
Blocks:
  Show dependency tree
 
Reported: 2014-04-19 10:47 UTC by Jens-Uwe Peter
Modified: 2016-05-31 03:04 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
MATE 1.8 ARM dependencies that need arm keyword. (file_508072.txt,256 bytes, text/plain)
2014-06-01 13:16 UTC, Tom Wijsman (TomWij) (RETIRED)
Details
MATE 1.8 keywording list (file_508072.txt,1.19 KB, text/plain)
2014-06-01 13:18 UTC, Tom Wijsman (TomWij) (RETIRED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jens-Uwe Peter 2014-04-19 10:47:25 UTC
As the Mate Desktop Environment is especially for low power computer it should be keyworded not only ~amd64 but also ~x86, maybe ~arm. On x86 it is running fine in the state being.
Comment 1 Tom Wijsman (TomWij) (RETIRED) gentoo-dev 2014-05-01 17:23:41 UTC
Added arm to CC list, Zero_Chaos was planning to try to keyword this afaik.

To get a list of ebuilds to keyword, one can do:

    grep --include='*.ebuild' -rl mate-desktop /usr/portage/ | sort

Alternatively, one can use the stabilization list of bug #509268; although, those don't contain the new MATE 1.8 packages (as also some renames happened upstream).
Comment 2 Tom Wijsman (TomWij) (RETIRED) gentoo-dev 2014-06-01 13:16:16 UTC
Created attachment 378002 [details]
MATE 1.8 ARM dependencies that need arm keyword.
Comment 3 Tom Wijsman (TomWij) (RETIRED) gentoo-dev 2014-06-01 13:18:18 UTC
Created attachment 378004 [details]
MATE 1.8 keywording list

x86 can proceed with keywording the attached list as it is clean according to a repoman check; arm has to wait for the previous list to be keyword, which I or someone else will cover through 4 "Depends on" bugs that are about to be added.
Comment 4 Agostino Sarubbo gentoo-dev 2014-06-07 16:42:20 UTC
x86 done
Comment 5 Matthias Maier gentoo-dev 2014-12-20 18:18:06 UTC
What is the current status of the arm keywording?
Comment 6 Mart Raudsepp gentoo-dev 2015-03-15 00:44:31 UTC
I'm not sure where's Zero_Chaos at, but after a long hiatus, I'm back setting up my cubietruck with MATE, so some more keywords will trinkle in from me later this month probably
Comment 7 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2015-07-03 16:14:18 UTC
removing arm till 1.10 in the tree.
Comment 8 Adam Feldman gentoo-dev 2015-07-06 06:40:06 UTC
*** Bug 551590 has been marked as a duplicate of this bug. ***
Comment 9 Adam Feldman gentoo-dev 2015-07-06 06:52:29 UTC
Switching to newly made MATE herd.

Will look into keywording once 1.10 is up.
Comment 10 Adam Feldman gentoo-dev 2015-07-22 20:07:08 UTC
*** Bug 555522 has been marked as a duplicate of this bug. ***
Comment 11 James Bates 2015-07-25 17:33:49 UTC
(In reply to Mikle Kolyada from comment #7)
> removing arm till 1.10 in the tree.

That doesn't seem appropriate I would say: as I reported in show_bug.cgi?id=555522 , pretty much all of mate 1.8 builds and runs without any problems on arm.
Comment 12 Adam Feldman gentoo-dev 2016-02-20 22:55:58 UTC
MATE 1.10 is in the tree.
The following is the list of MATE packages for consideration for the ARM keywording.  Will update with deps that require keywording prior to cc'ing ARM team:

app-arch/engrampa
app-editors/pluma
app-text/atril
dev-libs/libmateweather
dev-python/python-caja
mate-base/caja
mate-base/libmatekbd
mate-base/mate
mate-base/mate-applets
mate-base/mate-common
mate-base/mate-control-center
mate-base/mate-desktop
mate-base/mate-menus
mate-base/mate-panel
mate-base/mate-session-manager
mate-base/mate-settings-daemon
mate-base/mate-applets-meta
mate-extra/caja-extensions
mate-extra/mate-media
mate-extra/mate-polkit
mate-extra/mate-power-manager
mate-extra/mate-screensaver
mate-extra/mate-sensors-applet
mate-extra/mate-system-monitor
mate-extra/mate-user-share
mate-extra/mate-utils
mate-extra/mate-indicator-applet
mate-extra/mate-netbook
media-gfx/eom
media-libs/libmatemixer
net-analyzer/mate-netspeed
x11-misc/mate-notification-daemon
x11-misc/mozo
x11-terms/mate-terminal
x11-themes/mate-backgrounds
x11-themes/mate-icon-theme
x11-themes/mate-icon-theme-faenza
x11-themes/mate-themes
x11-wm/marco
Comment 13 Adam Feldman gentoo-dev 2016-04-09 21:49:25 UTC
(In reply to NP-Hardass from comment #12)
> MATE 1.10 is in the tree.
> The following is the list of MATE packages for consideration for the ARM
> keywording.  Will update with deps that require keywording prior to cc'ing
> ARM team:
> 
> app-arch/engrampa
> app-editors/pluma
> app-text/atril
> dev-libs/libmateweather
> dev-python/python-caja
> mate-base/caja
> mate-base/libmatekbd
> mate-base/mate
> mate-base/mate-applets
> mate-base/mate-common
> mate-base/mate-control-center
> mate-base/mate-desktop
> mate-base/mate-menus
> mate-base/mate-panel
> mate-base/mate-session-manager
> mate-base/mate-settings-daemon
> mate-base/mate-applets-meta
> mate-extra/caja-extensions
> mate-extra/mate-media
> mate-extra/mate-polkit
> mate-extra/mate-power-manager
> mate-extra/mate-screensaver
> mate-extra/mate-sensors-applet
> mate-extra/mate-system-monitor
> mate-extra/mate-user-share
> mate-extra/mate-utils
> mate-extra/mate-indicator-applet
> mate-extra/mate-netbook
> media-gfx/eom
> media-libs/libmatemixer
> net-analyzer/mate-netspeed
> x11-misc/mate-notification-daemon
> x11-misc/mozo
> x11-terms/mate-terminal
> x11-themes/mate-backgrounds
> x11-themes/mate-icon-theme
> x11-themes/mate-icon-theme-faenza
> x11-themes/mate-themes
> x11-wm/marco

Added the ~arm keyword to all of the above ebuilds in a local overlay.  Repoman reports no missing dependencies.  ARM team, please keyword all of the following packages in the 1.10 branch.
Comment 14 Adam Feldman gentoo-dev 2016-05-10 22:16:08 UTC
Ping @ARM team for a status update please.
Comment 15 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2016-05-30 19:20:04 UTC
~arm keyword has been added.
Comment 16 Adam Feldman gentoo-dev 2016-05-31 03:04:19 UTC
(In reply to Mikle Kolyada from comment #15)
> ~arm keyword has been added.

Thanks to you and the whole ARM team.  Greatly appreciated.