Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 508040 - >=app-office/akonadi-server-1.12: add soprano use flag
Summary: >=app-office/akonadi-server-1.12: add soprano use flag
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: All Linux
: Normal enhancement (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-04-18 18:43 UTC by AE
Modified: 2014-04-22 17:10 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Patch to CMakeLists.txt to make soprano optional (soprano-optional.patch,721 bytes, patch)
2014-04-18 18:44 UTC, AE
Details | Diff
Patch to add a +soprano USE flag. (akonadi-server-1.12.1.ebuild.patch,881 bytes, patch)
2014-04-18 18:45 UTC, AE
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description AE 2014-04-18 18:43:28 UTC
After a successful nepomuk-to-baloo data migration, akonadi-server does not need soprano any more. Please consider adding a +soprano entry in the IUSE variable of akonadi-server-1.12.1.ebuild. Patches for CMakeLists.txt and the ebuild attached.

Reproducible: Always
Comment 1 AE 2014-04-18 18:44:37 UTC
Created attachment 375224 [details, diff]
Patch to CMakeLists.txt to make soprano optional
Comment 2 AE 2014-04-18 18:45:38 UTC
Created attachment 375226 [details, diff]
Patch to add a +soprano USE flag.
Comment 4 Johannes Huber gentoo-dev 2014-04-18 21:09:31 UTC
Comment on attachment 375224 [details, diff]
Patch to CMakeLists.txt to make soprano optional

This patch is not needed the build option already exists. It just changes the default value.
Comment 5 Johannes Huber gentoo-dev 2014-04-18 21:14:17 UTC
Thanks for reporting. We will need to adjust the deps for KDE 4.12 branch and KDE >=4.13 branch first.
Comment 6 Johannes Huber gentoo-dev 2014-04-21 13:46:53 UTC
Thanks for reporting. This is fixed in cvs now. Please sync in some hours to get the changes.

+
+  21 Apr 2014; Johannes Huber <johu@gentoo.org> akonadi-server-1.12.1.ebuild,
+  metadata.xml:
+  Add USE flag soprano, bug #508040.
+