Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 507808 - [TRACKER] Metadata cache breakage, caused by redefining ebuild's SLOT through USE="multislot"
Summary: [TRACKER] Metadata cache breakage, caused by redefining ebuild's SLOT through...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: All Linux
: Normal enhancement (vote)
Assignee: Gentoo Quality Assurance Team
URL:
Whiteboard:
Keywords: Tracker
Depends on:
Blocks:
 
Reported: 2014-04-16 10:30 UTC by Sergey Popov
Modified: 2016-03-16 14:19 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sergey Popov gentoo-dev 2014-04-16 10:30:52 UTC
Due to not-so-properly implemented(without proper support from package manager) USE-dynamic[1] flag "multislot" now we have metadata inconsistency that violates PMS and can be point of breakage for other PMs, that follows PMS stricter than portage.

QA team discussion about multislot issue - http://wiki.gentoo.org/wiki/Project:Quality_Assurance/Meeting_Summaries#Multislot_issue

As usual - no talk here(unless it's about the whole issue itself), just link apropriate bugs to the tracker.

[1] - Bug #174407 gives some background about the USE-dynamic slots
Comment 1 Sergey Popov gentoo-dev 2014-04-16 10:40:28 UTC
Example of badly behaviour in some tools: bug #434536
Comment 2 Ryan Hill (RETIRED) gentoo-dev 2014-04-17 02:53:38 UTC
I never got a reply to the mail I sent, is masking with an appropriate warning acceptable?
Comment 3 Sergey Popov gentoo-dev 2014-04-17 06:37:23 UTC
(In reply to Ryan Hill from comment #2)
> I never got a reply to the mail I sent, is masking with an appropriate
> warning acceptable?

Masking the whole USE="multislot" ? Yeah, i think it's fine - SLOT variable in all ebuilds has persistent value with disabled USE="multislot".
Comment 4 Ulrich Müller gentoo-dev 2014-04-17 06:46:40 UTC
It should only be package.use.masked, otherwise sys-boot/grub will be affected where the flag is used properly (i.e. without changing metadata).
Comment 5 Sergey Popov gentoo-dev 2014-10-01 14:12:53 UTC
+  01 Oct 2014; Sergey Popov <pinkbyte@gentoo.org> package.use.mask:
+  Mask USE='multislot' in sys-devel/binutils as well, bug #507808
Comment 6 Jeroen Roovers gentoo-dev 2014-10-01 16:30:07 UTC
Er, so now we can't have SLOTted toolchain parts?
Comment 7 Sergey Popov gentoo-dev 2014-10-03 08:37:26 UTC
(In reply to Jeroen Roovers from comment #6)
> Er, so now we can't have SLOTted toolchain parts?

You can unmask USE="multislot" and use it on your own. But until the breakage will be fixed(by, for example, changing metadata concept in portage) it should not be allowed to be enabled for ordinary users.
Comment 8 Chris Reffett gentoo-dev Security 2014-10-03 13:03:19 UTC
@jer: more specifically, we can have SLOTted toolchain parts. The problem is having the SLOT be redefined by a USE flag, as is the case for USE=multislot.
Comment 9 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2015-11-22 23:13:15 UTC
No more bugs open. Closing the tracker.