Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 507568 - Gnome* maintained packages stabilization list for April 2014
Summary: Gnome* maintained packages stabilization list for April 2014
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords: STABLEREQ
Depends on: 506160 507704
Blocks: 500758 506826 507616 508006
  Show dependency tree
 
Reported: 2014-04-13 14:58 UTC by Pacho Ramos
Modified: 2014-04-23 13:42 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
List (lista,10.14 KB, text/plain)
2014-04-13 15:03 UTC, Pacho Ramos
Details
list v2 (lista,10.14 KB, text/plain)
2014-04-14 13:48 UTC, Alexandre Rostovtsev (RETIRED)
Details
list v3 (lista,10.14 KB, text/plain)
2014-04-14 13:51 UTC, Alexandre Rostovtsev (RETIRED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Pacho Ramos gentoo-dev 2014-04-13 14:58:05 UTC
The idea of this is to stabilize a much smaller set of packages on exotic arches (plus some newer versions in common arches) and, then, it contains the minimum required.

The final intention is to move most gnome stuff to testing in those arches as they clearly lack enough manpower to handle stable tree for them
Comment 1 Pacho Ramos gentoo-dev 2014-04-13 14:59:28 UTC
For the packages already stabled on amd64/x86/hppa simply skip them (it's easy to do at least with the scripts I use as ekeyword won't do anything if the package is already stable)
Comment 2 Pacho Ramos gentoo-dev 2014-04-13 15:03:22 UTC
Created attachment 374850 [details]
List
Comment 3 Agostino Sarubbo gentoo-dev 2014-04-13 18:26:00 UTC
amd64 stable
Comment 4 Jan Vesely 2014-04-14 05:10:27 UTC
(In reply to Pacho Ramos from comment #2)
> Created attachment 374850 [details]
> List

the list introduces a dependency conflict on amd64:
gnome-terminal-3.10.2 depends on gtk-builder-convert
gtk+-2.24.23 blocks <dev-util/gtk-builder-convert-2.24.23

the latest stable is gtk-builder-convert-2.24.22
Comment 5 Alexandre Rostovtsev (RETIRED) gentoo-dev 2014-04-14 13:48:36 UTC
Created attachment 374906 [details]
list v2

Forgot to add gtk-builder-convert to amd64
Comment 6 Alexandre Rostovtsev (RETIRED) gentoo-dev 2014-04-14 13:51:28 UTC
Created attachment 374908 [details]
list v3

another gtk-builder-convert list fix
Comment 7 Alexandre Rostovtsev (RETIRED) gentoo-dev 2014-04-14 13:52:52 UTC
@amd64, please quickly stabilize =dev-util/gtk-builder-convert-2.24.23 - it needed to have been stabilized together with gtk+-2.24.23, and is now causing dependency conflicts for stable users (bug #507616)
Comment 8 Alexandre Rostovtsev (RETIRED) gentoo-dev 2014-04-14 14:16:25 UTC
amd64 fixed (acked by ago)
Comment 9 Agostino Sarubbo gentoo-dev 2014-04-14 20:38:10 UTC
ppc stable
Comment 10 Agostino Sarubbo gentoo-dev 2014-04-16 09:28:46 UTC
ppc64 stable
Comment 11 Jeroen Roovers gentoo-dev 2014-04-17 11:11:00 UTC
Comment on attachment 374908 [details]
list v3

HPPA did most of these for bug #499954. Why are these targets being repeated here?
Comment 12 Pacho Ramos gentoo-dev 2014-04-17 12:40:25 UTC
Because of the way it was generated: as some arches are unable to stabilize the big list, I needed to create one much shorter, then, some deps were need to be added and inherited from the previous list.

It is not a problem with the scripts we use for stabilizing as the packages already stable will simply be no changed at all :/
Comment 13 Pacho Ramos gentoo-dev 2014-04-17 13:13:36 UTC
I saw you have just stabilized the newer stuff for hppa, then, hppa team would be done here already :) (feel free to unCC when you prefer)
Comment 14 Agostino Sarubbo gentoo-dev 2014-04-18 19:03:28 UTC
alpha/ia64 stable
Comment 15 Agostino Sarubbo gentoo-dev 2014-04-20 08:23:11 UTC
sparc stable
Comment 16 Agostino Sarubbo gentoo-dev 2014-04-20 08:52:01 UTC
x86 stable
Comment 17 Agostino Sarubbo gentoo-dev 2014-04-21 10:30:54 UTC
arm stable
Comment 18 Pacho Ramos gentoo-dev 2014-04-22 06:11:04 UTC
hppa looks to be also done already
Comment 19 Wei-Chun Chung 2014-04-23 07:43:46 UTC
gtk-builder-convert-2.24.23 still be masked in the tree (Timestamp of tree: Wed, 23 Apr 2014 07:30:01 +0000)
Comment 20 Wei-Chun Chung 2014-04-23 07:44:43 UTC
gtk-builder-convert-2.24.23 still be masked in the x86 tree (Timestamp of tree: Wed, 23 Apr 2014 07:30:01 +0000)
Comment 21 Émeric Maschino 2014-04-23 12:12:26 UTC
(In reply to Agostino Sarubbo from comment #14)
> alpha/ia64 stable

IMHO, ia64 is NOT stable:
- everything webkit-gtk-related (including webkit-gtk itself) will badly crash because of upstream bug #129992;
- the following bugs (tests failure) are still opened and relevant with updated packages in list_v3: bug #453478, bug #449010, bug #501842, bug #504510 and bug #504514.

     Émeric
Comment 22 Alexandre Rostovtsev (RETIRED) gentoo-dev 2014-04-23 13:42:08 UTC
(In reply to Wei-Chun Chung from comment #20)
> gtk-builder-convert-2.24.23 still be masked in the x86 tree (Timestamp of
> tree: Wed, 23 Apr 2014 07:30:01 +0000)

Fixed now, thanks for reporting!

+  23 Apr 2014; Alexandre Rostovtsev <tetromino@gentoo.org>
+  gtk-builder-convert-2.24.23.ebuild:
+  Stable for x86, wrt bug #507568, acked by Agostino Sarubbo