Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 507300 - app-emulation/vmware-view-open-client-4.5.0.297975-r1 - ld: vmware_view-baseXml.o: undefined reference to symbol 'g_module_symbol'
Summary: app-emulation/vmware-view-open-client-4.5.0.297975-r1 - ld: vmware_view-baseX...
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: Timo Gurr (RETIRED)
URL:
Whiteboard:
Keywords: PMASKED
Depends on:
Blocks: underlinking
  Show dependency tree
 
Reported: 2014-04-10 09:12 UTC by Bertrand Jacquin
Modified: 2015-11-05 19:46 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,255.33 KB, text/plain)
2014-04-10 09:12 UTC, Bertrand Jacquin
Details
emerge --info (info.log,17.67 KB, text/plain)
2014-04-10 09:12 UTC, Bertrand Jacquin
Details
vmware-view-client-2.2.0.ebuild.tgurr-changes (vmware-view-client-2.2.0.ebuild.tgurr-changes,1.44 KB, patch)
2014-04-17 16:13 UTC, Timo Gurr (RETIRED)
Details | Diff
vmware-view-open-client-4.5.0.297975-r2.ebuild (vmware-view-open-client-4.5.0.297975-r2.ebuild,1.42 KB, text/plain)
2014-06-05 00:51 UTC, Bob Carroll
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bertrand Jacquin 2014-04-10 09:12:04 UTC
# echo "=app-emulation/vmware-view-open-client-4.5.0.297975-r1 ~amd64" >> /etc/portage/package.accept_keywords

# emerge -vat app-emulation/vmware-view-open-client
(..)
[ebuild  N    ~] app-emulation/vmware-view-open-client-4.5.0.297975-r1  0 kB
(..)
x86_64-pc-linux-gnu-g++  -march=native -O2 -pipe -fomit-frame-pointer  -Wl,-O1 -Wl,--as-needed -o vmware-view vmware_view-baseApp.o vmware_view-baseXml.o vmware_view-broker.o vmware_view-brokerXml.o vmware_view-cdkUrl.o vmware_view-desktop.o vmware_view-procHelper.o vmware_view-protocols.o vmware_view-restartMonitor.o
vmware_view-stubs.o vmware_view-tunnel.o vmware_view-usb.o vmware_view-util.o  gtk/vmware_view-app.o gtk/vmware_view-brokerDlg.o gtk/vmware_view-cryptoki.o gtk/vmware_view-desktopDlg.o gtk/vmware_view-desktopSelectDlg.o gtk/vmware_view-disclaimerDlg.o gtk/vmware_view-dlg.o gtk/vmware_view-helpSupportDlg.o gtk/vmware_view-kioskWindow.o gtk/vmware_view-loginDlg.o gtk/vmware_view-main.o  gtk/vmware_view-passwordDlg.o gtk/vmware_view-prefs.o gtk/vmware_view-rdesktop.o gtk/vmware_view-rmks.o gtk/vmware_view-scCertDetailsDlg.o gtk/vmware_view-scCertDlg.o gtk/vmware_view-scInsertPromptDlg.o gtk/vmware_view-scPinDlg.o gtk/vmware_view-securIDDlg.o gtk/vmware_view-transitionDlg.o gtk/vmware_view-window.o gtk/vmware_view-windowSizeDlg.o   libFile.a libPanicDefault.a libPanic.a libString.a libStubs.a
libLog.a libUser.a libBasicHttp.a libNothread.a libPoll.a libPollDefault.a libPollGtk.a libGtm.a  libProductState.a libSig.a libDict.a libMisc.a libErr.a libUnicode.a libCdk.a  -lgtk-x11-2.0 -lgdk-x11-2.0 -lpangocairo-1.0 -latk-1.0 -lcairo
-lgdk_pixbuf-2.0 -lgio-2.0 -lpangoft2-1.0 -lpango-1.0 -lgobject-2.0 -lglib-2.0 -lfreetype -lfontconfig -lX11  -lxml2  -lcurl  -lssl -lcrypto  -L/usr/lib -lboost_signals-mt -licuuc -licudata
/usr/lib/gcc/x86_64-pc-linux-gnu/4.7.3/../../../../x86_64-pc-linux-gnu/bin/ld: vmware_view-baseXml.o: undefined reference to symbol 'g_module_symbol'
/usr/lib/gcc/x86_64-pc-linux-gnu/4.7.3/../../../../x86_64-pc-linux-gnu/bin/ld: note: 'g_module_symbol' is defined in DSO /usr/lib64/libgmodule-2.0.so.0 so try adding it to the linker command line
/usr/lib64/libgmodule-2.0.so.0: could not read symbols: Invalid operation
collect2: error: ld returned 1 exit status
make[2]: *** [vmware-view] Error 1
make[2]: Leaving directory `/var/tmp/portage/app-emulation/vmware-view-open-client-4.5.0.297975-r1/work/VMware-view-open-client-source-4.5.0-297975'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/app-emulation/vmware-view-open-client-4.5.0.297975-r1/work/VMware-view-open-client-source-4.5.0-297975'
make: *** [all] Error 2
 * ERROR: app-emulation/vmware-view-open-client-4.5.0.297975-r1::gentoo failed (compile phase):
 *   emake failed

build log and emerge --info attached

Please note that also HOMEPAGE now give an http error 404

$ curl -I http://code.google.com/p/vmware-view-open-client/
HTTP/1.1 404 Not Found
(..)

Reproducible: Always
Comment 1 Bertrand Jacquin 2014-04-10 09:12:23 UTC
Created attachment 374666 [details]
build.log
Comment 2 Bertrand Jacquin 2014-04-10 09:12:35 UTC
Created attachment 374668 [details]
emerge --info
Comment 3 Timo Gurr (RETIRED) gentoo-dev 2014-04-17 14:58:43 UTC
(In reply to Bertrand Jacquin from comment #0)
> Please note that also HOMEPAGE now give an http error 404

VMware abandoned the vmware-view-open-client quite a while ago, so expect no fixes. Instead I also plan to lastrite the vmware-view-open-client because of dead upstream.

Source of this information can be found here:
https://groups.google.com/forum/#!msg/vmware-view-open-client/ypXN_egz4Tc/FVIZE036IPEJ

I currently work on a vmware-view-client package, the binaries are available at http://archive.canonical.com/ubuntu/pool/partner/v/vmware-view-client

Please contact me directly via email if you're interested in helping to test (and possibly improve) the quite rudimentary ebuild I have for it. I won't attach it here since it's currently in a real embarrassing state.
Comment 4 Bertrand Jacquin 2014-04-17 15:22:56 UTC
(In reply to Timo Gurr from comment #3)
> (In reply to Bertrand Jacquin from comment #0)
> > Please note that also HOMEPAGE now give an http error 404
> 
> VMware abandoned the vmware-view-open-client quite a while ago, so expect no
> fixes. Instead I also plan to lastrite the vmware-view-open-client because
> of dead upstream.
> 
> Source of this information can be found here:
> https://groups.google.com/forum/#!msg/vmware-view-open-client/ypXN_egz4Tc/
> FVIZE036IPEJ

Thanks for the info.

> I currently work on a vmware-view-client package, the binaries are available
> at http://archive.canonical.com/ubuntu/pool/partner/v/vmware-view-client
> 
> Please contact me directly via email if you're interested in helping to test
> (and possibly improve) the quite rudimentary ebuild I have for it. I won't
> attach it here since it's currently in a real embarrassing state.

I done one last week based on ubuntu package. You can find that ebuild here  :

http://git.meleeweb.net/distros/gentoo/portage.git/tree/app-emulation/vmware-view-client

It work pretty nice, but libxkbfile.so is missing in app-emulation/emul-linux-x86-xlibs so I add to copy /usr/lib/libxkbfile.so{,1,1.0.2} from a x86 box and put it in /usr/local/lib32 to make to all work.

See bug #507328 for that point
Comment 5 Timo Gurr (RETIRED) gentoo-dev 2014-04-17 16:12:44 UTC
(In reply to Bertrand Jacquin from comment #4)
> I done one last week based on ubuntu package. You can find that ebuild here 

Great thanks, I've attached a diff with some additional stuff I had already done which you might consider applying.

* The locales didn't work for me the way you handled it (client still was in english instead of e.g. german).
* .desktop and png icon from the debian sources
* Install the EULA stuff (uncompressed) else when clicking the Licence button in the Help -> Info box fails to find/open them

> It work pretty nice, but libxkbfile.so is missing in
> app-emulation/emul-linux-x86-xlibs so I add to copy
> /usr/lib/libxkbfile.so{,1,1.0.2} from a x86 box and put it in
> /usr/local/lib32 to make to all work.
> 
> See bug #507328 for that point

I couldn't actually test the client yet, besides of starting it since our vdesktop's are currently not available so I probably didn't hit that failure yet.

Another dependecy that is listed and not available in the emul packages (afaik) is sys-apps/pcsc-lite which is probably optional.

Is the gnome-extra/zenity dependency actually needed? I only spotted it in the debian/ubuntu vmware-view.wrapper which we don't install (and also probably won't).

Thanks for your great work! Looking forward to include it in the main tree.

Regards
Timo
Comment 6 Timo Gurr (RETIRED) gentoo-dev 2014-04-17 16:13:12 UTC
Created attachment 375140 [details, diff]
vmware-view-client-2.2.0.ebuild.tgurr-changes
Comment 7 Bertrand Jacquin 2014-04-17 17:11:18 UTC
(In reply to Timo Gurr from comment #5)
> (In reply to Bertrand Jacquin from comment #4)
> > I done one last week based on ubuntu package. You can find that ebuild here 
> 
> Great thanks, I've attached a diff with some additional stuff I had already
> done which you might consider applying.
> 
> * The locales didn't work for me the way you handled it (client still was in
> english instead of e.g. german).

Oops :)

> * .desktop and png icon from the debian sources

Nice, that is something I really don't use so didn't catch it.

> * Install the EULA stuff (uncompressed) else when clicking the Licence
> button in the Help -> Info box fails to find/open them

Ok, I didn't try this. And as LICENSE was then available in /usr/portage/license/vmware, I wasn't seeing the point for installing them, but your justification is pretty acceptable.

> > It work pretty nice, but libxkbfile.so is missing in
> > app-emulation/emul-linux-x86-xlibs so I add to copy
> > /usr/lib/libxkbfile.so{,1,1.0.2} from a x86 box and put it in
> > /usr/local/lib32 to make to all work.
> > 
> > See bug #507328 for that point
> 
> I couldn't actually test the client yet, besides of starting it since our
> vdesktop's are currently not available so I probably didn't hit that failure
> yet.
> 
> Another dependecy that is listed and not available in the emul packages
> (afaik) is sys-apps/pcsc-lite which is probably optional.

I can confirm, I also added them in /usr/local/lib32, sorry to have not notice it. Not available via a multilib package nor an emul package :/ (sys-apps/pcsc-lite is only needed for USB redirection).

> Is the gnome-extra/zenity dependency actually needed? I only spotted it in
> the debian/ubuntu vmware-view.wrapper which we don't install (and also
> probably won't).

True. At the begenning I looked in the .deb archive. This is not needed when using the orig archive.

> Thanks for your great work! Looking forward to include it in the main tree.

Thanks :)
Comment 8 Bob Carroll 2014-06-05 00:51:09 UTC
While we wait for the libxkbfile.so problem to be fixed, I propose a small change to the vmware-view-open-client-4.5.0.297975 ebuild. I removed --as-needed from LDFLAGS and added -lgmodule-2.0 and now it builds successfully.
Comment 9 Bob Carroll 2014-06-05 00:51:38 UTC
Created attachment 378292 [details]
vmware-view-open-client-4.5.0.297975-r2.ebuild
Comment 10 Andreas K. Hüttel gentoo-dev 2015-09-27 21:28:12 UTC
Masked for removal 

# Andreas K. Huettel <dilfridge@gentoo.org> (27 Sep 2015)
# Dead upstream, buggy, effectively unmaintained. Removal
# in 30 days.
app-emulation/vmware-view-open-client
Comment 11 Pacho Ramos gentoo-dev 2015-11-05 19:46:26 UTC
removed