Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 507282 - kernel BUG at kernel/auditsc.c:1454! with auditd running ./glibc-test
Summary: kernel BUG at kernel/auditsc.c:1454! with auditd running ./glibc-test
Status: RESOLVED DUPLICATE of bug 513308
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: HPPA Linux
: Normal normal (vote)
Assignee: HPPA Porters
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-04-09 23:36 UTC by Jeroen Roovers
Modified: 2014-08-13 10:35 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jeroen Roovers gentoo-dev 2014-04-09 23:36:58 UTC
[369551.923044] ------------[ cut here ]------------
[369551.926378] kernel BUG at kernel/auditsc.c:1454!
[369551.933044] CPU: 0 PID: 32120 Comm: glibc-test Tainted: G      D      3.14.0-gentoo-JeR #1
[369551.939711] task: 000000006f5e0000 ti: 000000413ea08000 task.ti: 000000413ea08000
[369551.939711]      YZrvWESTHLNXBCVMcbcbcbcbOGFRQPDI
[369551.939711] PSW: 00001000000001101111111100001111 Tainted: G      D     
[369551.939711] r00-03  000000ff0806ff0f 000000413ea08180 0000000040186188 000000413ea08210
[369551.939711] r04-07  00000000fa957b30 000000007a8cd000 0000000000000000 00000000faefe480
[369551.939711] r08-11  00000000004a07f8 0000000000000000 0000000000000000 0000000000000000
[369551.939711] r12-15  0000000000000000 00000000000bf2d8 00000000000befd4 00000000000bc0f8
[369551.939711] r16-19  00000000ffffffff 0000000000000000 00000000000bc0f8 0000000000000681
[369551.939711] r20-23  00000000000000de 0000000000000000 0000000000000002 0000000000000000
[369551.939711] r24-27  0000000000000000 00000000000000de 000000006f5e0000 000000004086e560
[369551.939711] r28-31  000000000000000f 000000413ea081e0 000000413ea082a0 0000000000000001
[369551.939711] sr00-03  00000000001f0800 00000000001f0800 0000000000000000 00000000001f0800
[369551.939711] sr04-07  0000000000000000 0000000000000000 0000000000000000 0000000000000000
[369551.939711] IASQ: 0000000000000000 0000000000000000 IAOQ: 000000004025c700 000000004025c704
[369551.939711]  IIR: 03ffe01f    ISR: 0000000010350000  IOR: 000003fa82208228
[369551.939711]  CPU:        0   CR30: 000000413ea08000 CR31: ffffffffffffffff
[369551.939711]  ORIG_R28: 00000000000000a8
[369551.939711]  IAOQ[0]: __audit_syscall_entry+0x48/0x130
[369551.939711]  IAOQ[1]: __audit_syscall_entry+0x4c/0x130
[369551.939711]  RP(r2): do_syscall_trace_enter+0x180/0x1b8
[369551.939711] Backtrace:
[369551.939711]  [<0000000040186188>] do_syscall_trace_enter+0x180/0x1b8
[369551.939711]  [<0000000040166360>] tracesys_next+0x0/0x50
[369551.939711] CPU: 0 PID: 32120 Comm: glibc-test Tainted: G      D      3.14.0-gentoo-JeR #1
[369551.939711] Backtrace:
[369551.939711]  [<000000004017ddd4>] show_stack+0x2c/0x40
[369551.939711]  [<000000004047c980>] dump_stack+0xe0/0x150
[369551.939711]  [<000000004017e05c>] die_if_kernel+0x254/0x390
[369551.939711]  [<000000004017e954>] handle_interruption+0x334/0xa80
[369551.939711]  [<000000004025c700>] __audit_syscall_entry+0x48/0x130
[369551.939711]  [<0000000040186188>] do_syscall_trace_enter+0x180/0x1b8
[369551.939711]  [<0000000040166360>] tracesys_next+0x0/0x50
[369551.939711] ---[ end trace 078b9069b61c6a16 ]---

When I stop auditd, glibc-test runs fine. With auditd running (which presumably enables CONFIG_AUDITSYSCALL) I get a segmentation fault.
Comment 1 Jeroen Roovers gentoo-dev 2014-04-09 23:44:33 UTC
Thu 10 Apr 01:44:09 CEST 2014
emerge --info 
Portage 2.2.10 (default/linux/hppa/13.0, gcc-4.7.3, glibc-2.17, 3.14.0-gentoo-JeR parisc64)
=================================================================
System uname: Linux-3.14.0-gentoo-JeR-parisc64-PA8800_-Mako-with-gentoo-2.2
KiB Mem:     8231888 total,   4824404 free
KiB Swap:    2101676 total,   2101676 free
Timestamp of tree: Wed, 09 Apr 2014 15:15:01 +0000
ld GNU ld (GNU Binutils) 2.23.2
distcc 3.2rc1 hppa2.0-unknown-linux-gnu [enabled]
ccache version 3.1.9 [disabled]
app-shells/bash:          4.2_p45
dev-lang/python:          2.6.8-r3, 2.7.6, 3.2.5-r3, 3.3.3
dev-util/ccache:          3.1.9-r3
dev-util/cmake:           2.8.12.2
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.12.4
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.9.6-r3, 1.11.6, 1.12.6, 1.13.4
sys-devel/binutils:       2.22-r1, 2.23.1, 2.23.2, 2.24-r1
sys-devel/gcc:            4.6.3, 4.7.2-r1, 4.7.3-r1, 4.8.1-r1, 4.8.2
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.2
sys-devel/make:           4.0-r1
sys-kernel/linux-headers: 3.13 (virtual/os-headers)
sys-libs/glibc:           2.17
Repositories: gentoo JeR
ACCEPT_KEYWORDS="hppa"
ACCEPT_LICENSE="*"
CBUILD="hppa2.0-unknown-linux-gnu"
CFLAGS="-mschedule=8000 -march=2.0 -ggdb -Wall -O2 -pipe -Wno-comment"
CHOST="hppa2.0-unknown-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib/distcc/bin /usr/lib/python2.6/site-packages/buildbot/status/web /usr/lib/python2.7/site-packages/buildbot/status/web /usr/share/easy-rsa /usr/share/gnupg/qualified.txt /var/bind /var/spool/torque /var/www/localhost/htdocs/wordpress/wp-config.php"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/apache2-php5.4/ext-active/ /etc/php/apache2-php5.5/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cgi-php5.5/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/php/cli-php5.5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-mschedule=8000 -march=2.0 -ggdb -Wall -O2 -pipe"
DISTDIR="/world/distfiles"
EMERGE_DEFAULT_OPTS="--quiet-build=n"
FCFLAGS=""
FEATURES="assume-digests binpkg-logs buildpkg config-protect-if-modified distcc distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync metadata-transfer network-sandbox news notitles parallel-fetch preserve-libs protect-owned sandbox sfperms splitdebug strict test test-fail-continue unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-mschedule=8000 -march=2.0 -ggdb -Wall -O2 -pipe"
GENTOO_MIRRORS="ftp://gentoo.imj.fr/pub/gentoo/ ftp://mirror.netcologne.de/gentoo/ ftp://mirror.netcologne.de/gentoo/ ftp://91.121.124.139/gentoo-distfiles/"
LANG="C"
LC_ALL="en_GB.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--hash-style=gnu -Wl,--as-needed"
MAKEOPTS="-j6"
PKGDIR="/keeps/gentoo/packages/karsten"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/dev/shm"
PORTDIR="/world/gentoo/portage"
PORTDIR_OVERLAY="/keeps/gentoo/local"
SYNC="rsync://rsync.nl.gentoo.org/gentoo-portage"
USE="256-color X acl alsa amr anacron apng audit bash-completion berkdb bfio bittorrent bzip2 cairo canberra cli coverage cracklib crossdev crypt cups custom-cflags cxx dane dbus declarative dirac directfb distinct-l dlz dri emacs exif expat fbcon filecaps firefox firmware foomaticdb fortran frontend-optional gdbm geoip geoloc glep gost gpm graphite gsm gstreamer gtk gudev guile hddtemp hppa hwdb iconv idn imlib inotify ipv6 javascript jingle jpeg json kmod ladspa lasi launch-frontend libcaca libcanberra libevent libusb libwww lua lzma lzo mad mng mod modplug modules mp3 multislot multitarget munge nagios ncurses netlink nls nptl objc objc++ objc-gc offensive openexr opengl openmp openrc opus oss pam pcre php pic pkcs11 png pnm policykit python qt qt3support qt4 quvi readline regression-test rtmp samba schroedinger session smi socks5 speex spell spidermonkey sqlite ssl tcl tcpd test tga theora threads tiff tk truetype unicode unwind v4l vim-syntax vorbis vpx wcwidth x264 xattr xcb xft xhtml xml2 xvfb xvid zlib" ALSA_CARDS="ad1889 usb-audio" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CURL_SSL="nss" DRACUT_MODULES="nfs syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev joystick keyboard mouse acecad aiptek calcomp citron digitaledge dmc dynapro elo2300 elographics fpit hyperpen jamstudio magellan microtouch mutouch palmax penmount spaceorb summa tek4957 tslib ur98 void" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en nl he" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_6 python2_7 python3_2 python3_3" RUBY_TARGETS="ruby19 ruby20" USERLAND="GNU" VIDEO_CARDS="stifb dummy" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
USE_PYTHON="2.6 2.7 3.2 3.3"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 2 SpanKY gentoo-dev 2014-08-13 10:35:34 UTC

*** This bug has been marked as a duplicate of bug 513308 ***