Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 506920 - net-wireless/bluedevil with net-wireless/bluez-5.15 - bluedevil-sendfile fails?
Summary: net-wireless/bluedevil with net-wireless/bluez-5.15 - bluedevil-sendfile fails?
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
Depends on: 509358
Blocks:
  Show dependency tree
 
Reported: 2014-04-06 11:55 UTC by Kete Tefid
Modified: 2014-07-23 13:24 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kete Tefid 2014-04-06 11:55:43 UTC
While marked as stable, the latest bluez 5.15 does not work with latest stable bluedevil and libbluedevil packages.

This is the output of bluedevil-sendfile in a terminal:

Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 14: reading configurations from ~/.fonts.conf is deprecated.
bluedevilsendfile(3880) SendFileWizard::SendFileWizard: DeviceUbi:  ""
bluedevilsendfile(3880) SendFileWizard::SendFileWizard: Files
bluedevilsendfile(3880) SendFileWizard::SendFileWizard: ()
bluedevilsendfile(3880) SendFileWizard::SendFileWizard: DeviceUbi:  ""
bluedevilsendfile(3880) SendFileWizard::SendFileWizard: Files
bluedevilsendfile(3880) SendFileWizard::SendFileWizard: ()
bluedevilsendfile(3880) SendFileWizard::setDevice: ""
Object::connect: No such signal BlueDevil::Adapter::deviceFound(QVariantMap)
Object::connect:  (receiver name: 'Discover')
======================== 
Address:  "E0:A6:70:C4:8D:F1" 
Name:  "Ketetefid" 
Alias:  "Ketetefid" 
Icon:  "phone" 

 
bluedevilsendfile(3880) SendFileWizard::setDevice: BlueDevil::Device(0x188f110)
Object::connect: No such signal org::freedesktop::UPower::DeviceAdded(QDBusObjectPath)
Object::connect: No such signal org::freedesktop::UPower::DeviceRemoved(QDBusObjectPath)
"/org/freedesktop/UDisks2/drives/ST9500325AS_S2WD5JBV" : property "Drive" does not exist 
"/org/freedesktop/UDisks2/drives/CDEmu_Virt_2e_CD_2fDVD_ROM" : property "Drive" does not exist 
"/org/freedesktop/UDisks2/drives/TSSTcorp_CDDVDW_SN_208AB_R8HU6GHBB15148" : property "Drive" does not exist 
"/org/freedesktop/UDisks2/drives/ST9500325AS_S2WD5JBV" : property "DeviceNumber" does not exist 
"/org/freedesktop/UDisks2/drives/ST9500325AS_S2WD5JBV" : property "Device" does not exist 
bluedevilsendfile(3880) KSambaSharePrivate::testparmParamValue: Running testparm ("-d0", "-s", "--parameter-name", "usershare path")
bluedevilsendfile(3880) KSambaSharePrivate::getNetUserShareInfo: We got some errors while running 'net usershare info' 
bluedevilsendfile(3880) KSambaSharePrivate::getNetUserShareInfo: "info_fn: file /var/lib/samba/usershares/lll is not a well formed usershare file.
info_fn: Error was Path is not a directory.
" 
bluedevilsendfile(3880) SendFileWizard::setFiles: ("/home/tefid/mywords")
bluedevilsendfile(3880) SendFileWizard::setFiles: ("/home/tefid/install_flash_player_ics.apk")
bluedevilsendfile(3880) SendFilesJob::SendFilesJob: ("/home/tefid/install_flash_player_ics.apk")
bluedevilsendfile(3880) KSharedUiServerProxy::KSharedUiServerProxy: kuiserver registered
bluedevilsendfile(3880) SendFilesJob::doStart:
bluedevilsendfile(3880) SendFilesJob::createSessionSlot: Error:
bluedevilsendfile(3880) SendFilesJob::createSessionSlot: "org.freedesktop.DBus.Error.ServiceUnknown"
bluedevilsendfile(3880) SendFilesJob::createSessionSlot: "The name org.bluez.obex was not provided by any .service files" 

Google search did not lead me to anywhere.

The original bluez package was built with +obex and the problem was there. Even after removing this flag from bluez, the problem did not disappear.

  emerge -pv libbluedevil bluedevil bluez

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] net-wireless/bluez-5.15:0/3  USE="cups readline -debug -obex (-selinux) -systemd {-test}" 0 kB
[ebuild   R    ] net-libs/libbluedevil-2.0_rc1:4  USE="(-aqua) -debug" 0 kB
[ebuild   R    ] net-wireless/bluedevil-2.0_rc1:4  USE="(-aqua) -debug" LINGUAS="ar fa -bs -ca -ca@valencia -cs -da -de -el -en_GB -eo -es -et -eu -fi -fr -ga -gl -hu -it -ja -kk -km -ko -lt -mai -mr -ms -nb -nds -nl -pa -pl -pt -pt_BR -ro -ru -sk -sl -sr -sr@ijekavian -sr@ijekavianlatin -sr@latin -sv -th -tr -ug -uk -zh_CN -zh_TW" 0 kB

Total: 3 packages (3 reinstalls), Size of downloads: 0 kB

emerge --info
Portage 2.2.8-r1 (default/linux/amd64/13.0/desktop/kde, gcc-4.8.2, glibc-2.17, 3.13.5-gentoo x86_64)
=================================================================
System uname: Linux-3.13.5-gentoo-x86_64-Intel-R-_Core-TM-_i3_CPU_M_380_@_2.53GHz-with-gentoo-2.2
KiB Mem:     3841028 total,   2476344 free
KiB Swap:    4194300 total,   4194300 free
Timestamp of tree: Sat, 05 Apr 2014 20:30:01 +0000
ld GNU ld (GNU Binutils) 2.23.2
distcc 3.1 x86_64-pc-linux-gnu [enabled]
app-shells/bash:          4.2_p45
dev-java/java-config:     2.2.0
dev-lang/python:          2.7.5-r3, 3.2.5-r3, 3.3.3
dev-util/cmake:           2.8.12.2
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.12.4
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6, 1.12.6, 1.13.4
sys-devel/binutils:       2.23.2
sys-devel/gcc:            4.6.4, 4.7.3-r1, 4.8.2
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.9 (virtual/os-headers)
sys-libs/glibc:           2.17
Repositories: gentoo tlp linuxsystems science MyLocalOverlay Mylocaloverlay
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA Google-TOS AdobeFlash-11.x PUEL sun-bcla-java-vm skype-eula dlj-1.1 RTCW-ETEULA AdobeFlash-10.3 AdobeFlash-10 Nero-EULA-US skype-4.0.0.7-copyright Intel-SDP"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=corei7 -mcx16 -msahf -mno-movbe -mno-aes -mno-pclmul -mpopcnt -mno-abm -mno-lwp -mno-fma -mno-fma4 -mno-xop -mno-bmi -mno-bmi2 -mno-tbm -mno-avx -mno-avx2 -msse4.2 -msse4.1 -mno-lzcnt -mno-rtm -mno-hle -mno-rdrnd -mno-f16c -mno-fsgsbase -mno-rdseed -mno-prfchw -mno-adx -mfxsr -mno-xsave -mno-xsaveopt --param l1-cache-size=32 --param l1-cache-line-size=64 --param l2-cache-size=3072 -mtune=corei7"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/themes/oxygen-gtk/gtk-2.0"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo"
CXXFLAGS="-O2 -pipe -march=corei7 -mcx16 -msahf -mno-movbe -mno-aes -mno-pclmul -mpopcnt -mno-abm -mno-lwp -mno-fma -mno-fma4 -mno-xop -mno-bmi -mno-bmi2 -mno-tbm -mno-avx -mno-avx2 -msse4.2 -msse4.1 -mno-lzcnt -mno-rtm -mno-hle -mno-rdrnd -mno-f16c -mno-fsgsbase -mno-rdseed -mno-prfchw -mno-adx -mfxsr -mno-xsave -mno-xsaveopt --param l1-cache-size=32 --param l1-cache-line-size=64 --param l2-cache-size=3072 -mtune=corei7"
DISTDIR="/usr/portage/distfiles/"
EMERGE_DEFAULT_OPTS="--keep-going --jobs=15 --load-average=8.0 --with-bdeps y"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs buildpkg config-protect-if-modified distcc distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.UTF-8"
LC_ALL="en_US.UTF-8"
LDFLAGS="-Wl,-z,now,--as-needed,-O1,--hash-style=gnu,--sort-common"
MAKEOPTS="-j15 -l8"
PKGDIR="/usr/portage/GentooPackages/"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_EXTRA_OPTS="--exclude-from=/etc/portage/rsync_excludes"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/usr/portage/prtgtmp"
PORTDIR="/usr/portage/maintree"
PORTDIR_OVERLAY="/usr/portage/lymnprtg/tlp /usr/portage/lymnprtg/linuxsystems /usr/portage/lymnprtg/science /usr/portage/lymnprtg /usr/portage/lymnprtg/localoverlays"
USE="3dnow 3dnowext 3gp X a52 aac aalib acl acpi alsa amd64 amr archive asf automount avahi berkdb bittorrent blas bluetooth bmp branding bzip2 cairo cdda cddb cdio cdparanoia cdr cli consolekit cracklib crypt cups cxx dbus declarative directfb djvu double-precision dri dts dv dvb dvd dvdnav dvdr emboss encode exif faac faad fam fbcon fbcondecor fbsplash ffmpeg firefox flac flash fortran fortran95 fuse gd gdbm gif gmp gpg gpm gstreamer gtk gzip h323 iconv icu id3tag inotify ipv6 jingle jpeg jpeg2k kde kipi lame lapack lcms ldap libnotify live lm_sensors lzma mad matroska mjpeg mms mmx mmxext mng modules mozilla mp3 mp4 mpeg mtp ncurses network nfs nls nptl nptlonly nsplugin ogg ogm openal opengl openmp oss pam pango pcre pdf phonon plasma png pnm policykit postscript ppds python3 qt3support qt4 quicktime rar rdesktop readline real samba sasl scanner sdl search semantic-desktop session sftp sip slp smp socks socks5 spell sse sse2 sse3 sse4 sse4_1 sse4a ssh ssl ssse3 startup-notification stream svg symlink taglib tcpd theora tiff tk truetype type3 udev udisks unicode upower usb v4l vaapi vcd vcdx vda vlm vnc vorbis vpx wav wavpack webgl wifi wma wmf wxwidgets x264 xattr xcb xcomposite xinerama xml xpm xscreensaver xv xvid yahoo youtube zeroconf zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en ar fa" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" RUBY_TARGETS="ruby20" SANE_BACKENDS="gt68xx" USERLAND="GNU" VIDEO_CARDS="intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, SYNC, USE_PYTHON

The problem was solved by downgrading to :
emerge =bluedevil-1.3.2 =libbluedevil-1.9.4

What's wrong with SendFilesJob::createSessionSlot: "The name org.bluez.obex was not provided by any .service files"  ?

                                                                    

Reproducible: Always
Comment 1 Pacho Ramos gentoo-dev 2014-04-06 14:14:16 UTC
Is bluetoothd running when you try to use bluedevil?
Comment 2 Kete Tefid 2014-04-07 17:24:02 UTC
(In reply to Pacho Ramos from comment #1)
> Is bluetoothd running when you try to use bluedevil?

Yes. Of course. Otherwise it could not have detected my adapter.
Comment 3 Kete Tefid 2014-04-07 17:25:44 UTC
I hope you meant /etc/init.d/bluetooth. yes? If so, yes. It is running.
Comment 4 Johannes Huber gentoo-dev 2014-04-07 18:35:23 UTC

*** This bug has been marked as a duplicate of bug 504570 ***
Comment 5 Pacho Ramos gentoo-dev 2014-04-07 19:44:54 UTC
Please ensure bluetoothd is still running when you get the problem (ps axu | grep bluetoothd), maybe it has worked for some reason

Regarding making this a duplicate of bug 504570 ... I am unsure, since it works fine for me on gnome with gnome-user-share running and, then, I am unsure it's a problem in bluez :/

Maybe this reporter could try with gnome + gnome-user-share to try to focus the issue :|
Comment 6 Kete Tefid 2014-04-07 20:26:52 UTC
Hello again.

Bluetoothd is running.

ps axu | grep bluetoothd
root      3125  0.0  0.0  21356  1716 ?        Ss   Apr06   0:00 /usr/sbin/bluetoothd
root     15193  0.0  0.0    768     4 pts/3    D+   00:46   0:00 grep --colour=auto bluetoothd


Maybe bluez 5.15 wants systemd. I might not be correct. 
Also I don't have a gnome system. It would be a real burden to install gnome on my laptop.

Is the error dbus related?
SendFilesJob::createSessionSlot: "The name org.bluez.obex was not provided by any .service files"

Why does it work with bluez 4.101-r8 and not 5.15?
Also I think that this bug is different than 504570. The errors are different. That user cannot send from phone to pc while sending files from pc to phone is possible for him/her. For me neither ways are working.
Comment 7 Stephan Karacson 2014-04-09 17:03:23 UTC
I can confirm the exact problem of  Kete Tefid.
send&recive not possible.
only a manual mask of
=net-wireless/bluez-5.15
=net-wireless/bluedevil-2.0_rc1
works for me as libbluedevil-2 needs bluez-5.
Comment 8 Johannes Huber gentoo-dev 2014-04-13 09:06:48 UTC
Could you please try to remove app-mobilephone/obexd and test again with with net-wireless/bluez-5.15? (Info from bug #507486)
Comment 9 Stephan Karacson 2014-04-14 18:07:20 UTC
Tested with unmerges obexd.
Behaviour is different. bluedevil 2.0_rc1 icon now shows me a connection, but transfer fails.
Tested both directions against nokia, android.
Comment 10 Stephan Karacson 2014-05-11 09:09:36 UTC
Tested with bluedevil-2.0_rc1-r1 which demans uninstall of obexd and the server.
bluez is 5.18

Tested with nokia SymbianOS and Android 4.4.2 with two Gentoo PCs.

Connection is made, but send and recieve fails.
It works with bluedevil 1.

here is a hcidump, perhaps it helps.
I sended a ogg-file from Android Tablet to the bluedevil-2 PC:
hcidump
HCI sniffer - Bluetooth packet analyzer ver 2.5
device: hci0 snap_len: 1500 filter: 0xffffffffffffffff
> HCI Event: Connect Request (0x04) plen 10
    bdaddr 08:60:6E:3F:54:62 class 0x1a0114 type ACL
< HCI Command: Accept Connection Request (0x01|0x0009) plen 7
    bdaddr 08:60:6E:3F:54:62 role 0x00
    Role: Master
> HCI Event: Command Status (0x0f) plen 4
    Accept Connection Request (0x01|0x0009) status 0x00 ncmd 1
> HCI Event: Role Change (0x12) plen 8
    status 0x00 bdaddr 08:60:6E:3F:54:62 role 0x00
    Role: Master
> HCI Event: Connect Complete (0x03) plen 11
    status 0x00 handle 41 bdaddr 08:60:6E:3F:54:62 type ACL encrypt 0x00
< HCI Command: Read Remote Supported Features (0x01|0x001b) plen 2
    handle 41
> HCI Event: Page Scan Repetition Mode Change (0x20) plen 7
    bdaddr 08:60:6E:3F:54:62 mode 0
> HCI Event: Max Slots Change (0x1b) plen 3
    handle 41 slots 5
> HCI Event: Command Status (0x0f) plen 4
    Read Remote Supported Features (0x01|0x001b) status 0x00 ncmd 0
> ACL data: handle 41 flags 0x02 dlen 10
    L2CAP(s): Info req: type 2
< ACL data: handle 41 flags 0x02 dlen 16
    L2CAP(s): Info rsp: type 2 result 0
      Extended feature mask 0x00b8
        Enhanced Retransmission mode
        Streaming mode
        FCS Option
        Fixed Channels
> HCI Event: Command Status (0x0f) plen 4
    Unknown (0x00|0x0000) status 0x00 ncmd 1
< HCI Command: Change Connection Packet Type (0x01|0x000f) plen 4
    handle 41 ptype 0xcc18
    Packet type: DM1 DM3 DM5 DH1 DH3 DH5 
> HCI Event: Number of Completed Packets (0x13) plen 5
    handle 41 packets 1
> ACL data: handle 41 flags 0x02 dlen 10
    L2CAP(s): Info req: type 3
< ACL data: handle 41 flags 0x02 dlen 20
    L2CAP(s): Info rsp: type 3 result 0
      Fixed channel list 0x00000002
        L2CAP Signalling Channel
> HCI Event: Number of Completed Packets (0x13) plen 5
    handle 41 packets 1
> ACL data: handle 41 flags 0x02 dlen 12
    L2CAP(s): Connect req: psm 1 scid 0x0044
> HCI Event: Command Status (0x0f) plen 4
    Change Connection Packet Type (0x01|0x000f) status 0x00 ncmd 1
< ACL data: handle 41 flags 0x02 dlen 16
    L2CAP(s): Connect rsp: dcid 0x0040 scid 0x0044 result 1 status 0
      Connection pending - No futher information available
< ACL data: handle 41 flags 0x02 dlen 10
    L2CAP(s): Info req: type 2
> HCI Event: Connection Packet Type Changed (0x1d) plen 5
    status 0x00 handle 41 ptype 0xcc18
    Packet type: DM1 DM3 DM5 DH1 DH3 DH5 
> HCI Event: Number of Completed Packets (0x13) plen 5
    handle 41 packets 1
> HCI Event: Read Remote Supported Features (0x0b) plen 11
    status 0x00 handle 41
    Features: 0xbf 0xfe 0xcf 0xfe 0xdb 0xff 0x7b 0x87
> HCI Event: Number of Completed Packets (0x13) plen 5
    handle 41 packets 1
> ACL data: handle 41 flags 0x02 dlen 16
    L2CAP(s): Info rsp: type 2 result 0
      Extended feature mask 0x00b8
        Enhanced Retransmission mode
        Streaming mode
        FCS Option
        Fixed Channels
< ACL data: handle 41 flags 0x02 dlen 10
    L2CAP(s): Info req: type 3
> HCI Event: Number of Completed Packets (0x13) plen 5
    handle 41 packets 1
> ACL data: handle 41 flags 0x02 dlen 20
    L2CAP(s): Info rsp: type 3 result 0
      Fixed channel list 0x00000002
        L2CAP Signalling Channel
< ACL data: handle 41 flags 0x02 dlen 16
    L2CAP(s): Connect rsp: dcid 0x0040 scid 0x0044 result 0 status 0
      Connection successful
< ACL data: handle 41 flags 0x02 dlen 23
    L2CAP(s): Config req: dcid 0x0044 flags 0x00 clen 11
      RFC 0x00 (Basic) 
> HCI Event: Number of Completed Packets (0x13) plen 5
    handle 41 packets 1
> HCI Event: Number of Completed Packets (0x13) plen 5
    handle 41 packets 1
> ACL data: handle 41 flags 0x02 dlen 16
    L2CAP(s): Config req: dcid 0x0040 flags 0x00 clen 4
      MTU 256 
< ACL data: handle 41 flags 0x02 dlen 18
    L2CAP(s): Config rsp: scid 0x0044 flags 0x00 result 0 clen 4
      MTU 256 
> ACL data: handle 41 flags 0x02 dlen 14
    L2CAP(s): Config rsp: scid 0x0040 flags 0x00 result 0 clen 0
      Success
> HCI Event: Number of Completed Packets (0x13) plen 5
    handle 41 packets 1
> ACL data: handle 41 flags 0x02 dlen 38
    L2CAP(d): cid 0x0040 len 34 [psm 1]
        SDP SSA Req: tid 0x0 len 0x1d
          pat uuid-128 00001105-0000-1000-8000-00805f9b34fb
          max 240
          aid(s) 0x0000 - 0xffff
          cont 00
< ACL data: handle 41 flags 0x02 dlen 14
    L2CAP(d): cid 0x0044 len 10 [psm 1]
        SDP SSA Rsp: tid 0x0 len 0x5
          count 2
          cont 00
> HCI Event: Number of Completed Packets (0x13) plen 5
    handle 41 packets 1
> ACL data: handle 41 flags 0x02 dlen 12
    L2CAP(s): Disconn req: dcid 0x0040 scid 0x0044
< ACL data: handle 41 flags 0x02 dlen 12
    L2CAP(s): Disconn rsp: dcid 0x0040 scid 0x0044
> HCI Event: Number of Completed Packets (0x13) plen 5
    handle 41 packets 1
< HCI Command: Disconnect (0x01|0x0006) plen 3
    handle 41 reason 0x13
    Reason: Remote User Terminated Connection
> HCI Event: Command Status (0x0f) plen 4
    Disconnect (0x01|0x0006) status 0x00 ncmd 1
> HCI Event: Disconn Complete (0x05) plen 4
    status 0x00 handle 41 reason 0x13
    Reason: Remote User Terminated Connection

Android tells me it fails. File is not on my PC.
This new bluedevil makes me crazy,  :-(

bluedevil 1.3.2 works as expected
Comment 11 Pacho Ramos gentoo-dev 2014-05-11 09:34:51 UTC
(In reply to Stephan Karacson from comment #10)
> Tested with bluedevil-2.0_rc1-r1 which demans uninstall of obexd and the
> server.
> bluez is 5.18

What is the bluedevil-send output with this setup?
Comment 12 Stephan Karacson 2014-05-11 11:20:12 UTC
$ bluedevil-sendfile 
Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 14: reading configurations from ~/.fonts.conf is deprecated.
Object::connect: No such signal BlueDevil::Adapter::deviceFound(QVariantMap)
Object::connect:  (receiver name: 'Discover')
======================== 
Address:  "00:1C:9A:F5:CB:6F" 
Name:  "VrennsPad2" 
Alias:  "VrennsPad2" 
Icon:  "phone" 

 
======================== 
Address:  "08:60:6E:3F:54:62" 
Name:  "Karapad" 
Alias:  "Karapad" 
Icon:  "computer" 

 
Object::connect: No such signal org::freedesktop::UPower::DeviceAdded(QDBusObjectPath)
Object::connect: No such signal org::freedesktop::UPower::DeviceRemoved(QDBusObjectPath)
bluedevilsendfile(2197) KSambaSharePrivate::findSmbConf: KSambaShare: Could not find smb.conf!

Click on send file just closes the dialog, my phone or tablet dosen't recognize that gentoo wanted to send something.
Comment 13 Pacho Ramos gentoo-dev 2014-05-11 12:14:00 UTC
Maybe an upstream report to bluedevil maintainers could help us to find where is the issue:
https://bugs.kde.org/

Stephan, could you do that? (as you have the setup to test what upstream could ask you). Also, please post here the link to let us track the issue

Thanks
Comment 14 Stephan Karacson 2014-05-11 12:59:02 UTC
There seems to be a bugreport already.
https://bugs.kde.org/show_bug.cgi?id=332087
Sad that there is quite low activity for 2 month.
Another user has 3 Gentoo systems failing send/recieve.
I left my links.
Comment 15 Pacho Ramos gentoo-dev 2014-05-11 13:02:43 UTC
Try posting you last errors and show them that you are running latest bluez and so
Comment 16 Stephan Karacson 2014-05-11 14:15:37 UTC
I posted hcidumps, dbus-logs and bluez/kde/bluedevil versions.
I hope I'm not flooding to much (or to less, if you need the logs here please tell)
Thank you for helping.
I wished I could do more, but even to interpret the dbus-logs is over my classification, anyway I want to hunt this bug down.

I see now bluedevil1 has following lines of dbus:
method call sender=:1.103 -> dest=org.openobex.client serial=26 path=/; interface=org.openobex.Client; member=SendFiles
   array [
      dict entry(
         string "Destination"
         variant             string "00:1C:9A:F5:CB:6F"
      )
   ]
   array [
      string "/home/stephan/bilder/aquarium/03032007(004).jpg"
   ]
   object path "/BlueDevil_sendAgent"

bluedevil 2 has following lines:
member=AddMatch
   string "type='signal',sender='org.freedesktop.DBus',interface='org.freedesktop.DBus',member='NameOwnerChanged',arg0='org.bluez.obex'"

It seems that bluedevil2 uses org.bluez.obex instead of org.openobex.client as sending "dbus object?", but where the hell is the destination declared?
Comment 17 Pacho Ramos gentoo-dev 2014-07-22 19:55:14 UTC
Please retry with:
+*bluez-5.21-r1 (22 Jul 2014)
+
+  22 Jul 2014; Pacho Ramos <pacho@gentoo.org> +bluez-5.21-r1.ebuild,
+  -bluez-5.21.ebuild:
+  dbus file wasn't being installed with USE -systemd due missing eautoreconf
+  (#517818 by Uros)
+
Comment 18 Stephan Karacson 2014-07-23 13:21:54 UTC
Tested bluedevil 2.0_rc1 & 2.0_rc1-r1 with bluez 5.21-r1.
Works out of the box with my android and old nokia in both directions.
Thanks to the bughunters of kde.org and to you resolving it.
Comment 19 Pacho Ramos gentoo-dev 2014-07-23 13:24:10 UTC
Big thanks to Uros for finding the issue (I wasn't suffering it as I use systemd ;)) -> it's already stable on amd64 and for the rest it will be handled in bug 512012