Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 506616 - app-admin/perl-cleaner - dependency resolution fails on virtual/perl-*
Summary: app-admin/perl-cleaner - dependency resolution fails on virtual/perl-*
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Development (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Paul Varner (RETIRED)
URL:
Whiteboard:
Keywords:
: 507040 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-04-02 23:31 UTC by Austin English (RETIRED)
Modified: 2014-06-07 11:30 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Austin English (RETIRED) gentoo-dev 2014-04-02 23:31:52 UTC
Trying to fix my system after an emerge world and a perl upgrade:
aw25 perl-digest-base # perl-cleaner --reallyall ; echo $?
...

dev-lang/perl:0

  (dev-lang/perl-5.18.2:0/5.18::gentoo, installed) pulled in by
    =dev-lang/perl-5.18* required by (virtual/perl-IO-1.280.0:0/0::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                     
    (and 2 more with the same problem)

  (dev-lang/perl-5.16.3:0/5.16::gentoo, ebuild scheduled for merge) pulled in by
    =dev-lang/perl-5.16* required by (virtual/perl-Locale-Maketext-Simple-0.210.0-r2:0/0::gentoo, installed)
    ^              ^^^^^                                                                                                                                           
    (and 5 more with the same problem)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


The following mask changes are necessary to proceed:
 (see "package.unmask" in the portage(5) man page for more details)
# required by virtual/perl-Test-Simple-0.980.0-r2
# required by perl-core/CPAN-Meta-2.132.510
# required by virtual/perl-CPAN-Meta-2.132.510
# required by perl-core/ExtUtils-MakeMaker-6.820.0
# required by virtual/perl-ExtUtils-MakeMaker-6.820.0
# required by dev-perl/IO-HTML-1.00.0
# required by dev-perl/HTTP-Message-6.60.0
# required by dev-perl/HTTP-Cookies-6.0.1-r1
# required by dev-perl/libwww-perl-6.50.0
# required by dev-vcs/git-1.9.1[subversion,perl]
# required by @system
# required by @world (argument)
# /etc/portage/package.mask/mask:
=dev-lang/perl-5.16.3

Reproducible: Always

Steps to Reproduce:
perl-clean --all



aw25 gentoo # emerge --info
Portage 2.2.10 (default/linux/amd64/13.0, gcc-4.8.2, glibc-2.19, 3.12.0-gentoo-devlight-1 x86_64)
=================================================================
System uname: Linux-3.12.0-gentoo-devlight-1-x86_64-Intel-R-_Core-TM-_i7_CPU_960_@_3.20GHz-with-gentoo-2.2
KiB Mem:     6106996 total,    328472 free
KiB Swap:   11718652 total,   9211232 free
Timestamp of tree: Wed, 02 Apr 2014 02:05:01 +0000
ld GNU ld (GNU Binutils) 2.24
app-shells/bash:          4.2_p46
dev-java/java-config:     2.2.0
dev-lang/python:          2.7.6, 3.3.5, 3.4.0
dev-util/cmake:           2.8.12.2
dev-util/pkgconfig:       0.28-r1
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.12.4
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6, 1.12.6, 1.13.4, 1.14.1
sys-devel/binutils:       2.24-r2
sys-devel/gcc:            4.7.3-r1, 4.8.2
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2::austin-overlay
sys-devel/make:           4.0-r1
sys-kernel/linux-headers: 3.14 (virtual/os-headers)
sys-libs/glibc:           2.19
Repositories: gentoo
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -g -march=corei7 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt /usr/share/maven-bin-3.1/conf"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -g -march=corei7 -pipe"
DISTDIR="/var/portage/distfiles"
EMERGE_DEFAULT_OPTS="--getbinpkg --usepkg=y --binpkg-respect-use=y --jobs=4 --load-average=4"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
INSTALL_MASK="/usr/lib/systemd/system /usr/lib/systemd/system-sleep /lib/systemd/system"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j8"
PKGDIR="/var/portage/packages"
PORTAGE_COMPRESS="xz"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/var/portage/repos/gentoo"
USE="X aac acl acpi alsa amd64 apng avx bash-completion bzip2 cairo caps cdda cdio cli consolekit cracklib crypt cups curl cxx dbus device-mapper dri dvd egl exif ffmpeg fftw flac fuse gif git gmp gnome-keyring gpm gtk iconv ipv6 ithreads jbit jpeg jpeg2k lcms libffi libnotify lzma lzo mad mmap mmx mmxext mng modules mp3 mtp multilib ncurses networking nptl ogg openal opengl openmp openssl openvg opus pam pcre pdf png pnm policykit python readline session sndfile spell sqlite sse sse2 sse3 sse4_1 ssl ssse3 startup-notification svg theora threads tiff truetype udev unicode usb usbredir vaapi vdpau vim vim-syntax vorbis vpx x264 xattr xcb xinerama xorg xv zlib zsh-completion" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" RUBY_TARGETS="ruby19 ruby20" USERLAND="GNU" VIDEO_CARDS="fbdev glint intel mach64 mga nouveau nv r128 radeon savage sis tdfx trident vesa via vmware dummy nvidia qxl radeonsi v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
USE_PYTHON="2.7 3.3"
Unset:  CPPFLAGS, CTARGET, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, SYNC
Comment 1 Jeroen Roovers gentoo-dev 2014-04-03 00:03:21 UTC
# required by virtual/perl-Test-Simple-0.980.0-r2

With dev-lang/perl-5.18 unmasked you should also have =virtual/perl-Test-Simple-0.980.0-r3 - the above does indeed block, and presumably for good reasons.
Comment 2 Austin English (RETIRED) gentoo-dev 2014-04-03 00:11:11 UTC
(In reply to Jeroen Roovers from comment #1)
> # required by virtual/perl-Test-Simple-0.980.0-r2
> 
> With dev-lang/perl-5.18 unmasked you should also have
> =virtual/perl-Test-Simple-0.980.0-r3 - the above does indeed block, and
> presumably for good reasons.

I have that package unmasked:
austin@aw25 ~ $ eix virtual/perl-Test-Simple
[U] virtual/perl-Test-Simple
     Available versions:  0.94 (~)0.96 0.980.0-r2 (~)0.980.0-r3
     Installed versions:  0.980.0-r2(07:39:41 PM 12/13/2013)
     Description:         Virtual for Test-Simple

austin@aw25 ~ $ cat /etc/portage/package.accept_keywords 
# First multilib version
=dev-libs/libxslt-1.1.28-r2 ~amd64
=dev-libs/libgcrypt-1.6.1-r1 ~amd64

# perl..
=virtual/perl-Locale-Maketext-Simple-0.210.0-r3 ~amd64
=virtual/perl-Package-Constants-0.20.0-r3 ~amd64
=virtual/perl-Test-Simple-0.980.0-r3 ~amd64
=virtual/perl-digest-base-1.170.0-r2 ~amd64
Comment 3 Jeroen Roovers gentoo-dev 2014-04-03 14:20:26 UTC
You appear to already have this set:

ACCEPT_KEYWORDS="amd64 ~amd64"

so why do you additionally use package.accept_keywords ?
Comment 4 Jeroen Roovers gentoo-dev 2014-04-07 13:59:57 UTC
*** Bug 507040 has been marked as a duplicate of this bug. ***
Comment 5 Jeroen Roovers gentoo-dev 2014-04-07 18:22:48 UTC
*** Bug 507040 has been marked as a duplicate of this bug. ***
Comment 6 Austin English (RETIRED) gentoo-dev 2014-04-07 18:43:14 UTC
(In reply to Jeroen Roovers from comment #3)
> You appear to already have this set:
> 
> ACCEPT_KEYWORDS="amd64 ~amd64"
> 
> so why do you additionally use package.accept_keywords ?

I had set those in an attempt to prod portage to figure out the dependencies. If I remove them, the emerge still fails, just fails on a different dependency:

Total: 111 packages (5 upgrades, 1 downgrade, 1 new, 104 reinstalls, 2 binaries), Size of downloads: 200 kB

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-lang/perl:0

  (dev-lang/perl-5.18.2:0/5.18::gentoo, installed) pulled in by
    =dev-lang/perl-5.18* required by (virtual/perl-libnet-1.230.0:0/0::gentoo, installed)
    ^              ^^^^^                                                                                                                        
    (and 2 more with the same problem)

  (dev-lang/perl-5.16.3:0/5.16::gentoo, ebuild scheduled for merge) pulled in by
    =dev-lang/perl-5.16* required by (virtual/perl-digest-base-1.170.0-r2:0/0::gentoo, installed)
    ^              ^^^^^                                                                                                                                
    (and 5 more with the same problem)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


The following mask changes are necessary to proceed:
 (see "package.unmask" in the portage(5) man page for more details)
# required by virtual/perl-digest-base-1.170.0-r2
# required by perl-core/Digest-MD5-2.530.0
# required by virtual/perl-Digest-MD5-2.530.0
# required by dev-perl/Digest-HMAC-1.30.0
# required by dev-perl/Authen-SASL-2.160.0
# required by dev-vcs/git-1.9.1[perl]
# required by @system
# required by @world (argument)
# /etc/portage/package.mask/mask:
=dev-lang/perl-5.16.3

NOTE: The --autounmask-keep-masks option will prevent emerge
      from creating package.unmask or ** keyword changes.
Comment 7 Austin English (RETIRED) gentoo-dev 2014-04-08 01:14:44 UTC
perl-cleaner --reallyall -- -t --backtrack=30

worked around it for me
Comment 8 Markus Knetschke 2014-04-08 20:25:22 UTC
backtrack=30 solved my problem too.
Comment 9 Paweł Hajdan, Jr. (RETIRED) gentoo-dev 2014-05-21 11:09:54 UTC
(In reply to Markus Knetschke from comment #8)
> backtrack=30 solved my problem too.

+1 "perl-cleaner --all -- --backtrack=30" works

Please consider making it default.
Comment 10 Andreas K. Hüttel gentoo-dev 2014-06-06 20:00:39 UTC
This is fixed in perl-cleaner-2.13 (backtrack option added per default).