Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 506466 - x11-drivers/nvidia-drivers-334.21-r3 wont compile for sys-kernel/gentoo-sources-3.14.0
Summary: x11-drivers/nvidia-drivers-334.21-r3 wont compile for sys-kernel/gentoo-sou...
Status: RESOLVED DUPLICATE of bug 447566
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-04-01 14:26 UTC by tman
Modified: 2014-04-09 16:22 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
nvidia patch for 3.14 from arch (nv-314.patch,416 bytes, patch)
2014-04-01 22:57 UTC, Harris Landgarten
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description tman 2014-04-01 14:26:50 UTC
In file included from /var/tmp/portage/x11-drivers/nvidia-drivers-334.21-r3/work/kernel/nv-linux.h:277:0,
                 from /var/tmp/portage/x11-drivers/nvidia-drivers-334.21-r3/work/kernel/nv-i2c.c:15:
/usr/src/linux-3.14.0-gentoo/include/acpi/acpi_drivers.h: At top level:
/usr/src/linux-3.14.0-gentoo/include/acpi/acpi_drivers.h:98:43: warning: ‘struct acpi_pci_root’ declared inside parameter list [enabled by default]
 struct pci_bus *pci_acpi_scan_root(struct acpi_pci_root *root);
                                           ^
/usr/src/linux-3.14.0-gentoo/include/acpi/acpi_drivers.h:98:43: warning: its scope is only this definition or declaration, which is probably not what you want [enabled by default]
/usr/src/linux-3.14.0-gentoo/Makefile:1274: recipe for target '_module_/var/tmp/portage/x11-drivers/nvidia-drivers-334.21-r3/work/kernel' failed
make[2]: *** [_module_/var/tmp/portage/x11-drivers/nvidia-drivers-334.21-r3/work/kernel] Error 2
Makefile:133: recipe for target 'sub-make' failed
make[1]: *** [sub-make] Error 2
make[1]: Leaving directory '/usr/src/linux-3.14.0-gentoo'
NVIDIA: left KBUILD.
 nvidia.ko failed to build!
Makefile:170: recipe for target 'nvidia.ko' failed
make: *** [nvidia.ko] Error 1
 * ERROR: x11-drivers/nvidia-drivers-334.21-r3::gentoo failed (compile phase):
 *   emake failed
 * 
 * If you need support, post the output of `emerge --info '=x11-drivers/nvidia-drivers-334.21-r3::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=x11-drivers/nvidia-drivers-334.21-r3::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/x11-drivers/nvidia-drivers-334.21-r3/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/x11-drivers/nvidia-drivers-334.21-r3/temp/environment'.
 * Working directory: '/var/tmp/portage/x11-drivers/nvidia-drivers-334.21-r3/work/kernel'
 * S: '/var/tmp/portage/x11-drivers/nvidia-drivers-334.21-r3/work/'

 * Messages for package x11-drivers/nvidia-drivers-334.21-r3:

 * Gentoo supports kernels which are supported by NVIDIA
 * which are limited to the following kernels:
 * <sys-kernel/gentoo-sources-3.14
 * <sys-kernel/vanilla-sources-3.14


Reproducible: Always



Expected Results:  
System uname: Linux-3.13.7-gentoo-x86_64-Intel-R-_Core-TM-_i7-3740QM_CPU_@_2.70GHz-with-gentoo-2.2
KiB Mem:    24695476 total,  21462796 free
KiB Swap:   25598972 total,  25598972 free
Timestamp of tree: Tue, 01 Apr 2014 13:00:01 +0000
ld GNU ld (GNU Binutils) 2.24
app-shells/bash:          4.2_p46
dev-java/java-config:     2.2.0
dev-lang/python:          2.7.6, 3.2.5-r3, 3.3.5, 3.4.0
dev-util/cmake:           2.8.12.2
dev-util/pkgconfig:       0.28-r1
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.12.4
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6, 1.14.1
sys-devel/binutils:       2.24-r2
sys-devel/gcc:            4.8.2
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           4.0-r1
sys-kernel/linux-headers: 3.14 (virtual/os-headers)
sys-libs/glibc:           2.19
Repositories: gentoo bitcoin lokal
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=corei7 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.5/ext-active/ /etc/php/cgi-php5.5/ext-active/ /etc/php/cli-php5.5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=corei7 -O2 -pipe"
DISTDIR="/mnt/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="de_DE.UTF-8"
LC_ALL=""
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j9"
PKGDIR="/mnt/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/mnt/portage"
Comment 1 Mr. Bones. (RETIRED) gentoo-dev 2014-04-01 15:15:06 UTC
The ebuild says:

    if use kernel_linux && kernel_is ge 3 14 ; then
        ewarn "Gentoo supports kernels which are supported by NVIDIA"
        ewarn "which are limited to the following kernels:"
        ewarn "<sys-kernel/gentoo-sources-3.14"
        ewarn "<sys-kernel/vanilla-sources-3.14"
        ewarn ""
        ewarn "You are free to utilize epatch_user to provide whatever"
        ewarn "support you feel is appropriate, but will not receive"
        ewarn "support as a result of those changes."
        ewarn ""
        ewarn "Do not file a bug report about this."
    fi

In your emerge output you chopped off the last part about not filing a bug report about this.
Comment 2 Jeroen Roovers gentoo-dev 2014-04-01 19:10:14 UTC
Oh, this is the next round already?

*** This bug has been marked as a duplicate of bug 447566 ***
Comment 3 Harris Landgarten 2014-04-01 22:57:47 UTC
Created attachment 374056 [details, diff]
nvidia patch for 3.14 from arch

This patch is from arch-linux for 3.14
Comment 5 Jeroen Roovers gentoo-dev 2014-04-09 16:22:17 UTC
(In reply to SpanKY from comment #4)
> Commit message: Add patch to fix building w/linux-3.14
> http://sources.gentoo.org/x11-drivers/nvidia-drivers/files/nvidia-drivers-
> 334.21-linux-3.14.patch?rev=1.1
> http://sources.gentoo.org/x11-drivers/nvidia-drivers/nvidia-drivers-334.21-
> r3.ebuild?r1=1.2&r2=1.3

And reverted.