Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 506136 - media-gfx/blender-2.70 depends on package.masked media-video/ffmpeg-2.1.4
Summary: media-gfx/blender-2.70 depends on package.masked media-video/ffmpeg-2.1.4
Status: RESOLVED DUPLICATE of bug 505364
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Keywording and Stabilization (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-03-29 09:59 UTC by Cyp
Modified: 2014-03-30 22:41 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Cyp 2014-03-29 09:59:05 UTC
Stable virtual/ffmpeg-0.10.3 pulls in masked >=media-video/ffmpeg-0.10.3:0.

Earliest version of virtual/ffmpeg is 0.10.3.

Guessing maybe 0.10.12 should be marked stable, and the dependency should be >=media-video/ffmpeg-0.10.3:0.10 instead of >=media-video/ffmpeg-0.10.3:0?

[I] media-video/ffmpeg
     Available versions:  
     (0.10) ~0.10.12
     (0)    1.0.8 ~1.0.9 ~1.2.6 [M]~2.1.4(0/52.55.55) [M]~2.2_rc2(0/52.55.55) [M]~2.2(0/52.55.55) [M]**9999(0/52.55.55)

[I] virtual/ffmpeg
     Available versions:  0.10.3 ~9
Comment 1 Alex Xu (Hello71) 2014-03-29 11:26:01 UTC
Please paste the entire output of emerge -pqv virtual/ffmpeg.
Comment 2 Jeroen Roovers gentoo-dev 2014-03-29 15:24:29 UTC
1) Please post your `emerge --info' output in a comment.
2) Please post your `emerge -pvt virtual/ffmpeg' output in a comment.
Comment 3 Cyp 2014-03-29 17:28:32 UTC
The 'emerge -pvt virtual/ffmpeg' didn't complain, looks like it's unstable blender-2.70 pulling masked >=media-video/ffmpeg-2.1.4:0 in.

Not sure why virtual/ffmpeg and app-cdr/k3b get the blame in the output of emerge -avuDN world or emerge -pvu1 blender, since they seem to have nothing to do with it...

############################################################

# emerge -avuDN world
...
[ebuild     U #] media-video/ffmpeg-2.2:0/52.55.55 [1.0.8:0/0] USE="3dnow 3dnowext X aac alsa bzip2 doc encode fontconfig gnutls hardcoded-tables iconv%* jpeg2k libcaca mmx mmxext mp3 network opengl%* opus oss rtmp sdl speex sse%* sse2%* ssse3 theora threads truetype v4l vorbis vpx x264 xvid zlib -aacplus (-altivec) -amr -amrenc% (-armv5te) (-armv6) (-armv6t2) (-armvfp) -avx -avx2% -bindist -bluray -cdio -celt -cpudetection -debug -examples -faac -fdk -flite -fma3% -fma4% -frei0r -gme% -gsm -iec61883 -ieee1394 -jack -ladspa% -libass -libsoxr% -libv4l (-mips32r2) (-mipsdspr1) (-mipsdspr2) (-mipsfpu) -modplug (-neon) -openal -openssl -pic -pulseaudio -quvi% -schroedinger -sse3% -sse4% -sse4_2% -ssh% -static-libs {-test} -twolame -vaapi -vdpau -wavpack% -webp% -x265% -zvbi% (-vis%)" FFTOOLS="aviocat cws2fws ffescape%* ffeval ffhash%* fourcc2pixfmt graph2dot ismindex pktdumper qt-faststart trasher" 6,861 kB
[ebuild  rR    ] media-gfx/hugin-2013.0.0-r1  USE="sift -debug -lapack -python" LINGUAS="da pt_BR -bg -ca -cs -de -en_GB -es -eu -fi -fr -hu -it -ja -ko -nl -pl -ro -ru -sk -sl -sv -uk -zh_CN -zh_TW" PYTHON_SINGLE_TARGET="python2_7 -python3_2 -python3_3" PYTHON_TARGETS="python2_7 python3_3 -python3_2" 0 kB
[ebuild     U ~] media-gfx/blender-2.70 [2.69] USE="boost bullet dds doc elbeem ffmpeg game-engine jpeg2k nls openexr openmp opennl%* sdl sndfile sse sse2 tiff -collada -colorio -cycles -debug -fftw -jack -ndof -openal -openimageio% -player -redcode" PYTHON_SINGLE_TARGET="python3_3" PYTHON_TARGETS="python3_3" 54,002 kB

Total: 55 packages (44 upgrades, 6 new, 5 reinstalls), Size of downloads: 567,676 kB

The following keyword changes are necessary to proceed:
 (see "package.accept_keywords" in the portage(5) man page for more details)
# required by virtual/ffmpeg-0.10.3
# required by media-video/transcode-1.1.7-r1
# required by app-cdr/k3b-2.0.2-r4[encode,dvd]
# required by @selected
# required by @world (argument)
=media-video/ffmpeg-2.2 ~amd64

The following mask changes are necessary to proceed:
 (see "package.unmask" in the portage(5) man page for more details)
# required by virtual/ffmpeg-0.10.3
# required by media-video/transcode-1.1.7-r1
# required by app-cdr/k3b-2.0.2-r4[encode,dvd]
# required by @selected
# required by @world (argument)
# /usr/portage/profiles/package.mask:
# Alexis Ballier <aballier@gentoo.org> (20 Jul 2013)
# New major release and lots of packages fail to build.
# Tracker bug is: https://bugs.gentoo.org/show_bug.cgi?id=476490
=media-video/ffmpeg-2.2
...

############################################################

# emerge -pvu1 blender

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] dev-python/charade-1.0.3  PYTHON_TARGETS="python2_7 python3_3 (-pypy2_0) -python2_6 -python3_2" 165 kB
[ebuild  N     ] dev-python/requests-1.2.3  USE="{-test}" PYTHON_TARGETS="python2_7 python3_3 (-pypy2_0) -python2_6 -python3_2" 341 kB
[ebuild     U #] media-video/ffmpeg-2.2:0/52.55.55 [1.0.8:0/0] USE="3dnow 3dnowext X aac alsa bzip2 doc encode fontconfig gnutls hardcoded-tables iconv%* jpeg2k libcaca mmx mmxext mp3 network opengl%* opus oss rtmp sdl speex sse%* sse2%* ssse3 theora threads truetype v4l vorbis vpx x264 xvid zlib -aacplus (-altivec) -amr -amrenc% (-armv5te) (-armv6) (-armv6t2) (-armvfp) -avx -avx2% -bindist -bluray -cdio -celt -cpudetection -debug -examples -faac -fdk -flite -fma3% -fma4% -frei0r -gme% -gsm -iec61883 -ieee1394 -jack -ladspa% -libass -libsoxr% -libv4l (-mips32r2) (-mipsdspr1) (-mipsdspr2) (-mipsfpu) -modplug (-neon) -openal -openssl -pic -pulseaudio -quvi% -schroedinger -sse3% -sse4% -sse4_2% -ssh% -static-libs {-test} -twolame -vaapi -vdpau -wavpack% -webp% -x265% -zvbi% (-vis%)" FFTOOLS="aviocat cws2fws ffescape%* ffeval ffhash%* fourcc2pixfmt graph2dot ismindex pktdumper qt-faststart trasher" 6,861 kB
[ebuild     U ~] media-gfx/blender-2.70 [2.69] USE="boost bullet dds doc elbeem ffmpeg game-engine jpeg2k nls openexr openmp opennl%* sdl sndfile sse sse2 tiff -collada -colorio -cycles -debug -fftw -jack -ndof -openal -openimageio% -player -redcode" PYTHON_SINGLE_TARGET="python3_3" PYTHON_TARGETS="python3_3" 54,002 kB

Total: 4 packages (2 upgrades, 2 new), Size of downloads: 61,368 kB

The following keyword changes are necessary to proceed:
 (see "package.accept_keywords" in the portage(5) man page for more details)
# required by virtual/ffmpeg-0.10.3
# required by media-video/transcode-1.1.7-r1
# required by app-cdr/k3b-2.0.2-r4[encode,dvd]
# required by @selected
# required by @world (argument)
=media-video/ffmpeg-2.2 ~amd64

The following mask changes are necessary to proceed:
 (see "package.unmask" in the portage(5) man page for more details)
# required by virtual/ffmpeg-0.10.3
# required by media-video/transcode-1.1.7-r1
# required by app-cdr/k3b-2.0.2-r4[encode,dvd]
# required by @selected
# required by @world (argument)
# /usr/portage/profiles/package.mask:
# Alexis Ballier <aballier@gentoo.org> (20 Jul 2013)
# New major release and lots of packages fail to build.
# Tracker bug is: https://bugs.gentoo.org/show_bug.cgi?id=476490
=media-video/ffmpeg-2.2
...

############################################################

# emerge --info
Portage 2.2.8-r1 (default/linux/amd64/13.0/desktop/kde, gcc-4.7.3, glibc-2.17, 3.8.13-gentoo x86_64)
=================================================================
System uname: Linux-3.8.13-gentoo-x86_64-Intel-R-_Core-TM-_i7-3770K_CPU_@_3.50GHz-with-gentoo-2.2
KiB Mem:    16372436 total,   8304452 free
KiB Swap:   18798588 total,  18798588 free
Timestamp of tree: Sat, 29 Mar 2014 09:00:01 +0000
ld GNU ld (GNU Binutils) 2.23.2
ccache version 3.1.9 [disabled]
app-shells/bash:          4.2_p45
dev-java/java-config:     2.2.0
dev-lang/python:          2.7.5-r3, 3.2.5-r2, 3.3.4
dev-util/ccache:          3.1.9-r3
dev-util/cmake:           2.8.12.2
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.12.4
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.9.6-r3, 1.11.6, 1.12.6, 1.13.4
sys-devel/binutils:       2.23.2
sys-devel/gcc:            3.4.6-r2, 4.1.2, 4.2.4-r1, 4.3.6-r1, 4.4.7, 4.5.4, 4.6.4, 4.7.3-r1, 4.8.2
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.9 (virtual/os-headers)
sys-libs/glibc:           2.17
Repositories: gentoo My_local_repo x11 spring seden betagarden
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe -g"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib/X11/xkb /usr/share/config /usr/share/gnupg/qualified.txt /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.4/ext-active/ /etc/php/apache2-php5.5/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cgi-php5.5/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/php/cli-php5.5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe -g"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS=" http://gentoo.tiscali.nl/ http://mirrors.sec.informatik.tu-darmstadt.de/gentoo/ #http://pandemonium.tiscali.de/pub/gentoo/ http://ds.thn.htu.se/linux/gentoo"
LANG="en_US.UTF8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,-O1"
MAKEOPTS="-j8"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage /var/lib/layman/x11 /var/lib/layman/Spring /var/lib/layman/seden /var/lib/layman/betagarden"
USE="3dnow 3dnowext X a52 aac aalib acl acpi alisp alsa amd64 apache2 apng ares bash-completion bazaar bdf berkdb bluetooth branding bzip2 cairo cdda cdr cli consolekit cracklib crypt css cups curl cvs cxx d dbus declarative dhcp djvu dk doc dri dts dvd dvdr dvipdfm editor emboss emoticons-manager encode exif expat extensions extra fam ffmpeg firefox firefox3 flac fontconfig foomaticdb fortran g3dvl gcj gd gdbm gif git glitz gmp gnutls go gpm graphite graphviz gtk iconv icu imlib ipv6 irda ithreads jadetex java jpeg jpeg2k kde kerberos kipi kompare kpathsea lcms ldap libcaca libnotify live llvm logitech-mouse lzma mad mercurial midi mikmod mjpeg mmx mmxext mng modules mozilla mp2 mp3 mp4 mpeg msn mudflap multilib multitarget mysql ncurses network nls nodrm nptl nsplugin objc objc++ objc-gc offensive ogg ogre ois opengl openmp oss otr pam pango pcre pdf phonon plasma plotutils png policykit povray ppds qt3support qt4 qthelp readline rle rtmp samba scanner sdl se_swedb semantic-desktop server session sift sip sndfile solver speex spell sql sse sse2 ssl ssse3 startup-notification subversion svg tcpd tga theora threads tiff timidity tk tokenizer truetype udev udisks unicode upower usb v4l v4l2 vcd video videos vnc vorbis vpx wav webkit wma wxwidgets x264 xcb xcomposite xine xinerama xml xscreensaver xv xvid xvmc zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="cgid cgi actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en da pt_BR" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" RUBY_TARGETS="ruby19 ruby20" USERLAND="GNU" VIDEO_CARDS="v4l vesa vga intel radeon r600" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
USE_PYTHON="2.7 3.3"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, SYNC

############################################################

# emerge -pvt virtual/ffmpeg

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!
[ebuild   R    ] virtual/ffmpeg-0.10.3  USE="X encode jpeg2k mp3 sdl speex theora threads truetype x264 -gsm -vaapi -vdpau" 0 kB

Total: 1 package (1 reinstall), Size of downloads: 0 kB

 * IMPORTANT: 2 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.
Comment 4 Jeroen Roovers gentoo-dev 2014-03-30 22:41:06 UTC

*** This bug has been marked as a duplicate of bug 505364 ***