Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 505422 - sys-apps/portage-2.2.9: emerge fails to "emerge -1uavDN perl": KeyError: <Package ('installed', '/', 'sys-devel/autoconf-2.69', 'nomerge', 'installed')>
Summary: sys-apps/portage-2.2.9: emerge fails to "emerge -1uavDN perl": KeyError: <Pac...
Status: RESOLVED FIXED
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Core (show other bugs)
Hardware: All Linux
: Normal major (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords: InVCS
: 505488 505640 (view as bug list)
Depends on:
Blocks: 484436
  Show dependency tree
 
Reported: 2014-03-23 10:59 UTC by jannis
Modified: 2014-08-04 02:11 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info (einfo,25.08 KB, text/plain)
2014-03-23 10:59 UTC, jannis
Details
output of "emerge -1uavDN system" (ei,2.65 KB, text/plain)
2014-03-23 11:11 UTC, jannis
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jannis 2014-03-23 10:59:17 UTC
When I run "emerge -1uavDN perl", emerge exits with this traceback:
miramis ~ # emerge -1uavDN perl

These are the packages that would be merged, in order:

Calculating dependencies... done!
Traceback (most recent call last):
  File "/usr/bin/emerge", line 50, in <module>
    retval = emerge_main()
  File "/usr/lib64/portage/pym/_emerge/main.py", line 1037, in emerge_main
    return run_action(emerge_config)
  File "/usr/lib64/portage/pym/_emerge/actions.py", line 4061, in run_action
    emerge_config.args, spinner)
  File "/usr/lib64/portage/pym/_emerge/actions.py", line 320, in action_build
    settings, trees, myopts, myparams, myaction, myfiles, spinner)
  File "/usr/lib64/portage/pym/_emerge/depgraph.py", line 8402, in backtrack_depgraph
    myaction, myfiles, spinner)
  File "/usr/lib64/portage/pym/_emerge/depgraph.py", line 8434, in _backtrack_depgraph
    success, favorites = mydepgraph.select_files(myfiles)
  File "/usr/lib64/portage/pym/_emerge/depgraph.py", line 3092, in select_files
    return self._select_files(args)
  File "/usr/lib64/portage/pym/_emerge/depgraph.py", line 3428, in _select_files
    return self._resolve(myfavorites)
  File "/usr/lib64/portage/pym/_emerge/depgraph.py", line 3583, in _resolve
    self.altlist()
  File "/usr/lib64/portage/pym/_emerge/depgraph.py", line 6228, in altlist
    self._resolve_conflicts()
  File "/usr/lib64/portage/pym/_emerge/depgraph.py", line 6355, in _resolve_conflicts
    self._process_slot_conflicts()
  File "/usr/lib64/portage/pym/_emerge/depgraph.py", line 1212, in _process_slot_conflicts
    self._solve_non_slot_operator_slot_conflicts()
  File "/usr/lib64/portage/pym/_emerge/depgraph.py", line 1163, in _solve_non_slot_operator_slot_conflicts
    self._remove_pkg(pkg)
  File "/usr/lib64/portage/pym/_emerge/depgraph.py", line 2434, in _remove_pkg
    if not self._dynamic_config.digraph.parent_nodes(child):
  File "/usr/lib64/portage/pym/portage/util/digraph.py", line 155, in parent_nodes
    return list(self.nodes[node][1])
KeyError: <Package ('installed', '/', 'sys-devel/autoconf-2.69', 'nomerge', 'installed')>
miramis ~ # 

commands like "emerge -1uavDN system" still do run normally (output will be attached).

Reproducible: Always
Comment 1 jannis 2014-03-23 10:59:49 UTC
Created attachment 373304 [details]
emerge --info
Comment 2 jannis 2014-03-23 11:11:57 UTC
Created attachment 373306 [details]
output of "emerge -1uavDN system"
Comment 3 Sebastian Luther (few) 2014-03-24 17:10:14 UTC
*** Bug 505488 has been marked as a duplicate of this bug. ***
Comment 5 Brian Dolbec gentoo-dev 2014-03-25 14:39:06 UTC
*** Bug 505640 has been marked as a duplicate of this bug. ***
Comment 6 Brian Dolbec gentoo-dev 2014-08-04 02:11:23 UTC
released in portage-2.2.11