not much detail needed, I just don't want an old, unrecommended version of python to use plone.
Steps to Reproduce:
1. emerge plone (keywords ~x86 or without)
2. shout ARGH! why does it want python-2.1.3
It should use latest python, it works.
plone depend on zope and the lastest in portage zope-2.6.x is "No version of Zope is yet officially compatible with any version of Python 2.2" (quoted from http://zope.org/Documentation/Books/ZopeBook/2_6Edition/InstallingZope.stx). I suggest you bug for a version bump (http://zope.org/Products/Zope/2.7.0)
it's not that plone requires python-2.1.3, it's the zope 2.6 ebuild that requires python...
as soon as we have a 2.7 ebuild you can easily move to 2.3.3 - in meanwhile you might want to edit the zope ebuild (the ebuild describes how to set PYTHON_SLOT)