Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 504570 - net-wireless/bluez-5.15 - OBEX FTP file transfer fails
Summary: net-wireless/bluez-5.15 - OBEX FTP file transfer fails
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Pacho Ramos
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-03-14 08:43 UTC by Mehmet Giritli
Modified: 2014-07-25 08:14 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mehmet Giritli 2014-03-14 08:43:41 UTC
Phone says that "the transfer is forbidden by the target device" and I see this in my logs:

Mar 14 10:27:08 mordor obexd[2388]: CONNECT(0x0), (null)(0xffffffff)
Mar 14 10:27:08 mordor obexd[2388]: CONNECT(0x0), (null)(0x0)
Mar 14 10:27:08 mordor obexd[2388]: PUT(0x2), (null)(0xffffffff)
Mar 14 10:27:08 mordor obexd[2388]: PUT(0x2), FORBIDDEN(0x43)
Mar 14 10:27:08 mordor obexd[2388]: DISCONNECT(0x1), (null)(0xffffffff)
Mar 14 10:27:08 mordor obexd[2388]: DISCONNECT(0x1), SUCCESS(0x20)
Mar 14 10:27:08 mordor obexd[2388]: disconnected: Transport got disconnected

$emerge -pv bluez

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] net-wireless/bluez-5.15:0/3  USE="cups obex readline systemd -debug (-selinux) {-test}" 0 kB


Reproducible: Always




Portage 2.2.8-r1 (default/linux/amd64/13.0/desktop/gnome, gcc-4.7.3, glibc-2.17, 3.12.13-gentoo-mordor.giritli.eu x86_64)
=================================================================
System uname: Linux-3.12.13-gentoo-mordor.giritli.eu-x86_64-AMD_Phenom-tm-_II_X6_1090T_Processor-with-gentoo-2.2
KiB Mem:     8167260 total,   2179096 free
KiB Swap:    9767484 total,   9767484 free
Timestamp of tree: Sun, 09 Mar 2014 21:30:01 +0000
ld GNU ld (GNU Binutils) 2.23.2
distcc 3.1 x86_64-pc-linux-gnu [disabled]
ccache version 3.1.9 [disabled]
app-shells/bash:          4.2_p45
dev-java/java-config:     2.2.0
dev-lang/python:          2.7.5-r3, 3.3.3
dev-util/ccache:          3.1.9-r3
dev-util/cmake:           2.8.11.2
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.12.4
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6, 1.13.4
sys-devel/binutils:       2.23.2
sys-devel/gcc:            4.6.3, 4.7.3-r1
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.9 (virtual/os-headers)
sys-libs/glibc:           2.17
Repositories: gentoo Mehmet-s-Repo
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA dlj-1.1 googleearth AdobeFlash-10 AdobeFlash-10.1 AdobeFlash-10.3 Oracle-BCLA-JavaSE google-talkplugin skype-4.0.0.7-copyright Google-TOS AdobeFlash-11.x MakeMKV-EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=amdfam10"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -pipe -march=amdfam10"
DISTDIR="/mnt/media/Documents/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_GB.UTF-8"
LC_ALL="en_GB.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j8"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
USE="3dnow 3dnowext 64bit X a52 aac acl acpi alsa amd64 apng applet aspell bash-completion beagle berkdb bluetooth bluray branding brasero bzip2 cairo ccache cdda cddb cdr cdrom cdrtools cli colord cpufreq cracklib crypt css cups cxx dbus dconf deskbar device-mapper dga disk-partition dri dtmf dts dvd dvdnav dvdr dvi dvipdfm eds emboss encode exif extra faac faad fam fbcon fbcondecor ffmpeg firefox flac g3dvl galago gcj gdbm gdu geoclue gif gnome gnome-keyring gnome-online-accounts gnutls gpm gps graphics grilo gstreamer gtk gtk3 h323 hddtemp html iconv imap inotify introspection jabber java java6 javascript jingle jpeg jpeg2k kms kpathsea laptop lcms libmpeg2 libnotify libsamplerate libsecret mad mmx mmxext mng modules mp3 mp4 mpeg multilib musicbrainz nautilus ncurses networkmanager nls nptl nsplugin offensive ogg opengl openmp pam pango pcre pdf png policykit ppds pstricks pulseaudio python qt3support qt4 readline rtmp samba science sdl sendto session smp sms socialweb speex spell sqlite sse sse2 sse4a ssl startup-notification svg systemd tcpd theora threads tiff totem tracker transcode truetype udev udisks unicode upnp upnp-av upower usb v4l v4l2 vdpau vim-syntax vorbis wav wavpack wmf wps wxwidgets x264 xcb xml xv xvid zeitgeist zemberek zeroconf zip zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="tr en en_GB en_US" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" RUBY_TARGETS="ruby19 ruby18" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, SYNC, USE_PYTHON
Comment 1 Pacho Ramos gentoo-dev 2014-03-15 09:58:42 UTC
Can you try removing this line:
SystemdService=dbus-org.bluez.obex.service

from /usr/share/dbus-1/services/org.bluez.obex.service ?

(I would then reboot to ensure bluez and dbus stuff is fully reloaded)
Comment 2 Mehmet Giritli 2014-03-16 18:03:17 UTC
Sorry Pacho, it did not make any difference.
Comment 3 Pacho Ramos gentoo-dev 2014-03-16 22:59:12 UTC
Do you suffer the same with 5.16?
Comment 4 Mehmet Giritli 2014-03-20 08:44:26 UTC
(In reply to Pacho Ramos from comment #3)
> Do you suffer the same with 5.16?

Yep, just upgraded and tested after a reboot.
Comment 5 Pacho Ramos gentoo-dev 2014-03-20 21:19:28 UTC
It still works for me :/, how do you try to send your files? (I use the gnome 3.10 dialog for that)
Comment 6 Mehmet Giritli 2014-03-21 08:49:30 UTC
(In reply to Pacho Ramos from comment #5)
> It still works for me :/, how do you try to send your files? (I use the
> gnome 3.10 dialog for that)

Pacho, I do not have a problem sending files from my computer to my phone, rather the other way around. I can not send files from my phone to my computer.
Comment 7 Martin Heusel 2014-03-21 17:22:33 UTC
same here trying to send files from phone to laptop

enabling the bt device gives:

Mar 21 18:21:19 tp bluetoothd[13558]: Sap driver initialization failed.
Mar 21 18:21:19 tp bluetoothd[13558]: sap-server: Operation not permitted (1)

dunno if it's related
Comment 8 Pacho Ramos gentoo-dev 2014-03-22 08:45:00 UTC
Umm, I see

But I only get this error:
mar 22 09:42:37 belkin5 obexd[733]: Unable to find service record


Not sure how to get better errors,
Comment 9 Pacho Ramos gentoo-dev 2014-03-22 08:49:51 UTC
OK, I see the same:
$ /usr/libexec/bluetooth/obexd -n
obexd[1944]: OBEX daemon 5.16
obexd[1944]: CONNECT(0x0), (null)(0xffffffff)
obexd[1944]: CONNECT(0x0), (null)(0x0)
obexd[1944]: PUT(0x2), (null)(0xffffffff)
obexd[1944]: PUT(0x2), FORBIDDEN(0x43)
obexd[1944]: DISCONNECT(0x1), (null)(0xffffffff)
obexd[1944]: DISCONNECT(0x1), SUCCESS(0x20)
obexd[1944]: disconnected: Transport got disconnected
Comment 10 Martin Heusel 2014-03-22 09:28:05 UTC
have the same output with obexd -n

it's a permission problem?

bluetoothd[13558]: sap-server: Operation not permitted (1)

obexd[1944]: PUT(0x2), FORBIDDEN(0x43)
Comment 11 Pacho Ramos gentoo-dev 2014-03-22 11:54:49 UTC
Works manually starting gnome-user-share to allow it control permissions, but we need to manually start it because autostart file was dropped due:
http://git.overlays.gentoo.org/gitweb/?p=proj/gnome.git;a=commit;h=105f4022c7da637250c8b2d705be7741d0484a0b
Comment 12 Pacho Ramos gentoo-dev 2014-03-22 11:57:28 UTC
Maybe got fixed by this:
https://git.gnome.org/browse/gnome-user-share/commit/?id=c92a090d7c42114433040c6b6053f00506743f3d

That should come up with 3.10.2
Comment 13 Martin Heusel 2014-03-22 12:00:59 UTC
i don't use gnome(?)
Comment 14 Pacho Ramos gentoo-dev 2014-03-22 12:09:22 UTC
But you need to use something in computer side as a server to control authentication, permissions... I only know gnome-user-share for that :/
Comment 15 Martin Heusel 2014-03-22 12:36:57 UTC
i use kde control center

the phone is paired and trusted, i removed the phone and paired again but still no file transfer possible. It worked always like this.
Comment 16 Martin Heusel 2014-03-22 12:51:09 UTC
in the bluetooth configuring gui the checkbox to receive files is set, it is set to receive from "trusted devices" but it didn't work for receiving from "all devices" too. i did not make any changes there before it stopped receiving.
Comment 17 Pacho Ramos gentoo-dev 2014-03-22 23:31:39 UTC
Will CC kde team as I don't know what kde app takes care of this authentication handling (as gnome-user-share does on Gnome)
Comment 18 Michael Palimaka (kensington) gentoo-dev 2014-03-23 14:07:03 UTC
It's probably net-wireless/bluedevil (if so, which version?)
Comment 19 Pacho Ramos gentoo-dev 2014-03-30 08:12:50 UTC
If it's bluedevil it should be 2.0_rc1 version and reporter should ensure it's running
Comment 20 Mehmet Giritli 2014-03-30 08:26:47 UTC
(In reply to Pacho Ramos from comment #19)
> If it's bluedevil it should be 2.0_rc1 version and reporter should ensure
> it's running

I dont have KDE or bluedevil running on my computer.
Comment 21 Martin Heusel 2014-03-30 08:33:19 UTC
I have KDE and bluetooth 2.0_rc1 is running

Installed versions:  2.0_rc1(4)(14:27:19 03/23/14)

I re-installed it with other bluetooth librarires, udev etc. to be sure everything is linked up to date
Comment 22 Pacho Ramos gentoo-dev 2014-03-30 08:35:39 UTC
(In reply to Mehmet Giritli from comment #20)
> (In reply to Pacho Ramos from comment #19)
> > If it's bluedevil it should be 2.0_rc1 version and reporter should ensure
> > it's running
> 
> I dont have KDE or bluedevil running on my computer.

You will need to google then to try to know what kind of tool is used for that authentication purpose, upstream explained me that you need one of them to work and, indeed, it works:
http://marc.info/?l=linux-bluetooth&m=139548745516645&w=4
Comment 23 Martin Heusel 2014-03-30 08:39:44 UTC
Here is bluez 5.15 running
Comment 24 Mehmet Giritli 2014-03-30 10:10:54 UTC
(In reply to Pacho Ramos from comment #22)
> (In reply to Mehmet Giritli from comment #20)
> > (In reply to Pacho Ramos from comment #19)
> > > If it's bluedevil it should be 2.0_rc1 version and reporter should ensure
> > > it's running
> > 
> > I dont have KDE or bluedevil running on my computer.
> 
> You will need to google then to try to know what kind of tool is used for
> that authentication purpose, upstream explained me that you need one of them
> to work and, indeed, it works:
> http://marc.info/?l=linux-bluetooth&m=139548745516645&w=4

Do you mean that bluez is not doing that? I have bluez as I mentioned in the original report. Actually this is pretty standard gnome installation. So if this thing is not working with the standard gnome installation, I think you have to adjust deps in the ebuilds as well.
Comment 25 Pacho Ramos gentoo-dev 2014-03-30 10:21:46 UTC
It works when gnome-user-share is installed, and we are considering to pull it from extras meta -> bug 506176
Comment 26 Mehmet Giritli 2014-03-30 10:28:25 UTC
(In reply to Pacho Ramos from comment #25)
> It works when gnome-user-share is installed, and we are considering to pull
> it from extras meta -> bug 506176

No, I have it installed since the beginning. So it still doesnt work for me when gnome-user-share is installed.

emerge -pv gnome-user-share

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] gnome-extra/gnome-user-share-3.10.1  USE="bluetooth" 0 kB
Comment 27 Pacho Ramos gentoo-dev 2014-03-30 10:37:44 UTC
That is because it wasn't autostarted, you can either start it manually of bump to 3.10.2 (that fixes that issue)
Comment 28 Mehmet Giritli 2014-03-30 10:46:54 UTC
(In reply to Pacho Ramos from comment #27)
> That is because it wasn't autostarted, you can either start it manually of
> bump to 3.10.2 (that fixes that issue)

Oh, now I see. Thank you for the info. I'll try it later after upgrading g-u-s.
Comment 29 Johannes Huber gentoo-dev 2014-04-07 18:35:23 UTC
*** Bug 506920 has been marked as a duplicate of this bug. ***
Comment 30 Johannes Huber gentoo-dev 2014-04-07 18:36:30 UTC
Can somebody please test newer net-wireless/bluez?
Comment 31 Martin Heusel 2014-04-07 18:42:49 UTC
still not working with bluez-5.17
Comment 32 Mehmet Giritli 2014-04-08 19:39:44 UTC
(In reply to Pacho Ramos from comment #27)
> That is because it wasn't autostarted, you can either start it manually of
> bump to 3.10.2 (that fixes that issue)

Thanks, I can confirm that it works with gnome-user-share 3.10.2.
Comment 33 Johannes Huber gentoo-dev 2014-05-02 09:42:58 UTC
Remove kde from here we proceed in bug 509358
Comment 34 Jacek 2014-05-19 08:14:48 UTC
Hi,

Yesterday I made some tests bluez5, gnome-user-share 3.10.2, file transfer etc.
Phone: android device (MIUIv5)
PC: gentoo, gnome3.10, tested kernels 3.12.20, 3.13.11, 3.14.4. x230, Broadcom Corp. BCM20702 Bluetooth 4.0

Results below:
1. bluez 5.15 out of the box
after pairing pbap accept
sending from gnome works
receive works
a2dp works
libreoffice presentation works

2. bluez 5.18
after pairing pbap accept or forbid
sending from gnome works
receive doesn't work
a2dp works
libreoffice presentation not tested

3. bluez from git
after pairing pbap accept or forbid
sending gnome works
receive doesn't work
a2dp not tested (probably works)
libreoffice presentation not tested

for 2 and 3 I found that after accepting or forbid PBAP service obexd crash (segmentation fault).  I used -d -n parameter and strace and there is no interestnig logs.

Workarounds: 
First) sending a file from pc to phone at first (strange). This starts obexd service.

Second workaround): using gnome-session-properties create statup program with script aaa.sh that contain:
sleep 7 && dbus-send --session --dest="org.bluez.obex" /org/bluez/obex "org.bluez.obex". 
This is starts obexd after first crash but after restarting gnome-shell it doesn't work.

Third) remove paired phone on both side and pair them again. After request PABP don't accept or forbid. Only press 'back' button. After every gnome-shell restarts or startup session phone device shows request PABP access - don't accept or refuse just press back button as above.

It shows that there is PABP problem in bluez 5.17, 5.18 and git version. 
In few days I'll do phone upgrade and try again.

thanks for reading :) Maybe its usefull.
jd
Comment 35 Pacho Ramos gentoo-dev 2014-07-22 19:55:23 UTC
Please retry with:
+*bluez-5.21-r1 (22 Jul 2014)
+
+  22 Jul 2014; Pacho Ramos <pacho@gentoo.org> +bluez-5.21-r1.ebuild,
+  -bluez-5.21.ebuild:
+  dbus file wasn't being installed with USE -systemd due missing eautoreconf
+  (#517818 by Uros)
+
Comment 36 Martin Heusel 2014-07-24 04:37:05 UTC
works with bluez-5.21-r1 & KDE 4.12.5. Thanks!
Comment 37 Martin Heusel 2014-07-25 04:45:55 UTC
Unfortunately stopped working after the laptop is coming back from Suspend-To-Ram mode. I have to log out and log in in KDE again to make it work again. udev restart doesn't help.
Comment 38 Pacho Ramos gentoo-dev 2014-07-25 08:14:40 UTC
(In reply to Martin Heusel from comment #37)
> Unfortunately stopped working after the laptop is coming back from
> Suspend-To-Ram mode. I have to log out and log in in KDE again to make it
> work again. udev restart doesn't help.

I would open a new bug for that, testing with latest kernel as that could be a different issue (more related with some module failing to be reloaded when resuming from suspend). dmesg output before and after suspending could be useful