Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 504372 - sci-mathematics/geomview-1.9.5 version bump
Summary: sci-mathematics/geomview-1.9.5 version bump
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Science Mathematics related packages
Depends on:
Reported: 2014-03-13 00:05 UTC by Claus-Justus Heine
Modified: 2020-10-03 20:48 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---

Ebuild Overlay with Geomview v1.9.5 and a collection of emodules (geomview-ebuilds.tar.xz,8.70 KB, application/x-tgz)
2014-03-13 11:32 UTC, Claus-Justus Heine

Note You need to log in before you can comment on or make changes to this bug.
Description Claus-Justus Heine 2014-03-13 00:05:16 UTC
My apologies. I have now spent 30 Minutes to figure how to get in contact with the relevant Gentoo Guy.

Me: I am the current upstream maintainer, at least one of those.

Please contact me for the new maintenance release, which is already online at SF.

Comment 1 Claus-Justus Heine 2014-03-13 00:46:10 UTC
Maybe some further comments which might shine a little more light on this not-a-bug-report:

- Ages ago, around 2007/2008, I have contributed the last "vital" changes to Geomview, adding true lambda expressions and defun's to its lisp interprete + some minor changes.

- The current "bug" report simply serves as a trigger to please lable the current state (stable for several years, but without official release-number) as a new release.

I'm very willing to help, if stuff should not work as expected.

- Intentionally, most of the add-on modules (emodules, in GV tongue) should work also with recent TCL/TK, which is probably the most important change: make it compile and work a.D. 2014.

- I could help out with ebuild defs. Where somehow I just realized that it seems that I have deleted all my private ebuilds related to Geomview. If I remember right this was out of frustration towards Tcl/Tk changes. However, it would be nice to not only have the Geomview core-renderer available, but also the most important add-ons. It's all standard autoconf stuff, I could very easily provide add-on ebuilds (crayola, ndview (most wanted by me), the bunch of xforms modules). Of course, I alway had my own non-ebuild builds. After all, this is simple GNU autoconf stuff.

In principle stuff should work out of the box. Mmmh.


Comment 2 Alex Xu (Hello71) 2014-03-13 01:15:23 UTC
If you could, please test ebuilds in your local overlay: and state exactly what needs to be done or the options available for maintainers.

sci-* herds are generally extremely busy and do not have sufficient time as it is.
Comment 3 Claus-Justus Heine 2014-03-13 11:32:41 UTC
Created attachment 372550 [details]
Ebuild Overlay with Geomview v1.9.5 and a collection of emodules

works-for-me state

The tar-ball contains an overlay with ebuilds for geomview and all add-on modules (emoduls in Geomview tongue) which can be found on SF.
Comment 4 Andrey Grozin gentoo-dev 2014-03-13 16:21:34 UTC
I can commit these ebuilds to the main tree (after some looking at them). In the past I used geomview a little (I and my student have written a rather minimal interface fricas -> geomview, to use geomview as a 3D graphics viewer from fricas). At the moment I see that the geomview ebuild seems OK: compiles and works (on simple examples). Have not looked at the other ebuilds.
Comment 5 Claus-Justus Heine 2014-03-13 16:55:36 UTC
(In reply to Andrey Grozin from comment #4)
> viewer from fricas). At the moment I see that the geomview ebuild seems OK:
> compiles and works (on simple examples). Have not looked at the other
> ebuilds.

Yes, that was to be hoped. I simply took the existing v1.9.4 ebuild which worked out of the box as the build systems of GV 1.9.5 is still the same as it was in 1.9.4.

The other ebuild are wrapped around the various add-on modules. I have changed the Geomview Tcl-Addons slightly s.t. they should work (also) with recent Tcl/Tk versions (Tcl_Interpreter structure has been made opaque, since 8.6, I think)
Comment 6 Andrey Grozin gentoo-dev 2014-03-25 05:57:23 UTC
OK, I've committed geomview-1.9.5 to the tree. The ebuild was ancient, EAPI=1, I had to change many things (xpdf does not exist in the tree, etc.).
I'll have a look at the emodule ebuilds.
What are gvemodules-xforms and gvemod-xforms-example? Do they require x11-libs/xforms? Are they related to each other?