Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 504128 - app-admin/perl-cleaner: perl-cleaner should source functions.sh from /lib/gentoo/functions.sh
Summary: app-admin/perl-cleaner: perl-cleaner should source functions.sh from /lib/gen...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Perl team
URL:
Whiteboard:
Keywords:
: 499326 (view as bug list)
Depends on:
Blocks: init.d_functions.sh perl-cleaner-2.14
  Show dependency tree
 
Reported: 2014-03-10 20:44 UTC by Kirill Elagin
Modified: 2014-06-09 19:46 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
perl-cleaner-2.12-dont_source_functions_sh_from_etc_initd.patch (perl-cleaner-2.12-dont_source_functions_sh_from_etc_initd.patch,351 bytes, patch)
2014-03-19 13:56 UTC, Lars Wendler (Polynomial-C) (RETIRED)
Details | Diff
Possible fix (perl-cleaner-2.12-dont_source_functions_sh_from_etc_initd-r1.patch,776 bytes, patch)
2014-06-06 21:07 UTC, Thomas Deutschmann
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Kirill Elagin 2014-03-10 20:44:18 UTC
See bug 504116.
Comment 1 Lars Wendler (Polynomial-C) (RETIRED) gentoo-dev 2014-03-19 13:56:59 UTC
Created attachment 373028 [details, diff]
perl-cleaner-2.12-dont_source_functions_sh_from_etc_initd.patch

Possible fix...
Comment 2 Walter Meinl 2014-03-22 09:14:20 UTC
(In reply to Lars Wendler (Polynomial-C) from comment #1)
> Created attachment 373028 [details, diff] [details, diff]
> perl-cleaner-2.12-dont_source_functions_sh_from_etc_initd.patch
> 
> Possible fix...

Used this fix to update perl modules and depending libraries after installing gentoo-functions and perl-5.18.2. This fix worked like a charme...
Comment 3 Andreas K. Hüttel archtester gentoo-dev 2014-06-06 20:34:10 UTC
*** Bug 499326 has been marked as a duplicate of this bug. ***
Comment 4 Andreas K. Hüttel archtester gentoo-dev 2014-06-06 20:43:18 UTC
(In reply to Lars Wendler (Polynomial-C) from comment #1)
> Created attachment 373028 [details, diff] [details, diff]
> perl-cleaner-2.12-dont_source_functions_sh_from_etc_initd.patch
> 
> Possible fix...

Not really since this breaks old installations (with functions.sh at old location).
Comment 5 Thomas Deutschmann gentoo-dev 2014-06-06 20:47:34 UTC
When app-admin/perl-cleaner depends on sys-apps/gentoo-functions, how should it break old installations?
Comment 6 Andreas K. Hüttel archtester gentoo-dev 2014-06-06 21:00:00 UTC
(In reply to Thomas D. from comment #5)
> When app-admin/perl-cleaner depends on sys-apps/gentoo-functions, how should
> it break old installations?

Please read the explanation in bug 504116
Comment 7 Thomas Deutschmann gentoo-dev 2014-06-06 21:07:39 UTC
Created attachment 378394 [details, diff]
Possible fix

revdep-rebuild is using the same code.
Comment 8 Andreas K. Hüttel archtester gentoo-dev 2014-06-09 19:46:53 UTC
Fixed in perl-cleaner-2.14