Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 504044 - xfce-base/xfce4-session: add systemd/login1 hibernate/suspend support
Summary: xfce-base/xfce4-session: add systemd/login1 hibernate/suspend support
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: XFCE Team
URL: https://bugzilla.xfce.org/show_bug.cg...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-03-10 07:19 UTC by pelopor
Modified: 2014-06-16 10:15 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
diff -buw xfce4-session-4.10.1-r1.ebuild xfce4-session-4.10.1-r2.ebuild (xfce4-session.ebuild.diff,822 bytes, patch)
2014-03-10 07:20 UTC, pelopor
Details | Diff
patch to the xfce4-session sources (xfce4-session-4.10.1-logind-support-for-suspend-hibernate.patch,8.74 KB, patch)
2014-03-10 07:21 UTC, pelopor
Details | Diff
patch to the xfce4-session sources to add systemd support for hibernate/suspend (xfce4-session-4.10.1-systemd-support-for-suspend-hibernate.patch,11.81 KB, patch)
2014-03-11 12:08 UTC, pelopor
Details | Diff
diff -buw xfce4-session-4.10.1-r1.ebuild xfce4-session-4.10.1-r2.ebuild (xfce4-session.ebuild.diff,645 bytes, text/csv)
2014-03-11 12:09 UTC, pelopor
Details
systemd patch for 11.0 version (xfce4-session-4.11.0-systemd.patch,9.65 KB, patch)
2014-06-09 09:26 UTC, David Carlos Manuelda
Details | Diff
patch for ebuild 11.0-r1 (xfce4-session-4.11.0-r1.ebuild.patch,444 bytes, patch)
2014-06-09 09:28 UTC, David Carlos Manuelda
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description pelopor 2014-03-10 07:19:31 UTC
Add a patch to add hibernate and suspend support, from ArchLinux's PKGBUILD.
https://www.archlinux.org/packages/extra/i686/xfce4-session/


Reproducible: Always



Expected Results:  
Hibernate/suspend can executed through xfce4-session's menu.
Comment 1 pelopor 2014-03-10 07:20:22 UTC
Created attachment 372252 [details, diff]
diff -buw xfce4-session-4.10.1-r1.ebuild xfce4-session-4.10.1-r2.ebuild
Comment 2 pelopor 2014-03-10 07:21:32 UTC
Created attachment 372254 [details, diff]
patch to the xfce4-session sources

Taken from Archlinux.
Comment 3 Samuli Suominen gentoo-dev 2014-03-10 09:18:12 UTC
Comment on attachment 372252 [details, diff]
diff -buw xfce4-session-4.10.1-r1.ebuild xfce4-session-4.10.1-r2.ebuild

Same problem as with bug 504046, should not use 'if use systemd' for patching, but fix configure.ac (or .ac.in?) and set EAUTORECONF=1 to trigger eautoreconf by xfconf.eclass
To handle it from $(use_enable systemd)
Comment 4 Samuli Suominen gentoo-dev 2014-03-10 09:21:33 UTC
Needs a bug filed to http://bugzilla.xfce.org/ for review, I don't think it is this https://bugzilla.xfce.org/show_bug.cgi?id=10076 which is the only one I could find because it's already bug 469204
Comment 5 Samuli Suominen gentoo-dev 2014-03-10 09:23:47 UTC
(In reply to pelopor from comment #2)
> Created attachment 372254 [details, diff] [details, diff]
> patch to the xfce4-session sources
> 
> Taken from Archlinux.

This patch looks good if I read it correctly, it just puts things behind already existing #ifdef SYSTEMD and $(use_enable systemd)
So only upstream bug report missing, and this could be applied in tree
Comment 6 pelopor 2014-03-11 12:06:19 UTC
Samuli, thankyou for your review and comment.
I added the upstream bug report: https://bugzilla.xfce.org/show_bug.cgi?id=9952.
And it turns out there is a newer patch, which applies to git. I modified that patch so as to applies v.4.10.1 source trees, i.e. so that the patch to configure.ac.in (git) apply configure.ac (v.4.10.1). As it involves configure.ac, I add "EAUTORECONF=1" to the ebuild, as well as delete "if use" in the $PATCHES.
Comment 7 pelopor 2014-03-11 12:08:24 UTC
Created attachment 372368 [details, diff]
patch to the xfce4-session sources to add systemd support for hibernate/suspend

Patch taken from https://bugzilla.xfce.org/show_bug.cgi?id=9952, but a bit modified.
Comment 8 pelopor 2014-03-11 12:09:15 UTC
Created attachment 372370 [details]
diff -buw xfce4-session-4.10.1-r1.ebuild xfce4-session-4.10.1-r2.ebuild
Comment 9 Samuli Suominen gentoo-dev 2014-05-31 19:44:05 UTC
this is fixed by using upower-0.99 in xfce4-session-4.11+ which is now in ~arch
Comment 10 David Carlos Manuelda 2014-06-09 09:26:34 UTC
(In reply to Samuli Suominen from comment #9)
> this is fixed by using upower-0.99 in xfce4-session-4.11+ which is now in
> ~arch

Nope, I am using complete ~amd64 system (that includes xfce4-session-4.11.0-r1) and upower-0.99.0-r1 and with systemd, and I don't simply have the buttons suspend/hibernate.

DIgging on the internet, I found it is because I don't have pm-utils installed, but with systemd I just don't want them.

So I tried the patch for previous version, and it did not apply cleanly, so I applied by hand and created a new one for 4.11 which enables systemd suspend/hibernate back again.

I tested, compiled and run it, and it just works (don't know if it may affect non systemd users), I will attach the patch and ebuild diff to review.

Can someone reopen this bug BTW?

P.S. I also noticed that the patch for 10.1 is not included in 11.0 version
Comment 11 David Carlos Manuelda 2014-06-09 09:26:59 UTC
Created attachment 378566 [details, diff]
systemd patch for 11.0 version
Comment 12 David Carlos Manuelda 2014-06-09 09:28:10 UTC
Created attachment 378568 [details, diff]
patch for ebuild 11.0-r1
Comment 13 David Carlos Manuelda 2014-06-09 09:34:37 UTC
mmm... seems I disabled udisk USE in xfce4-power-manager, but still, it should work with systemd only (and that is the purpose of that patch)
Comment 14 David Carlos Manuelda 2014-06-09 09:35:24 UTC
Disregard previous comment: udisks is not related to upower (my fault)
Comment 15 Andreas Grois 2014-06-13 14:23:01 UTC
I can confirm, that this bug is not fixed yet. I'm runnnig upower-0.99.0-r1 and xfce4-sesssion-4.11.0-r1.
Comment 16 Pacho Ramos gentoo-dev 2014-06-16 10:15:29 UTC
I don't fully understand: I guess that you are seeing that the patch currently applied in latest 4.10* is also needed in 4.11?