Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 502256 - app-accessibility/caribou-0.4.13 - ImportError: /usr/lib/libgirepository-1.0.so.1: undefined symbol: g_type_class_adjust_private_offset
Summary: app-accessibility/caribou-0.4.13 - ImportError: /usr/lib/libgirepository-1.0....
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: IA64 Linux
: Normal normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
: 502258 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-02-23 15:39 UTC by Émeric Maschino
Modified: 2014-02-25 21:32 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,16.21 KB, text/plain)
2014-02-23 15:42 UTC, Émeric Maschino
Details
environment (environment,149.34 KB, text/plain)
2014-02-23 15:43 UTC, Émeric Maschino
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Émeric Maschino 2014-02-23 15:39:27 UTC
emerge @world wanted to reinstall caribou-0.4.13 that fails at compile phase:

sed -e "s|[@]libexecdir[@]|/usr/libexec|" /var/tmp/portage/app-accessibility/car
ibou-0.4.13/work/caribou-0.4.13/data/org.gnome.Caribou.Antler.service.in > org.g
nome.Caribou.Antler.service
/usr/bin/python2.7 -B /var/tmp/portage/app-accessibility/caribou-0.4.13/work/car
ibou-0.4.13/tools/make_schema.py \
	-d "caribou" \
	-o org.gnome.caribou.gschema.xml.in caribou.settings.CaribouSettings
/usr/bin/python2.7 -B /var/tmp/portage/app-accessibility/caribou-0.4.13/work/car
ibou-0.4.13/tools/make_schema.py \
	-d "caribou" \
	-o org.gnome.antler.gschema.xml.in caribou.antler.AntlerSettings
Traceback (most recent call last):
  File "/var/tmp/portage/app-accessibility/caribou-0.4.13/work/caribou-0.4.13/to
ols/make_schema.py", line 3, in <module>
    from gi.repository import GLib
  File "/usr/lib/python2.7/site-packages/gi/__init__.py", line 27, in <module>
    from ._gi import _API, Repository
ImportError: /usr/lib/libgirepository-1.0.so.1: undefined symbol: g_type_class_a
djust_private_offset
make[2]: *** [org.gnome.antler.gschema.xml.in] Error 1
make[2]: *** Waiting for unfinished jobs....
Traceback (most recent call last):
  File "/var/tmp/portage/app-accessibility/caribou-0.4.13/work/caribou-0.4.13/tools/make_schema.py", line 3, in <module>
    from gi.repository import GLib
  File "/usr/lib/python2.7/site-packages/gi/__init__.py", line 27, in <module>
    from ._gi import _API, Repository
ImportError: /usr/lib/libgirepository-1.0.so.1: undefined symbol: g_type_class_a
djust_private_offset
make[2]: *** [org.gnome.caribou.gschema.xml.in] Error 1
Generating and caching the translation database
Merging translations into caribou-autostart.desktop.
make[2]: Leaving directory `/var/tmp/portage/app-accessibility/caribou-0.4.13/wo
rk/caribou-0.4.13-python2_7/data'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/app-accessibility/caribou-0.4.13/wo
rk/caribou-0.4.13-python2_7/data'
make: *** [all-recursive] Error 1

     Émeric
Comment 1 Émeric Maschino 2014-02-23 15:40:50 UTC
emerge --info

Portage 2.2.7 (default/linux/ia64/13.0/desktop/gnome/systemd, gcc-4.6.3, glibc-2.17, 3.10.25-gentoo ia64)
=================================================================
System uname: Linux-3.10.25-gentoo-ia64-Madison-with-gentoo-2.2
KiB Mem:    24987056 total,  20144096 free
KiB Swap:     524272 total,    524272 free
Timestamp of tree: Sun, 23 Feb 2014 14:00:01 +0000
ld GNU ld (GNU Binutils) 2.23.2
app-shells/bash:          4.2_p45
dev-java/java-config:     2.1.12-r1
dev-lang/python:          2.7.5-r3, 3.3.2-r2
dev-util/cmake:           2.8.11.2
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.12.4
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6, 1.13.4
sys-devel/binutils:       2.23.2
sys-devel/gcc:            4.6.3, 4.7.3-r1
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.9 (virtual/os-headers)
sys-libs/glibc:           2.17
Repositories: gentoo my_ebuilds
ACCEPT_KEYWORDS="ia64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="ia64-unknown-linux-gnu"
CFLAGS="-O1 -pipe"
CHOST="ia64-unknown-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O1 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="ftp://mirrors.linuxant.fr/distfiles.gentoo.org/"
LANG="fr_FR.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/my_ebuilds"
USE="X a52 aac acl acpi alsa berkdb branding bzip2 cairo cdda cdr cli colord cracklib crypt cups cxx dbus dri dts dvdr eds encode evo exif fam firefox flac fortran gdbm gif gnome gnome-keyring gnome-online-accounts gpm gstreamer gtk ia64 iconv introspection ipv6 jpeg lcms ldap libnotify libsecret mad mng modules mp3 mp4 mpeg nautilus ncurses nls nptl ogg opengl openmp pam pango pcre pdf png policykit ppds pulseaudio qt3support qt4 readline sdl session socialweb spell ssl startup-notification svg systemd tcpd tiff truetype udev udisks unicode upower usb vorbis wxwidgets xcb xml xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="fr" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" RUBY_TARGETS="ruby19 ruby18" USERLAND="GNU" VIDEO_CARDS="radeon" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, SYNC, USE_PYTHON
Comment 2 Émeric Maschino 2014-02-23 15:41:36 UTC
emerge -pqv

[ebuild   R   ] app-accessibility/caribou-0.4.13  PYTHON_TARGETS="python2_7 (-python2_6%)"
Comment 3 Émeric Maschino 2014-02-23 15:42:24 UTC
Created attachment 371126 [details]
build.log
Comment 4 Émeric Maschino 2014-02-23 15:43:08 UTC
Created attachment 371128 [details]
environment
Comment 5 Jeroen Roovers gentoo-dev 2014-02-24 01:10:40 UTC
Looks like the same problem as bug #502258 - an upgraded dev-libs/glib with the rest of the packages at the old version
Comment 6 Jeroen Roovers gentoo-dev 2014-02-24 01:10:57 UTC
*** Bug 502258 has been marked as a duplicate of this bug. ***
Comment 7 Émeric Maschino 2014-02-25 21:32:41 UTC
(In reply to Jeroen Roovers from comment #5)
> Looks like the same problem as bug #502258 - an upgraded dev-libs/glib with
> the rest of the packages at the old version

You're absolutely right, though I don't remember having to downgrade glib. But I'm now with glib-2.38, several other packages have been rebuilt successfully and caribou-0.4.13 now emerges flawlessly.

Thanks,

     Émeric