Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 501534 - sys-apps/install-xattr: needs to be keyworded for all arches that portage is keyworded for
Summary: sys-apps/install-xattr: needs to be keyworded for all arches that portage is ...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Keywording and Stabilization (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Anthony Basile
URL:
Whiteboard:
Keywords: KEYWORDREQ
Depends on: 502076 514936
Blocks: 515620
  Show dependency tree
 
Reported: 2014-02-16 23:51 UTC by Anthony Basile
Modified: 2014-10-13 09:38 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Anthony Basile gentoo-dev 2014-02-16 23:51:35 UTC
In order for portage to depend on install-xattr (see bug #465000), we need to mirror the keywordking:

KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"

I've already done amd64 and x86.  I can do mips arm ppc and ppc64, but I'll need arch teams to look at the following:

TARGET_ARCHES="~alpha ~arm64 ~hppa ~ia64 ~m68k ~s390 ~sh ~sparc ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"

Reproducible: Always
Comment 1 Anthony Basile gentoo-dev 2014-02-17 18:26:36 UTC
I just tested/keyworded for ~arm ~mips ~ppc ~ppc64
Comment 2 Agostino Sarubbo gentoo-dev 2014-02-22 07:17:58 UTC
alpha done
Comment 3 Agostino Sarubbo gentoo-dev 2014-02-22 07:18:08 UTC
ia64 done
Comment 4 Agostino Sarubbo gentoo-dev 2014-02-22 07:18:18 UTC
sparc done
Comment 5 Agostino Sarubbo gentoo-dev 2014-02-22 07:18:29 UTC
x86 done
Comment 6 Jeroen Roovers (RETIRED) gentoo-dev 2014-02-22 15:42:08 UTC
Marked ~hppa.
Comment 7 Anthony Basile gentoo-dev 2014-05-31 20:47:32 UTC
Ping remaining arches for keywords.

Since these are unstable arches, I'm going to start a stabilization request for the stable arches.  It has been in the tree a while now.
Comment 8 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2014-05-31 21:06:12 UTC
~s390 done.
Comment 9 Naohiro Aota gentoo-dev 2014-06-16 23:42:46 UTC
Since xattr is not provied on FreeBSD (instead it provide similar feature: extattr), it'll need some work to support this package on FreeBSD.
Comment 10 Anthony Basile gentoo-dev 2014-06-17 18:04:48 UTC
(In reply to Naohiro Aota from comment #9)
> Since xattr is not provied on FreeBSD (instead it provide similar feature:
> extattr), it'll need some work to support this package on FreeBSD.

Well actually, pax markings make no sense on freebsd either because pax markings are only for a pax enabled linux kernel.  So the question is, how do we make portage depend on this package if USE=xattr on all but non-linux arches.

Since I'm not familiar *-fbsd, how should we do this?  Does USE=xattr make any sense there?
Comment 11 Naohiro Aota gentoo-dev 2014-06-23 03:27:44 UTC
(In reply to Anthony Basile from comment #10)
> (In reply to Naohiro Aota from comment #9)
> > Since xattr is not provied on FreeBSD (instead it provide similar feature:
> > extattr), it'll need some work to support this package on FreeBSD.
> 
> Well actually, pax markings make no sense on freebsd either because pax
> markings are only for a pax enabled linux kernel.  So the question is, how
> do we make portage depend on this package if USE=xattr on all but non-linux
> arches.
> 
> Since I'm not familiar *-fbsd, how should we do this?  Does USE=xattr make
> any sense there?

Well... we *can* use extattr in some way. However, we don't have any usage for it now and we won't even plan to implement one. So there's nothing to prevent use.mask'ing the USE flag for now.
Comment 12 Anthony Basile gentoo-dev 2014-06-23 09:44:50 UTC
(In reply to Naohiro Aota from comment #11)
> (In reply to Anthony Basile from comment #10)
> > (In reply to Naohiro Aota from comment #9)
> > > Since xattr is not provied on FreeBSD (instead it provide similar feature:
> > > extattr), it'll need some work to support this package on FreeBSD.
> > 
> > Well actually, pax markings make no sense on freebsd either because pax
> > markings are only for a pax enabled linux kernel.  So the question is, how
> > do we make portage depend on this package if USE=xattr on all but non-linux
> > arches.
> > 
> > Since I'm not familiar *-fbsd, how should we do this?  Does USE=xattr make
> > any sense there?
> 
> Well... we *can* use extattr in some way. However, we don't have any usage
> for it now and we won't even plan to implement one. So there's nothing to
> prevent use.mask'ing the USE flag for now.

That works.
Comment 13 Anthony Basile gentoo-dev 2014-06-28 19:19:14 UTC
I just realized we also need keywordking for arm64 and m86k.  cc-ing vapier who takes care of those.
Comment 14 Naohiro Aota gentoo-dev 2014-07-07 01:45:29 UTC
Masked USE=xattr on FreeBSD
Comment 15 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2014-10-12 18:50:34 UTC
~m68k/~arm64 done
Comment 16 Agostino Sarubbo gentoo-dev 2014-10-13 09:38:51 UTC
This is already ~sh. If you want it stable, please change the KEYWORDS field and cc sh again.