Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 50147 - gecko-sharp 0.2 failing on compile
Summary: gecko-sharp 0.2 failing on compile
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: dotnet (DISBANDED)
URL: http://forums.gentoo.org/viewtopic.ph...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-05-05 16:49 UTC by Jonathan Hernández Velasco
Modified: 2004-06-02 20:07 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Hernández Velasco 2004-05-05 16:49:32 UTC
See this thread:
http://forums.gentoo.org/viewtopic.php?t=169615

Reproducible: Always
Steps to Reproduce:
1. upgrade from gecko-sharp 0.1 to gecko-sharp 0.2
2.
3.

Actual Results:  
[...]
-o GtkMozApp.exe ./GtkMozApp.cs ./MozWindow.cs
 
** (/usr/lib/mono/1.0/mcs.exe:14253): WARNING **: Could not find assembly
glib-sharp, references from /usr/lib/gecko-sharp.dll (assemblyref_index=0)
     Major/Minor: 0,0
     Build:       0,0
     Token:       (null)
 
 
Unhandled Exception: System.NullReferenceException: A null value was found where
an object instance was required.
in (unmanaged) /usr/lib/libmono.so.0(mono_assembly_open+0xe2) [0x40102fa2]
in (unmanaged) /usr/lib/libmono.so.0 [0x40102406]
in (unmanaged) /usr/lib/libmono.so.0(mono_assembly_load+0x1ab) [0x4010374b]
in (unmanaged) /usr/lib/libmono.so.0 [0x400f3f70]
in <0x0006c> (wrapper remoting-invoke-with-check) System.AppDomain:LoadAssembly
(string,System.Security.Policy.Evidence)
in <0x0006b> System.AppDomain:Load (string)
in <0x00058> (wrapper remoting-invoke-with-check) System.AppDomain:Load (string)
in <0x0001d> System.Reflection.Assembly:Load (string)
in <0x0012d> Mono.CSharp.Driver:LoadAssembly (string,bool)
in <0x0009f> Mono.CSharp.Driver:LoadReferences ()
in <0x006ac> Mono.CSharp.Driver:MainDriver (string[])
in <0x0001a> Mono.CSharp.Driver:Main (string[])
 
make[1]: *** [GtkMozApp.exe] Error 1
make[1]: Leaving directory
`/mnt/data/tmp/portage/gecko-sharp-0.2/work/gecko-sharp-0.2/sample'
make: *** [all-recursive] Error 1
 
!!! ERROR: dev-dotnet/gecko-sharp-0.2 failed.
!!! Function src_compile, Line 23, Exitcode 2
!!! make failed


if unmerge gecko-sharp and then emerge the new version, the ebuild compiles
fine, without any error:

emerge -C gecko-sharp
ACCEPT_KEYWORDS="~x86" emerge gecko-sharp
Comment 1 Peter Johanson (RETIRED) gentoo-dev 2004-05-05 17:51:26 UTC
This is a problem as a result of the transition to using the GAC. i've added a warning to the end of the die message if gecko-sharp, informing people that if they are upgrading from 0.1 they may need to unmerge gecko-sharp first. Future upgrades should not require this step as the GAC will be around.
Comment 2 Dan Elder 2004-05-12 09:45:47 UTC
I had the same problem with gecko-sharp 0.3 but unmerging gecko-sharp solved the problem as well so it seems this bug still applies (with an easy workaround at least).
Comment 3 Peter Johanson (RETIRED) gentoo-dev 2004-05-12 09:55:08 UTC
Are people seeing the information i added about unmerging and merging to the ebuilds? If not, I can make some bigger ewarns with capital letters to catch people's attentions.

The other option is to disable the building of the samples, as this is the only spot where not having the GACed things because an issue. If you're listening todd, what do you think of that? (:
Comment 4 Jonathan Hernández Velasco 2004-06-02 18:25:52 UTC
can this bug be considered fixed? I think its sufficient with this warning.
Comment 5 Peter Johanson (RETIRED) gentoo-dev 2004-06-02 20:07:27 UTC
Yup. marking FIXED.