Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 500330 - media-libs/libquvi-0.4.1 with media-libs/libquvi-scripts-0.9.20131130 - configure: error: Package requirements (libquvi-scripts >= 0.4.0) were not met: No package 'libquvi-scripts' found
Summary: media-libs/libquvi-0.4.1 with media-libs/libquvi-scripts-0.9.20131130 - confi...
Status: VERIFIED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-02-05 03:14 UTC by Vladimir Miloserdov
Modified: 2014-03-30 17:59 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,8.74 KB, text/plain)
2014-02-05 03:15 UTC, Vladimir Miloserdov
Details
emerge -pqv output (empqv.log,72 bytes, text/plain)
2014-02-05 03:16 UTC, Vladimir Miloserdov
Details
config.log (config.log,35.38 KB, text/plain)
2014-02-05 16:58 UTC, Vladimir Miloserdov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir Miloserdov 2014-02-05 03:14:10 UTC
Can't merge libquvi-0.4.1 due to configuration failure: No package 'libquvi-scripts' found. I have libquvi-scripts-0.9.20131130 installed.

Portage 2.2.8-r1 (default/linux/amd64/13.0/desktop/kde, gcc-4.8.2, glibc-2.18-r1, 3.13.0-gentoo-r1 x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-3.13.0-gentoo-r1-x86_64-Intel-R-_Core-TM-_i7-3770K_CPU_@_3.50GHz-with-gentoo-2.2
KiB Mem:     8045748 total,   6900716 free
KiB Swap:   10485756 total,  10485756 free
Timestamp of tree: Tue, 04 Feb 2014 13:45:01 +0000
ld GNU ld (GNU Binutils) 2.24
app-shells/bash:          4.2_p45-r1
dev-lang/python:          2.7.6, 3.3.3
dev-util/cmake:           2.8.12.2
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.12.4
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.12.6, 1.13.4, 1.14.1
sys-devel/binutils:       2.24-r2
sys-devel/gcc:            4.7.3-r1, 4.8.2
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           4.0-r1
sys-kernel/linux-headers: 3.13 (virtual/os-headers)
sys-libs/glibc:           2.18-r1
Repositories: gentoo steam-overlay qt
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=core-avx-i -mtune=core-avx-i -O3 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT=""
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=core-avx-i -mtune=core-avx-i -O3 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://mirror.yandex.ru/gentoo-distfiles/"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j9"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/steam /var/lib/layman/qt"
SYNC="rsync://rsync2.ru.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa amd64 avx bash-completion berkdb bluetooth branding bzip2 cairo cdda cdr cli consolekit cracklib crypt cups custom-cflags custom-cxxflags cxx dbus declarative djvu dri dts dvd dvdr emboss encode exif fam firefox flac fortran gdbm gif gpm gstreamer gtk iconv icu ipv6 jpeg jpeg2k kde kipi lcms ldap libnotify lzma mad mmx mng modules mp3 mp4 mpeg multilib ncurses networkmanager nls nptl nvidia ogg openal opengl openmp pam pango pcre pdf phonon plasma png policykit ppds qt3support qt4 readline sdl semantic-desktop session smp sound spell sse sse2 sse3 sse4 sse4_1 sse4_2 ssl ssse3 startup-notification svg tcpd tiff truetype udev udisks unicode upower usb vorbis wxwidgets x264 xcb xcomposite xinerama xml xscreensaver xv xvid zlib" ABI_X86="64 32" ALSA_CARDS="hda-intel" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev keyboard mouse joystick void" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en_GB en_US en ru" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" RUBY_TARGETS="ruby19 ruby18" USERLAND="GNU" VIDEO_CARDS="nvidia intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Vladimir Miloserdov 2014-02-05 03:15:14 UTC
Created attachment 369558 [details]
build.log
Comment 2 Vladimir Miloserdov 2014-02-05 03:16:21 UTC
Created attachment 369560 [details]
emerge -pqv output
Comment 3 Jeroen Roovers (RETIRED) gentoo-dev 2014-02-05 10:45:44 UTC
!!! Please attach the following file when seeking support:
!!! /var/tmp/portage/media-libs/libquvi-0.4.1/work/libquvi-0.4.1_build/config.log

Please do.
Comment 4 Jeroen Roovers (RETIRED) gentoo-dev 2014-02-05 10:55:06 UTC
Also, post your `emerge -vpq media-libs/libquvi-scripts' output in a comment.
Comment 5 Vladimir Miloserdov 2014-02-05 16:57:07 UTC
emerge -vpq media-libs/libquvi-scripts output:
[ebuild   R   ] media-libs/libquvi-scripts-0.9.20131130  USE="-offensive"
Comment 6 Vladimir Miloserdov 2014-02-05 16:58:21 UTC
Created attachment 369624 [details]
config.log
Comment 7 Michael Weber (RETIRED) gentoo-dev 2014-02-05 21:44:44 UTC
ceres ~ 1 # emerge -vpq media-libs/libquvi-scripts
[ebuild     U ] media-libs/libquvi-scripts-0.9.20131130 [0.9.20131104] USE="-offensive" 


Downgrading (`emerge -av1 =media-libs/libquvi-scripts-0.9.20131104`) solves this, kinda.
Comment 8 Tim Harder gentoo-dev 2014-02-06 03:39:44 UTC
Why are you using stable libquvi with unstable libquvi-scripts?
Comment 9 Vladimir Miloserdov 2014-02-06 03:51:06 UTC
For unstable mplayer with quvi use flag enabled stable libquvi is required. My system is unstable so I've got libquvi-scripts installed.
Comment 10 Ben Kohler gentoo-dev 2014-02-08 16:57:14 UTC
Yes, an unsuspecting full-unstable user can hit this easily.  mplayer2 has this in RDEPEND:
quvi? ( >=media-libs/libquvi-0.4.1 <media-libs/libquvi-0.9 )

It seems to me that media-libs/libquvi-0.4.1 should further restrict its libquvi-scripts dep, from just

>=media-libs/libquvi-scripts-0.4.0

to

>=media-libs/libquvi-scripts-0.4.0
<media-libs/libquvi-scripts-0.9

That should take care of the issue.  Is there any reason that any of the libquvi-scripts-0.9* versions should be allowed with libquvi-0.4*?
Comment 11 Alexis Ballier gentoo-dev 2014-02-12 12:49:50 UTC
should be fixed in libquvi-0.4.1-r1