Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 497894 - media-libs/imlib2-1.4.{5,6} - imlib2-config contains @my_libs@ which configure doesn't expand
Summary: media-libs/imlib2-1.4.{5,6} - imlib2-config contains @my_libs@ which configur...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Gentoo Graphics Project
Depends on:
Reported: 2014-01-12 14:22 UTC by Emile
Modified: 2014-01-18 19:32 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---

build log (buildlog.txt,5.67 KB, text/plain)
2014-01-12 14:22 UTC, Emile
The environment file (environment.txt,69.38 KB, text/plain)
2014-01-12 14:22 UTC, Emile
emerge --info output (info.txt,15.60 KB, text/plain)
2014-01-12 14:22 UTC, Emile
emerge -pqv output (pqv.txt,61 bytes, text/plain)
2014-01-12 14:22 UTC, Emile
imlib2-config contains un-expanded @my_libs@ (fix-imlib-config-libraries.patch,328 bytes, patch)
2014-01-12 16:58 UTC, Jimmy.Jazz
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Emile 2014-01-12 14:22:12 UTC
Well, it just doesn't compile. And I heard one of my friends is having this problem so it's not just me, I think.

Reproducible: Always

Steps to Reproduce:
1. emerge scrot
Comment 1 Emile 2014-01-12 14:22:21 UTC
Created attachment 367708 [details]
build log
Comment 2 Emile 2014-01-12 14:22:32 UTC
Created attachment 367710 [details]
The environment file
Comment 3 Emile 2014-01-12 14:22:44 UTC
Created attachment 367712 [details]
emerge --info output
Comment 4 Emile 2014-01-12 14:22:52 UTC
Created attachment 367714 [details]
emerge -pqv output
Comment 5 Jimmy.Jazz 2014-01-12 16:58:40 UTC
Created attachment 367734 [details, diff]
imlib2-config contains un-expanded @my_libs@
Comment 6 Emile 2014-01-13 08:13:20 UTC
Is there a fix, then?
I tried adding Jimmy's patch, but it didn't help
Comment 7 SpanKY gentoo-dev 2014-01-13 21:07:11 UTC
Comment on attachment 367734 [details, diff]
imlib2-config contains un-expanded @my_libs@

not sure wtf you're talking about wrt gnu

maybe take it as a sign that using imlib2-config is a bad idea and you should switch to `pkg-config --libs imlib2`
Comment 8 Ted Tanberry 2014-01-18 16:03:44 UTC
--- imlib2-1.4.6.ebuild
+++ imlib2-1.4.6-r1.ebuild
@@ -37,6 +37,11 @@
+src_prepare () {
+	# imlib2 1.4.6 has been posted as non-maintainer upload
+	sed -i 's/@my_libs@//'
 src_configure() {
 	# imlib2 has diff configure options for x86/amd64 mmx
 	if [[ $(tc-arch) == amd64 ]]; then
Comment 9 Ted Tanberry 2014-01-18 16:15:37 UTC
(In reply to SpanKY from comment #7)
While I agree in general with the comment, the broken imlib2-config breaks too many downstream packages (such as scrot through its dependency on giblib). Debian has fixed it ( and BLFS also just seds @my_libs@ out ( Please commit this simple fix.
Comment 10 SpanKY gentoo-dev 2014-01-18 18:47:55 UTC
(In reply to Ted Tanberry from comment #9)

i'm not sure that description really fits.  1.4.5 has been in the tree since Feb 2012 and stable since Sep 2012 and this is the first bug report in Gentoo about it.

clearly it's not really used commonly anymore if it takes 2 years for someone to notice it.
Comment 12 SpanKY gentoo-dev 2014-01-18 19:32:34 UTC
should be all set now in the tree; thanks for the report!

Commit message: Add fix from upstream for stray @my_libs@ in imlib2-config