Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 497362 - media-sound/timidity++-2.14.0 with sys-libs/ncurses[tinfo] - ld: ../interface/libinterface.a(ncurs_c.o): undefined reference to symbol 'cbreak'
Summary: media-sound/timidity++-2.14.0 with sys-libs/ncurses[tinfo] - ld: ../interface...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Sound Team
URL:
Whiteboard:
Keywords:
: 519420 533142 (view as bug list)
Depends on:
Blocks: tinfo
  Show dependency tree
 
Reported: 2014-01-07 07:27 UTC by Dave Kemper
Modified: 2014-12-21 09:55 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
/var/tmp/portage/media-sound/timidity++-2.14.0/temp/build.log (build.log,50.70 KB, text/plain)
2014-01-07 07:27 UTC, Dave Kemper
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dave Kemper 2014-01-07 07:27:08 UTC
Created attachment 367258 [details]
/var/tmp/portage/media-sound/timidity++-2.14.0/temp/build.log

I first emerged media-sound/timidity++-2.14.0 in December 2012, and all went well.  Recently "emerge @preserved-rebuild" wanted to rebuild the same version of this package, and this rebuild failed:

i686-pc-linux-gnu-gcc  -O2 -march=native -pipe -O2 -march=native -pipe   -rdynamic -Wl,-O1 -Wl,--as-needed -o timidity aiff_a.o aq.o au_a.o audio_cnv.o common.o controls.o effect.o filter.o freq.o instrum.o list_a.o loadtab.o m2m.o mfi.o miditrace.o midi_a.o mix.o mod.o mod2midi.o modmid_a.o mt19937ar.o optcode.o output.o playmidi.o quantity.o raw_a.o rcp.o readmidi.o recache.o resample.o reverb.o sbkconv.o sffile.o sfitem.o smfconv.o smplfile.o sndfont.o tables.o timidity.o version.o wave_a.o wrd_read.o wrdt.o alsa_a.o vorbis_a.o flac_a.o dl_dlopen.o ../interface/libinterface.a ../libarc/libarc.a ../libunimod/libunimod.a ../utils/libutils.a  -lXaw3d  -lXmu -lXt -lSM -lICE -lXext -lX11 -lX11 -lasound -lm -ldl -lpthread -lm -ldl -lpthread -lm -ldl -lpthread -L/usr/lib -lFLAC -lm -lncurses -ldl -lpng -lz    -L/usr/lib -lvorbis -lm -lvorbisenc -L/usr/lib -logg
/usr/lib/gcc/i686-pc-linux-gnu/4.7.3/../../../../i686-pc-linux-gnu/bin/ld: ../interface/libinterface.a(ncurs_c.o): undefined reference to symbol 'cbreak'
/usr/lib/gcc/i686-pc-linux-gnu/4.7.3/../../../../i686-pc-linux-gnu/bin/ld: note: 'cbreak' is defined in DSO /lib/libtinfo.so.5 so try adding it to the linker command line
/lib/libtinfo.so.5: could not read symbols: Invalid operation
collect2: error: ld returned 1 exit status

I had to rebuild sys-libs/ncurses-5.9-r2 in May 2013, which I presume has something to do with timidity++'s current failure.
Comment 1 Rafał Mużyło 2014-01-07 17:10:00 UTC
...
Let me guess: ncurses[tinfo] ?
Comment 2 Dave Kemper 2014-01-07 19:28:28 UTC
Seems likely: symptoms are similar to bug 483496 and bug 486124 (among others), which block bug 457530.
Comment 3 SpanKY gentoo-dev 2014-04-29 03:09:21 UTC
should be all set now in the tree; thanks for the report!

Commit message: Fix pkg-config handling and use it to get ncurses info
http://sources.gentoo.org/media-sound/timidity++/files/timidity++-2.14.0-pkg-config.patch?rev=1.1
http://sources.gentoo.org/media-sound/timidity++/timidity++-2.14.0-r2.ebuild?rev=1.1
Comment 4 Jeroen Roovers gentoo-dev 2014-08-12 09:40:31 UTC
*** Bug 519420 has been marked as a duplicate of this bug. ***
Comment 5 Jeroen Roovers gentoo-dev 2014-12-21 09:55:46 UTC
*** Bug 533142 has been marked as a duplicate of this bug. ***