Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 497238 - =sys-apps/portage-2.2.8: New portage always wants to rebuild subslotted package
Summary: =sys-apps/portage-2.2.8: New portage always wants to rebuild subslotted package
Status: RESOLVED FIXED
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Core - Dependencies (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords: InVCS
: 497990 (view as bug list)
Depends on:
Blocks: 484436
  Show dependency tree
 
Reported: 2014-01-06 10:49 UTC by Thomas Deutschmann
Modified: 2014-08-04 02:09 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Requested emerge debug output (portage-2.2.8_bug497238_debug.log.gz,175.45 KB, application/x-compressed-tar)
2014-01-06 16:30 UTC, Thomas Deutschmann
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Deutschmann gentoo-dev Security 2014-01-06 10:49:19 UTC
Hi,

today I upgraded from "sys-apps/portage-2.2.7" to "sys-apps/portage-2.2.8". Now every time I run

  emerge --ask --verbose --update --deep --with-bdeps=y --newuse world

portage always wants to re-emerge the following packages:

Calculating dependencies... done!
[ebuild  rR    ] net-firewall/iptables-1.4.21:0/10::whissi-overlay  USE="ipv6 -netlink -static-libs" 0 kB
[ebuild  rR    ] sys-apps/iproute2-3.12.0  USE="berkdb iptables ipv6 -atm -minimal" 0 kB

Total: 2 packages (2 reinstalls), Size of downloads: 0 kB


As you can see it is not net-firewall/iptables from portage, it is from my overlay. You can find it in GitHub [1] (I forked the package package basically to resolve bug 489882 for me, so I added a subslot and bumped EAPI to 5).

"sys-apps/iproute2-3.12.0" will be rebuild because it depends on "net-firewall/iptables:=", so this is correct.

Because it was working before "sys-apps/portage-2.2.8" like a charm I think this is a bug in the new portage version. Maybe the problem was introduced with the fix for bug 487198?



See also:
=========
[1] https://github.com/Whissi/gentoo-overlay/blob/master/net-firewall/iptables/iptables-1.4.21.ebuild


# emerge --info
Portage 2.2.8 (default/linux/amd64/13.0, gcc-4.8.2, glibc-2.17, 3.10.25 x86_64)
=================================================================
System uname: Linux-3.10.25-x86_64-Intel-R-_Core-TM-_i7-3770K_CPU_@_3.50GHz-with-gentoo-2.2
KiB Mem:     4050880 total,   3215856 free
KiB Swap:    1048572 total,   1048572 free
Timestamp of tree: Mon, 06 Jan 2014 09:45:01 +0000
ld GNU ld (GNU Binutils) 2.24
app-shells/bash:          4.2_p45
dev-lang/python:          2.7.6, 3.3.3
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.12.4
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.69
sys-devel/automake:       1.12.6, 1.14.1
sys-devel/binutils:       2.24
sys-devel/gcc:            4.8.2
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           4.0-r1
sys-kernel/linux-headers: 3.11 (virtual/os-headers)
sys-libs/glibc:           2.17
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.de.gentoo.org/gentoo-portage/
    priority: -1000

whissi-overlay
    location: /usr/local/portage
    sync-type: git
    sync-uri: https://github.com/Whissi/gentoo-overlay.git
    masters: gentoo

ABI="amd64"
ABI_X86="64"
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA"
ACCEPT_PROPERTIES="*"
ACCEPT_RESTRICT="*"


Reproducible: Always
Comment 1 Thomas Deutschmann gentoo-dev Security 2014-01-06 11:39:34 UTC
What I noticed:

If I add

  net-firewall/iptables::gentoo

to /etc/portage/package.mask (notice that I mask the package from the Gentoo repository which isn't installed) portage does *not* want to re-emerge net-firewall/iptables::whissi-overlay anymore! If I remove the mask, portage wants to re-emerge "net-firewall/iptables-1.4.21:0/10::whissi-overlay" like before.

Also, if I copy the ebuild from my overlay into the tree (as 1.4.21-r1) the problem is gone after I upgraded (so there's nothing wrong with the ebuild?).

Finally I bumped iptables-1.4.21.ebuild to iptables-1.4.21-r1.ebuild in my overlay. After I upgraded to -r1 from my overlay, the problem was also solved.

My conclusion:
iptables-1.4.21.ebuild with subslot information from my overlay is conflicting with iptables-1.4.21.ebuild without subslot information from the official Gentoo repository.

Looks like portage's depgraph function is mixing information it shouldn't mix.
Comment 2 Sebastian Luther (few) 2014-01-06 15:59:54 UTC
Please attach the debug.log created by: "emerge --ask --verbose --update --deep --with-bdeps=y --newuse world --debug &> debug.log"
Comment 3 Thomas Deutschmann gentoo-dev Security 2014-01-06 16:30:18 UTC
Created attachment 367198 [details]
Requested emerge debug output
Comment 5 Thomas Deutschmann gentoo-dev Security 2014-01-07 23:26:47 UTC
Thank you Sebastian! I tested the fix and portage no longer wants to rebuild the sub-slotted package from the overlay.

One last question: Are you going to release a new portage version containing the fix within the next week or don't you know yet when the next portage version will be released?
Comment 6 Sebastian Luther (few) 2014-01-08 06:08:42 UTC
(In reply to Thomas D. from comment #5)
> One last question: Are you going to release a new portage version containing
> the fix within the next week or don't you know yet when the next portage
> version will be released?


I don't think we're going to release a new versin that soon.
Comment 7 Sebastian Luther (few) 2014-01-14 11:58:20 UTC
*** Bug 497990 has been marked as a duplicate of this bug. ***
Comment 8 Brian Dolbec gentoo-dev 2014-08-04 02:09:46 UTC
released in portage-2.2.11