Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 497128 - dev-lang/ruby-2.1.0 with tcl-8.6*: tcltklib.o: In function `ip_cancel_eval_core': tcltklib.c:(.text+0x164f): undefined reference to `Tcl_CancelEval'
Summary: dev-lang/ruby-2.1.0 with tcl-8.6*: tcltklib.o: In function `ip_cancel_eval_co...
Status: RESOLVED DUPLICATE of bug 497130
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Development (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-01-05 11:08 UTC by jannis
Modified: 2014-01-05 11:13 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jannis 2014-01-05 11:08:42 UTC
dev-lang/ruby-2.1.0 fails to compile against tcl-8.6* with an linker error:
x86_64-pc-linux-gnu-gcc -shared -o ../../.ext/x86_64-linux/tcltklib.so stubs.o tcltklib.o -L. -L../.. -L/usr/lib64 -L. -Wl,-O1 -Wl,--as-needed -fstack-protector -rdynamic -Wl,-export-dynamic -Wl,--no-undefined    -lruby21 -lX11 -lm -ldl  -L/usr/lib64 -Wl,-R/usr/lib64 -ltcl8.5 -lX11 -lm -ldl  -L/usr/lib64 -Wl,-R/usr/lib64 -ltk8.5 -lX11 -lm -ldl  -L/usr/lib64 -Wl,-R/usr/lib64 -ltcl8.5 -lX11 -lm -ldl  -lpthread -lgmp -ldl -lcrypt -lm   -lc
tcltklib.o: In function `ip_cancel_eval_core':
tcltklib.c:(.text+0x164f): undefined reference to `Tcl_CancelEval'
collect2: error: ld returned 1 exit status
Makefile:2052: recipe for target '../../.ext/x86_64-linux/tcltklib.so' failed
make[2]: *** [../../.ext/x86_64-linux/tcltklib.so] Error 1

Note that on my system the shared libraries for tcl-8.5 are still preserved since sci-geosciences/grass also fails to compile against tcl-8.6 (#451358)

Reproducible: Always
Comment 1 Lars Wendler (Polynomial-C) gentoo-dev 2014-01-05 11:13:20 UTC

*** This bug has been marked as a duplicate of bug 497130 ***