Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 495988 - app-text/qpdf-5.1.0 fails to build
Summary: app-text/qpdf-5.1.0 fails to build
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Printing Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: nonbash
  Show dependency tree
 
Reported: 2013-12-25 13:01 UTC by Patrick Lauer
Modified: 2017-02-14 22:23 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Lauer gentoo-dev 2013-12-25 13:01:53 UTC
sed -e 's:@PACKAGE_VERSION@:5.1.0:g' \
    -e 's:@docdir@:/usr/share/doc/qpdf:g' \
    < manual/zlib-flate.1.in > doc/zlib-flate.1
/bin/bash ./libtool --quiet --mode=compile x86_64-pc-linux-gnu-g++ -O2 -pipe -Wold-style-cast -Wall -MD -MF libqpdf/build/BitStream.tdep -MP -Iinclude -Ilibqpdf  -c libqpdf/BitStream.cc -o libqpdf/build/BitStream.o; sed -e 's/\.o:/.lo:/' < libqpdf/build/BitStream.tdep > libqpdf/build/BitStream.dep
./libtool: line 903: print: command not found
./libtool: line 903: print: command not found
./libtool: line 903: print: command not found
./libtool: line 903: print: command not found
./libtool: line 974: print: command not found
./libtool: line 976: print: command not found
./libtool: line 910: print: command not found
/bin/bash: libqpdf/build/BitStream.tdep: No such file or directory
libqpdf/build.mk:81: recipe for target 'libqpdf/build/BitStream.lo' failed
make: *** [libqpdf/build/BitStream.lo] Error 1
 * ERROR: app-text/qpdf-5.1.0::gentoo failed (compile phase):
 *   emake failed

Portage 2.2.7 (default/linux/amd64/13.0/desktop/kde, gcc-4.8.2, glibc-2.17, 3.12.0-gentoo x86_64)
=================================================================
System uname: Linux-3.12.0-gentoo-x86_64-AMD_E-350_Processor-with-gentoo-2.2
KiB Mem:     3641120 total,    518656 free
KiB Swap:    8388604 total,   8335800 free
Timestamp of tree: Unknown
ld GNU ld (GNU Binutils) 2.23.2
app-shells/bash:          4.2_p45
dev-java/java-config:     2.2.0
dev-lang/python:          2.5.4-r4, 2.6.8, 2.7.6, 3.2.4, 3.3.3
dev-util/cmake:           2.8.12.1-r1
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.12.4
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.9.6-r3, 1.11.5, 1.12.6, 1.13.4, 1.14
sys-devel/binutils:       2.23.2
sys-devel/gcc:            4.6.3, 4.7.2-r1, 4.8.2
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           4.0-r1
sys-kernel/linux-headers: 3.12 (virtual/os-headers)
sys-libs/glibc:           2.17
Repositories: gentoo local
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA skype-eula Q3AEULA PUEL AdobeFlash-10.3 skype-4.0.0.7-copyright AdobeFlash-11.x"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/polkit-1/actions"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--quiet-build=n"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PKGDIR="/home/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/home/me/code/gentoo-x86"
PORTDIR_OVERLAY="/home/me/code/overlay"
USE="X a52 aac acl acpi alsa amd64 berkdb bluetooth branding bzip2 cairo cdda cdr cli consolekit cracklib crypt cups cxx dbus declarative device-mapper dri dts dvd dvdr emboss encode exif extras fam firefox flac fortran gdbm gif gles2 gpm gtk gudev iconv icu ipv6 jabber jpeg kde kipi lcms ldap libnotify mad mmx mng modules mp3 mp4 mpeg mudflap multilib ncurses networkmanager nls nptl nsplugin ogg opengl openmp opus pam pango pcre pdf phonon plasma png policykit ppds python qt3support qt4 readline sdl semantic-desktop session spell sql sqlite sse sse2 ssl startup-notification svg tcpd tiff truetype udev udisks unicode upower usb vdpau vorbis webkit wxwidgets x264 xcb xcomposite xinerama xml xscreensaver xv xvid zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" NGINX_MODULES_HTTP="access auth_basic autoindex browser charset empty_gif fastcgi geo gzip limit_req limit_zone map memcached proxy referer rewrite scgi split_clients ssi upstream_ip_hash userid uwsgi push" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" RUBY_TARGETS="ruby20" USERLAND="GNU" VIDEO_CARDS="radeon vesa" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, MAKEOPTS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, SYNC, USE_PYTHON
Comment 1 Tim Harder gentoo-dev 2013-12-27 07:42:29 UTC
I'm guessing it's a parallel make bug. Can you try building serially to confirm that works since I can't reproduce it?
Comment 2 Jeff Bedard 2014-07-29 03:36:07 UTC
I have encountered this build failure as well with 5.1.2.  It seems that libqpdf/build/.libs is not created as it should be.  Creating this directory manually allows the build to continue further, however compilation fails as follows:
-r -- libtool: link: g++  -fPIC -DPIC -shared -nostdlib /usr/lib/gcc/x86_64-pc-linux-gnu/4.8.3/../../../../lib64/crti.o /usr/lib/gcc/x86_64-pc-linux-gnu/4.8.3/crtbeginS.o  libqpdf/build/.libs/BitStream.o libqpdf/build/.libs/BitWriter.o libqpdf/build/.libs/Buffer.o libqpdf/build/.libs/BufferInputSource.o libqpdf/build/.libs/FileInputSource.o libqpdf/build/.libs/InputSource.o libqpdf/build/.libs/InsecureRandomDataProvider.o libqpdf/build/.libs/.libs/InputSource.o libqpdf/build/.libs/InsecureRandomDataProvider.o libqpdf/build/.libs/MD5.o libqpdf/build/.libs/OffsetInputSource.o libqpdf/build/.libs/PCRE.o libqpdf/build/.libs/Pipeline.o libqpdf/build/.libs/Pl_AES_PDF.o libqpdf/build/.libs/Pl_ASCII85Decoder.o libqpdf/build/.libs/Pl_ASCIIHexDecoder.o libqpdf/build/.libs/Pl_Buffer.o libqpdf/build/.libs/Pl_Concatenate.o libqpdf/build/.libs/Pl_Count.o libqpdf/build/.libs/Pl_Discard.o libqpdf/build/.libs/Pl_Flate.o libqpdf/build/.libs/Pl_LZWDecoder.o libqpdf/build/.libs/Pl_MD5.o libqpdf/build/.libs/Pl_PNGFilter.o libqpdf/build/.libs/Pl_QPDFTokenizer.o libqpdf/build/.libs/Pl_RC4.o libqpdf/build/.libs/Pl_SHA2.o libqpdf/build/.libs/Pl_StdioFile.o libqpdf/build/.libs/QPDF.o libqpdf/build/.libs/QPDFExc.o libqpdf/build/.libs/QPDFObjGen.o libqpdf/build/.libs/QPDFObject.o libqpdf/build/.libs/QPDFObjectHandle.o libqpdf/build/.libs/QPDFTokenizer.o libqpdf/build/.libs/QPDFWriter.o libqpdf/build/.libs/QPDFXRefEntry.o libqpdf/build/.libs/QPDF_Array.o libqpdf/build/.libs/QPDF_Bool.o libqpdf/build/.libs/QPDF_Dictionary.o libqpdf/build/.libs/QPDF_InlineImage.o libqpdf/build/.libs/QPDF_Integer.o libqpdf/build/.libs/QPDF_Name.o libqpdf/build/.libs/QPDF_Null.o libqpdf/build/.libs/QPDF_Operator.o libqpdf/build/.libs/QPDF_Real.o libqpdf/build/.libs/QPDF_Reserved.o libqpdf/build/.libs/QPDF_Stream.o libqpdf/build/.libs/QPDF_String.o libqpdf/build/.libs/QPDF_encryption.o libqpdf/build/.libs/QPDF_linearization.o libqpdf/build/.libs/QPDF_optimization.o libqpdf/build/.libs/QPDF_pages.o libqpdf/build/.libs/QTC.o libqpdf/build/.libs/QUtil.o libqpdf/build/.libs/RC4.o libqpdf/build/.libs/SecureRandomDataProvider.o libqpdf/build/.libs/qpdf-c.o libqpdf/build/.libs/rijndael.o libqpdf/build/.libs/sha2.o libqpdf/build/.libs/sha2big.o   -lpcre -lz -L/usr/lib/gcc/x86_64-pc-linux-gnu/4.8.3 -L/usr/lib/gcc/x86_64-pc-linux-gnu/4.8.3/../../../../lib64 -L/lib/../lib64 -L/usr/lib/../lib64 -L/usr/lib/gcc/x86_64-pc-linux-gnu/4.8.3/../../../../x86_64-pc-linux-gnu/lib -L/usr/lib/gcc/x86_64-pc-linux-gnu/4.8.3/../../.. -lstdc++ -lm -lc -lgcc_s /usr/lib/gcc/x86_64-pc-linux-gnu/4.8.3/crtfastmath.o /usr/lib/gcc/x86_64-pc-linux-gnu/4.8.3/crtendS.o /usr/lib/gcc/x86_64-pc-linux-gnu/4.8.3/../../../../lib64/crtn.o  -Ofast -march=native -mfpmath=both -Wl,--version-script=libqpdf.map -r --   -Wl,-soname -Wl,libqpdf.so.13 -o libqpdf/build/.libs/libqpdf.so.13.1.2
g++: error: unrecognized command line option '--'
libqpdf/build.mk:99: recipe for target 'libqpdf/build/libqpdf.la' failed
make: *** [libqpdf/build/libqpdf.la] Error 1
Comment 3 Jeff Bedard 2014-07-29 03:42:38 UTC
Running the build serially does not succeed (trying to address potential parallel make problem)  My emerge --info follows:

Portage 2.2.10 (default/linux/amd64/13.0/no-multilib, gcc-4.8.3, glibc-2.19-r1, 3.15.6-gentoo x86_64)
=================================================================
System uname: Linux-3.15.6-gentoo-x86_64-AMD_Turion-tm-_64_X2_Mobile_Technology_TL-60-with-gentoo-2.2
KiB Mem:     3919464 total,    304032 free
KiB Swap:    4000180 total,   3991224 free
Timestamp of tree: Mon, 28 Jul 2014 02:45:01 +0000
ld GNU ld (GNU Binutils) 2.24
app-shells/bash:          4.2_p47
dev-lang/python:          2.7.7, 3.4.1
dev-util/cmake:           2.8.12.2-r1
dev-util/pkgconfig:       0.28-r1
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.12.4
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.14.1
sys-devel/binutils:       2.24-r3
sys-devel/gcc:            4.8.3
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2-r1
sys-devel/make:           4.0-r1
sys-kernel/linux-headers: 3.15 (virtual/os-headers)
sys-libs/glibc:           2.19-r1
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.us.gentoo.org/gentoo-portage
    priority: -1000

ABI="amd64"
ABI_X86="64"
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA"
ACCEPT_PROPERTIES="*"
ACCEPT_RESTRICT="*"
ALSA_CARDS=""
APACHE2_MODULES=""
ARCH="amd64"
AUTOCLEAN="yes"
BOOTSTRAP_USE="cxx unicode internal-glib python_targets_python3_3 python_targets_python2_7 multilib multilib"
CALLIGRA_FEATURES=""
CAMERAS=""
CBUILD="x86_64-pc-linux-gnu"
CCACHE_DIR="/tmp"
CFLAGS="-pipe -Ofast -fomit-frame-pointer -march=native -mfpmath=both"
CFLAGS_amd64="-m64"
CFLAGS_x32="-mx32"
CFLAGS_x86="-m32"
CHOST="x86_64-pc-linux-gnu"
CHOST_amd64="x86_64-pc-linux-gnu"
CHOST_x32="x86_64-pc-linux-gnux32"
CHOST_x86="i686-pc-linux-gnu"
CLEAN_DELAY="0"
COLLECTD_PLUGINS=""
COLLISION_IGNORE="/lib/modules/* *.py[co] *$py.class */dropin.cache"
COLORFGBG="15;default;0"
COLORTERM="rxvt-xpm"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CONFIG_SHELL="/bin/mksh"
CXXFLAGS="-pipe -Ofast -fomit-frame-pointer -march=native -mfpmath=both"
DEFAULT_ABI="amd64"
DESKTOP_STARTUP_ID="i3/i3-sensible-terminal/643-6-toshiba_TIME2925575"
DISPLAY=":0"
DISTDIR="/usr/portage/distfiles"
EDITOR="/usr/bin/vi"
ELIBC="glibc"
EMERGE_DEFAULT_OPTS="--keep-going --verbose --with-bdeps=y --changelog"
EMERGE_WARNING_DELAY="5"
EPAUSE_IGNORE="1"
EPREFIX=""
EROOT="/"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs buildsyspkg config-protect-if-modified distlocks fixlafiles merge-sync news parallel-fetch parallel-install preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch usersandbox usersync"
FETCHCOMMAND="/usr/bin/curl --connect-timeout 15 -# -o ${DISTDIR}/${FILE} ${URI}"
FETCHCOMMAND_RSYNC="rsync -avP "${URI}" "${DISTDIR}/${FILE}""
FETCHCOMMAND_SFTP="bash -c "x=\${2#sftp://} ; host=\${x%%/*} ; port=\${host##*:} ; host=\${host%:*} ; [[ \${host} = \${port} ]] && port=22 ; eval \"declare -a ssh_opts=(\${3})\" ; exec sftp -P \${port} \"\${ssh_opts[@]}\" \"\${host}:/\${x#*/}\" \"\$1\"" sftp "${DISTDIR}/${FILE}" "${URI}" "${PORTAGE_SSH_OPTS}""
FETCHCOMMAND_SSH="bash -c "x=\${2#ssh://} ; host=\${x%%/*} ; port=\${host##*:} ; host=\${host%:*} ; [[ \${host} = \${port} ]] && port=22 ; exec rsync --rsh=\"ssh -p\${port} \${3}\" -avP \"\${host}:/\${x#*/}\" \"\$1\"" rsync "${DISTDIR}/${FILE}" "${URI}" "${PORTAGE_SSH_OPTS}""
FFLAGS="-O2 -pipe"
GCC_SPECS=""
GENTOO_MIRRORS="http://distfiles.gentoo.org"
GNOME_DESKTOP_SESSION_ID="i3"
GPSD_PROTOCOLS=""
GRUB_PLATFORMS=""
HOME="/root"
HUSHLOGIN="FALSE"
INFOPATH="/usr/share/info:/usr/share/gcc-data/x86_64-pc-linux-gnu/4.8.3/info:/usr/share/binutils-data/x86_64-pc-linux-gnu/2.24/info"
INPUT_DEVICES=""
IRCNAME="anonymous"
IRCNICK="NuDragon"
IRCSERVER="us.undernet.org"
IUSE_IMPLICIT="abi_x86_64 prefix"
KERNEL="linux"
LANG="en_US.utf8"
LCD_DEVICES=""
LC_COLLATE="C"
LC_MESSAGES="C"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LDFLAGS_amd64="-m elf_x86_64"
LDFLAGS_x32="-m elf32_x86_64"
LDFLAGS_x86="-m elf_i386"
LESS="-R -M --shift 5"
LESSOPEN="|lesspipe %s"
LIBDIR_amd64="lib64"
LIBDIR_amd64_fbsd="lib64"
LIBDIR_arm="lib"
LIBDIR_arm64="lib64"
LIBDIR_n32="lib32"
LIBDIR_n64="lib64"
LIBDIR_o32="lib"
LIBDIR_ppc="lib32"
LIBDIR_ppc64="lib64"
LIBDIR_s390="lib32"
LIBDIR_s390x="lib64"
LIBDIR_sparc32="lib32"
LIBDIR_sparc64="lib64"
LIBDIR_x32="libx32"
LIBDIR_x86="lib32"
LIBDIR_x86_fbsd="lib32"
LIBREOFFICE_EXTENSIONS=""
LINGUAS="en"
LOGNAME="root"
LS_COLORS="rs=0:di=01;34:ln=04;36:mh=00:pi=40;33:so=01;35:do=01;35:bd=40;33;01:cd=40;33;01:or=01;05;37;41:mi=01;05;37;41:su=37;41:sg=30;43:ca=30;41:tw=30;42:ow=34;42:st=37;44:ex=01;32:*.tar=01;31:*.tgz=01;31:*.arc=01;31:*.arj=01;31:*.taz=01;31:*.lha=01;31:*.lz4=01;31:*.lzh=01;31:*.lzma=01;31:*.tlz=01;31:*.txz=01;31:*.tzo=01;31:*.t7z=01;31:*.zip=01;31:*.z=01;31:*.Z=01;31:*.dz=01;31:*.gz=01;31:*.lrz=01;31:*.lz=01;31:*.lzo=01;31:*.xz=01;31:*.bz2=01;31:*.bz=01;31:*.tbz=01;31:*.tbz2=01;31:*.tz=01;31:*.deb=01;31:*.rpm=01;31:*.jar=01;31:*.war=01;31:*.ear=01;31:*.sar=01;31:*.rar=01;31:*.alz=01;31:*.ace=01;31:*.zoo=01;31:*.cpio=01;31:*.7z=01;31:*.rz=01;31:*.cab=01;31:*.jpg=01;35:*.jpeg=01;35:*.gif=01;35:*.bmp=01;35:*.pbm=01;35:*.pgm=01;35:*.ppm=01;35:*.tga=01;35:*.xbm=01;35:*.xpm=01;35:*.tif=01;35:*.tiff=01;35:*.png=01;35:*.svg=01;35:*.svgz=01;35:*.mng=01;35:*.pcx=01;35:*.mov=01;35:*.mpg=01;35:*.mpeg=01;35:*.m2v=01;35:*.mkv=01;35:*.webm=01;35:*.ogm=01;35:*.mp4=01;35:*.m4v=01;35:*.mp4v=01;35:*.vob=01;35:*.qt=01;35:*.nuv=01;35:*.wmv=01;35:*.asf=01;35:*.rm=01;35:*.rmvb=01;35:*.flc=01;35:*.avi=01;35:*.fli=01;35:*.flv=01;35:*.gl=01;35:*.dl=01;35:*.xcf=01;35:*.xwd=01;35:*.yuv=01;35:*.cgm=01;35:*.emf=01;35:*.axv=01;35:*.anx=01;35:*.ogv=01;35:*.ogx=01;35:*.pdf=00;32:*.ps=00;32:*.txt=00;32:*.patch=00;32:*.diff=00;32:*.log=00;32:*.tex=00;32:*.doc=00;32:*.aac=00;36:*.au=00;36:*.flac=00;36:*.mid=00;36:*.midi=00;36:*.mka=00;36:*.mp3=00;36:*.mpc=00;36:*.ogg=00;36:*.ra=00;36:*.wav=00;36:*.axa=00;36:*.oga=00;36:*.spx=00;36:*.xspf=00;36:"
MAKEOPTS="-j4"
MANPATH="/usr/local/share/man:/usr/share/man:/usr/share/gcc-data/x86_64-pc-linux-gnu/4.8.3/man:/usr/share/binutils-data/x86_64-pc-linux-gnu/2.24/man"
MULTILIB_ABIS="amd64"
MULTILIB_STRICT_DENY="64-bit.*shared object"
MULTILIB_STRICT_DIRS="/lib32 /lib /usr/lib32 /usr/lib /usr/kde/*/lib32 /usr/kde/*/lib /usr/qt/*/lib32 /usr/qt/*/lib /usr/X11R6/lib32 /usr/X11R6/lib"
MULTILIB_STRICT_EXEMPT="(perl5|gcc|gcc-lib|binutils|eclipse-3|debug|portage|udev|systemd|clang|python-exec)"
NETBEANS="apisupport cnd groovy gsf harness ide identity j2ee java mobility nb php profiler soa visualweb webcommon websvccommon xml"
OFFICE_IMPLEMENTATION=""
OPENCL_PROFILE="amd"
OPENGL_PROFILE="xorg-x11"
PACKAGE_MANAGER="portage"
PAGER="/usr/bin/less"
PATH="/sbin:/bin:/usr/sbin:/usr/bin"
PHP_TARGETS=""
PKGDIR="/usr/portage/packages"
PKG_CONFIG_PATH="/usr/lib/pkgconfig:/usr/local/lib/pkgconfig"
PORTAGE_ARCHLIST="x86-winnt x86-solaris ppc64 hppa m68k arm64 sparc-solaris x64-openbsd ppc s390 ia64-hpux ppc-macos x86-fbsd amd64-fbsd x86-interix x64-freebsd x86-openbsd ppc-openbsd arm x86 sh amd64 x64-solaris sparc-fbsd arm-linux x86-macos ia64-linux x86-linux ppc-aix mips hppa-hpux alpha x86-freebsd amd64-linux sparc64-freebsd x86-cygwin ppc64-linux ia64 sparc x64-macos m68k-mint sparc64-solaris x86-netbsd"
PORTAGE_BIN_PATH="/usr/lib64/portage/bin"
PORTAGE_COMPRESS_EXCLUDE_SUFFIXES="css gif htm[l]? jp[e]?g js pdf png"
PORTAGE_CONFIGROOT="/"
PORTAGE_DEBUG="0"
PORTAGE_DEPCACHEDIR="/var/cache/edb/dep"
PORTAGE_ELOG_CLASSES="warn info error log"
PORTAGE_ELOG_MAILFROM="portage@localhost"
PORTAGE_ELOG_MAILSUBJECT="[portage] ebuild log for ${PACKAGE} on ${HOST}"
PORTAGE_ELOG_MAILURI="root"
PORTAGE_ELOG_SYSTEM="save"
PORTAGE_FETCH_CHECKSUM_TRY_MIRRORS="5"
PORTAGE_FETCH_RESUME_MIN_SIZE="350K"
PORTAGE_GID="250"
PORTAGE_GPG_SIGNING_COMMAND="gpg --sign --digest-algo SHA256 --clearsign --yes --default-key "${PORTAGE_GPG_KEY}" --homedir "${PORTAGE_GPG_DIR}" "${FILE}""
PORTAGE_INST_GID="0"
PORTAGE_INST_UID="0"
PORTAGE_INTERNAL_CALLER="1"
PORTAGE_OVERRIDE_EPREFIX=""
PORTAGE_PYM_PATH="/usr/lib64/portage/pym"
PORTAGE_PYTHONPATH="/usr/lib64/portage/pym"
PORTAGE_REPOSITORIES="[DEFAULT]
main-repo = gentoo

[gentoo]
location = /usr/portage
masters = 
priority = -1000
sync-type = rsync
sync-uri = rsync://rsync.us.gentoo.org/gentoo-portage
"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_RSYNC_RETRIES="-1"
PORTAGE_SYNC_STALE="30"
PORTAGE_TMPDIR="/var/tmp"
PORTAGE_VERBOSE="1"
PORTAGE_WORKDIR_MODE="0700"
PORTAGE_XATTR_EXCLUDE="security.* system.nfs4_acl"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
PORT_LOGDIR_CLEAN="find "${PORT_LOGDIR}" -type f ! -name "summary.log*" -mtime +7 -delete"
PRELINK_PATH_MASK="/usr/lib64/libfreebl3.so:/usr/lib64/libnssdbm3.so:/usr/lib64/libsoftokn3.so"
PROFILE_ONLY_VARIABLES="ARCH ELIBC IUSE_IMPLICIT KERNEL USERLAND USE_EXPAND_IMPLICIT USE_EXPAND_UNPREFIXED USE_EXPAND_VALUES_ARCH USE_EXPAND_VALUES_ELIBC USE_EXPAND_VALUES_KERNEL USE_EXPAND_VALUES_USERLAND"
PS1="# "
PYTHONDONTWRITEBYTECODE="1"
PYTHON_SINGLE_TARGET="python3_4"
PYTHON_TARGETS="python2_7 python3_4"
QEMU_SOFTMMU_TARGETS="arm i386 x86_64"
QEMU_USER_TARGETS="arm i386 x86_64"
QT_GRAPHICSSYSTEM="raster"
RANDOM="2624"
RESUMECOMMAND="/usr/bin/curl --connect-timeout 15 -# -C - -o ${DISTDIR}/${FILE}${URI}"
RESUMECOMMAND_RSYNC="rsync -avP "${URI}" "${DISTDIR}/${FILE}""
RESUMECOMMAND_SSH="bash -c "x=\${2#ssh://} ; host=\${x%%/*} ; port=\${host##*:} ; host=\${host%:*} ; [[ \${host} = \${port} ]] && port=22 ; exec rsync --rsh=\"ssh -p\${port} \${3}\" -avP \"\${host}:/\${x#*/}\" \"\$1\"" rsync "${DISTDIR}/${FILE}" "${URI}" "${PORTAGE_SSH_OPTS}""
ROOT="/"
ROOTPATH="/opt/bin:/usr/x86_64-pc-linux-gnu/gcc-bin/4.8.3"
RPMDIR="/usr/portage/rpm"
RUBY_TARGETS="ruby19"
SHELL="/bin/mksh"
SYMLINK_LIB="yes"
SYNC="rsync://rsync.us.gentoo.org/gentoo-portage"
TEMP="/tmp"
TERM="rxvt"
TIMEZONE="America/New_York"
TMP="/tmp"
TZ="America/New_York"
UNINSTALL_IGNORE="/lib/modules/*"
USE="3dnow 3dnowext X acpi adobe-cff alsa amd64 berkdb branding client custom-cflags custom-optimization dbus dri dri3 drm egl experimental glamor jpeg libkms lto matroska mmap mmx mmxext mp3 mpeg ncurses nptl nss ogg openrc pam png python3 smp smpeg sqlite sse sse2 sse3 svg symlink theora threads tools udev utils vorbis x264 xcb xgetdefault xinerama xlib-xcb xv" ABI_X86="64" ELIBC="glibc" KERNEL="linux" LINGUAS="en" PYTHON_SINGLE_TARGET="python3_4" PYTHON_TARGETS="python2_7 python3_4" QEMU_SOFTMMU_TARGETS="arm i386 x86_64" QEMU_USER_TARGETS="arm i386 x86_64" RUBY_TARGETS="ruby19" USERLAND="GNU" VIDEO_CARDS="fbdev radeon r300"
USER="root"
USERLAND="GNU"
USE_EXPAND="ABI_MIPS ABI_PPC ABI_S390 ABI_X86 ALSA_CARDS APACHE2_MODULES APACHE2_MPMS CALLIGRA_FEATURES CAMERAS COLLECTD_PLUGINS CROSSCOMPILE_OPTS CURL_SSL DRACUT_MODULES DVB_CARDS ELIBC ENLIGHTENMENT_MODULES FCDSL_CARDS FFTOOLS FOO2ZJS_DEVICES FRITZCAPI_CARDS GPSD_PROTOCOLS GRUB_PLATFORMS INPUT_DEVICES KERNEL LCD_DEVICES LIBREOFFICE_EXTENSIONS LINGUAS LIRC_DEVICES MONKEYD_PLUGINS NETBEANS_MODULES NGINX_MODULES_HTTP NGINX_MODULES_MAIL OFED_DRIVERS OFFICE_IMPLEMENTATION OPENMPI_FABRICS OPENMPI_OFED_FEATURES OPENMPI_RM PHP_TARGETS PYTHON_SINGLE_TARGET PYTHON_TARGETS QEMU_SOFTMMU_TARGETS QEMU_USER_TARGETS RUBY_TARGETS SANE_BACKENDS USERLAND UWSGI_PLUGINS VIDEO_CARDS VOICEMAIL_STORAGE XFCE_PLUGINS XTABLES_ADDONS"
USE_EXPAND_HIDDEN="ABI_MIPS ABI_PPC ABI_S390 ABI_X86 CROSSCOMPILE_OPTS ELIBC KERNEL USERLAND"
USE_EXPAND_IMPLICIT="ARCH ELIBC KERNEL USERLAND"
USE_EXPAND_UNPREFIXED="ARCH"
USE_EXPAND_VALUES_ARCH="alpha amd64 amd64-fbsd amd64-linux arm arm-linux arm64 hppa hppa-hpux ia64 ia64-hpux ia64-linux m68k m68k-mint mips ppc ppc64 ppc64-linux ppc-aix ppc-macos ppc-openbsd s390 sh sparc sparc64-freebsd sparc64-solaris sparc-fbsd sparc-solaris x64-freebsd x64-macos x64-openbsd x64-solaris x86 x86-cygwin x86-fbsd x86-freebsd x86-interix x86-linux x86-macos x86-netbsd x86-openbsd x86-solaris x86-winnt"
USE_EXPAND_VALUES_ELIBC="AIX Cygwin Darwin DragonFly FreeBSD glibc HPUX Interix mintlib musl NetBSD OpenBSD SunOS uclibc Winnt"
USE_EXPAND_VALUES_KERNEL="AIX Cygwin Darwin FreeBSD freemint HPUX Interix linux NetBSD OpenBSD SunOS Winnt"
USE_EXPAND_VALUES_USERLAND="BSD GNU"
USE_ORDER="env:pkg:conf:defaults:pkginternal:repo:env.d"
USE_PYTHON="3.4 2.7"
VIDEO_CARDS="fbdev radeon r300"
WINDOWID="31457282"
WINDOWPATH="4"
XAUTHORITY="/root/.xauthRTlqDE"
XDG_CACHE_HOME="/tmp/.cache"
XDG_CONFIG_DIRS="/etc/xdg"
XDG_DATA_DIRS="/usr/local/share:/usr/share"
XSESSION="openbox"
XTABLES_ADDONS=""
_="/usr/bin/emerge"
Comment 4 Jeff Bedard 2014-07-29 03:49:03 UTC
Solution:  Changing SHELL and CONFIG_SHELL to /bin/bash fixes compilation.
Comment 5 Andreas K. Hüttel gentoo-dev 2017-02-14 22:23:08 UTC
Version not in the tree anymore