Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 495980 - app-office/libreoffice-4.1.3.2-r2 - checking for required Perl modules... Can't locate Archive/Zip.pm in @INC
Summary: app-office/libreoffice-4.1.3.2-r2 - checking for required Perl modules... Can...
Status: RESOLVED DUPLICATE of bug 41124
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-12-25 11:34 UTC by zlg (RETIRED)
Modified: 2013-12-25 15:05 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
config.log (file_495980.txt,44.33 KB, text/plain)
2013-12-25 11:36 UTC, zlg (RETIRED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description zlg (RETIRED) gentoo-dev 2013-12-25 11:34:44 UTC
During the `econf` phase of building, I get the following error:

checking for required Perl modules... Can't locate Archive/Zip.pm in @INC (@INC contains: /etc/perl /us
r/local/lib64/perl5/5.16.3/x86_64-linux /usr/local/lib64/perl5/5.16.3 /usr/lib64/perl5/vendor_perl/5.16
.3/x86_64-linux /usr/lib64/perl5/vendor_perl/5.16.3 /usr/local/lib64/perl5 /usr/lib64/perl5/vendor_perl
 /usr/lib64/perl5/5.16.3/x86_64-linux /usr/lib64/perl5/5.16.3 .) at -e line 1.
BEGIN failed--compilation aborted at -e line 1.
configure: error: Failed to find some modules

Reproducible: Always

Steps to Reproduce:
1. Try to emerge libreoffice
2. ???
3. See error.
Actual Results:  
checking for required Perl modules... Can't locate Archive/Zip.pm in @INC (@INC contains: /etc/perl /us
r/local/lib64/perl5/5.16.3/x86_64-linux /usr/local/lib64/perl5/5.16.3 /usr/lib64/perl5/vendor_perl/5.16
.3/x86_64-linux /usr/lib64/perl5/vendor_perl/5.16.3 /usr/local/lib64/perl5 /usr/lib64/perl5/vendor_perl
 /usr/lib64/perl5/5.16.3/x86_64-linux /usr/lib64/perl5/5.16.3 .) at -e line 1.
BEGIN failed--compilation aborted at -e line 1.
configure: error: Failed to find some modules

Expected Results:  
Libreoffice should've compiled.

Portage 2.2.7 (default/linux/amd64/13.0, gcc-4.7.3, glibc-2.16.0, 3.10.17-gentoo x86_64)
=================================================================
System uname: Linux-3.10.17-gentoo-x86_64-AMD_Phenom-tm-_II_X6_1090T_Processor-with-gentoo-2.2
KiB Mem:    16437640 total,  12332360 free
KiB Swap:          0 total,         0 free
Timestamp of tree: Wed, 25 Dec 2013 10:45:01 +0000
ld GNU ld (GNU Binutils) 2.23.2
app-shells/bash:          4.2_p45
dev-lang/python:          2.7.5-r3, 3.2.5-r3, 3.3.2-r2
dev-util/cmake:           2.8.11.2
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.12.4
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6, 1.12.6, 1.13.4
sys-devel/binutils:       2.23.2
sys-devel/gcc:            4.7.3-r1
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.9 (virtual/os-headers)
sys-libs/glibc:           2.16.0
Repositories: gentoo hasufell steam-overlay gamerlay sporkbox
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.5/ext-active/ /etc/php/cgi-php5.5/ext-active/ /etc/php/cli-php5.5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/var/distfiles"
EMERGE_DEFAULT_OPTS="--ask-enter-invalid"
FCFLAGS="-march=native -O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-march=native -O2 -pipe"
GENTOO_MIRRORS="http://mirror.mcs.anl.gov/pub/gentoo/ rsync://mirror.mcs.anl.gov/gentoo/ http://mirror.datapipe.net/gentoo http://www.gtlib.gatech.edu/pub/gentoo http://lug.mtu.edu/gentoo/ ftp://lug.mtu.edu/gentoo/"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j7"
PKGDIR="/var/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/var/portage"
PORTDIR_OVERLAY="/var/lib/layman/hasufell /var/lib/layman/steam /var/lib/layman/gamerlay /home/daniel/projects/g-overlay"
SYNC="rsync://rsync.us.gentoo.org/gentoo-portage"
USE="X acl alsa amd64 berkdb bzip2 cairo cli cracklib crypt cups cxx dbus dri fam ffmpeg flac fortran ftp g3dvl gdbm gpm gtk iconv ipv6 jpeg lame lua mmx modules mudflap multilib ncurses netifrc nls nptl ogg opengl openmp openrc pam pcre png python qt4 readline samba session sqlite sse sse2 ssl svg tcpd theora truetype udev unicode vdpau vorbis webm xft xinerama xpm xvmc zlib" ABI_X86="32 64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev joystick wacom" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en en_US en_GB" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" RUBY_TARGETS="ruby19 ruby18" SANE_BACKENDS="hp hp4200" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 zlg (RETIRED) gentoo-dev 2013-12-25 11:36:19 UTC
Created attachment 366170 [details]
config.log

Instructions told me to include this with my bug report, so here it is. :)
Comment 2 Rafał Mużyło 2013-12-25 11:52:13 UTC
Did you check if that's not simply a perl-cleaner case ?
Cause given DEPEND in the ebuild, it most likely is.
Comment 3 zlg (RETIRED) gentoo-dev 2013-12-25 12:46:59 UTC
(In reply to Rafał Mużyło from comment #2)
> Did you check if that's not simply a perl-cleaner case ?
> Cause given DEPEND in the ebuild, it most likely is.

I ran `perl-cleaner --all` and it's compiling now. Waiting to see how it runs once the compile's finished to make sure everything works out okay. Forgot about that tool and feel kinda stupid now. x_x;
Comment 4 Jeroen Roovers gentoo-dev 2013-12-25 15:05:18 UTC

*** This bug has been marked as a duplicate of bug 41124 ***
Comment 5 Jeroen Roovers gentoo-dev 2013-12-25 15:05:38 UTC
Comment on attachment 366170 [details]
config.log

That didn't contain anything useful.